ubi-usersetup failed with exit code 1 on preseeded - encrypted-home installations on precise

Bug #1068178 reported by Para Siva on 2012-10-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Dimitri John Ledkov
Precise
High
Unassigned

Bug Description

Precise desktop installations do not get completed using preseed and with encrypted home directory.

Oct 18 08:31:58 ubuntu ubiquity: cp:
Oct 18 08:31:58 ubuntu ubiquity: cannot stat `/target/etc/fstab'
Oct 18 08:31:58 ubuntu ubiquity: : No such file or directory

syslog is attached.

Impacting the jenkins daily job,
https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-desktop-i386_encryptedhome/395/

Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :
Para Siva (psivaa) on 2012-10-18
tags: added: iso-testing
tags: added: ubiquity-2.10.20
Changed in ubiquity (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Para Siva (psivaa) on 2012-11-09
summary: - ubuntu ubiquity: cannot stat `/target/etc/fstab' error on preseeded -
- encrypted-home installations on precise
+ ubi-usersetup failed with exit code 1 on preseeded - encrypted-home
+ installations on precise
Para Siva (psivaa) on 2012-11-09
description: updated
Para Siva (psivaa) wrote :

This causes daily failure of a couple of jenkins jobs.
The corresponding, fix-released, quantal bug is 1024343 if that would help fix it.
Thanks

Dimitri John Ledkov (xnox) wrote :

there will be secure-boot SRU upload of ubiquity into precise soon.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
Changed in ubiquity (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04.2
status: Confirmed → In Progress

Hello Parameswaran, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Dimitri John Ledkov (xnox) wrote :

As can be seen here:

https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-desktop-amd64_encryptedhome/

https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-desktop-i386_encryptedhome/

1st of December jobs consistently passed on both architectures, which previously failed to succeed due to the race described in this bug.

I hope this is enough to consider this bug as verification-done.

Para Siva (psivaa) wrote :

1st, 2nd and 3rd December preseeded installations passed on both amd64 and i386 consistently. That is 6 jobs without failures. Hence I agree that it could be marked as verification-done.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.23

---------------
ubiquity (2.10.23) precise-proposed; urgency=low

  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

ubiquity (2.10.22) precise-proposed; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab. (LP: #1024343)
    (LP: #1068178)

  [ Colin Watson ]
  * Don't remove kernel headers just because we're removing signed kernel
    images of the same flavour (LP: #1070427).

ubiquity (2.10.21) precise-proposed; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Support UEFI Secure Boot (LP: #1075181):
    - Try to install a signed kernel if base-installer asks for one, and
      don't leave signed kernels installed if it doesn't.
    - If the SecureBoot EFI variable is set, then ensure that
      grub-efi-amd64-signed and shim-signed remain installed.
    - Copy the signed kernel from /cdrom if it is not in the squashfs. If
      there is a signed kernel there but no unsigned one, then use sbattach
      to remove the signature and construct the unsigned kernel on the fly.
  * Automatic update of included source packages: base-installer
    1.122ubuntu7.2, grub-installer 1.68ubuntu5.1.

  [ Mario Limonciello ]
  * Don't let oem-config crash from an invalid server return on the timezone
    page. (LP: #887879)

  [ Dmitrijs Ledkovs ]
  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Prevent progress label to expand & shrink the window (LP: #1046241)

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967
 -- Colin Watson <email address hidden> Thu, 06 Dec 2012 17:20:32 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments