ubiquity crashes when "something else" is selected

Bug #1067566 reported by Len Ovens on 2012-10-17
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Dimitri John Ledkov
Quantal
Critical
Dimitri John Ledkov

Bug Description

Tried both manual from use whole drive and something else. Both times the something else manual partition editor comes up then the installer crashes. The something crashed icon comes up and when selected asks if I would like to file a bug I select continue and get asked to include the config file with my password in it (I haven't even got to passwords yet). Then it goes away and no bug report.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.13
ProcVersionSignature: Ubuntu 3.5.0-17.18-lowlatency 3.5.5
Uname: Linux 3.5.0-17-lowlatency i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
CasperVersion: 1.328
Date: Wed Oct 17 00:32:47 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntustudio.seed boot=casper initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Ubuntu-Studio 12.10 "Quantal Quetzal" - Release i386 (20121016.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Len Ovens (len-ovenwerks) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1067566

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

While we might have fixed usb sticks installation. Manual partitioning is now having woes.

Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: Exception in GTK frontend (invoking crash handler):
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: Traceback (most recent call last):
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 1390, in on_next_clicked
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: self.dbfilter.ok_handler()
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 3089, in ok_handler
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: self.preseed('grub-installer/bootdev', self.ui.get_grub_choice())
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 580, in get_grub_choice
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: disk_fields = disk_string.split(None, 3)
Oct 17 00:32:16 ubuntu-studio ubiquity[14369]: AttributeError: 'NoneType' object has no attribute 'split'

Changed in ubiquity (Ubuntu Quantal):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Triaged
Greg Faith (gregfaith) wrote :

Same results with crashes on "do something else" qa iso-testing Lubuntu desktop 12.10 amd64 and i386.

Scott Kitterman (kitterman) wrote :

Also failed on Kubuntu, but the proposed fix, http://paste.ubuntu.com/1284298/ produced a completed, working install.

Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in ubiquity (Ubuntu Quantal):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.14

---------------
ubiquity (2.12.14) quantal-proposed; urgency=low

  * Add extra checks when determining boot parameter for grub_default,
    which prevents crashing the installer upton entering manual
    partitioning (LP: #1067566)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 17 Oct 2012 05:29:04 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers