when /cdrom/.disk/release_notes_url is missing ubiquity shows "installer update" even if there is no update pending. Should show nothing instead.

Bug #1066302 reported by Akhila on 2012-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
High
Colin Watson
ubiquity (Ubuntu)
Medium
Dimitri John Ledkov
Quantal
Medium
Unassigned

Bug Description

Running Studio on VirtualBox. When clicked on the 'update this installer' link (which is next to 'release notes' link) on the welcome page, there wasn't any sign of loading/updating or any prompt saying the installer is up-to-date.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-17.18-lowlatency 3.5.5
Uname: Linux 3.5.0-17-lowlatency i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Sat Oct 13 19:40:00 2012
InstallCmdLine: file=/cdrom/preseed/ubuntustudio.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Ubuntu-Studio 12.10 "Quantal Quetzal" - Release i386 (20121013)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Akhila (akhilahegde) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1066302

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

That link should not be visible, as there are no updates to the installer available. I wonder how come you can see it.

Akhila (akhilahegde) wrote :

I don't know. But I can see it. Attaching the screenshot, so that you can see it as well :)

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
summary: - 'update this installer' link on the welcome page shows no response to a
- mouse click
+ /cdrom/.disk/release_notes_url missing in ubuntu-studio, results in
+ ubiquity triggering installer update
summary: - /cdrom/.disk/release_notes_url missing in ubuntu-studio, results in
+ /cdrom/.disk/release_notes_url missing in ubuntu-studio, resulting in
ubiquity triggering installer update

This is triggered by a CD image build bug. On the other hand, it's still a ubiquity bug - we should be showing different text if release_notes_url is unset.

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Triaged
Colin Watson (cjwatson) wrote :

revno: 1820
fixes bug: https://launchpad.net/bugs/1066302
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Mon 2012-10-15 14:47:08 +0100
message:
  Set release_notes_url for Ubuntu Studio.

Changed in ubuntu-cdimage:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Fix Released
summary: - /cdrom/.disk/release_notes_url missing in ubuntu-studio, resulting in
- ubiquity triggering installer update
+ when /cdrom/.disk/release_notes_url is missing ubiquity shows "installer
+ update" even if there is no update pending. Should show nothing instead.
Colin Watson (cjwatson) on 2012-10-15
Changed in ubiquity (Ubuntu Quantal):
importance: High → Medium
status: Triaged → Won't Fix
Changed in ubiquity (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Akhila (akhilahegde) wrote :

The link 'update this installer' is not visible anymore. Build 20121015.1. Screenshot attached.

Colin Watson (cjwatson) wrote :

Good, that's how it's supposed to be. (But the ubiquity task on this bug remains open, since the behaviour without .disk/release_notes_url was still incorrect.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.13.4

---------------
ubiquity (2.13.4) raring; urgency=low

  [ Colin Watson ]
  * Huge pile of minor changes to make ubiquity compatible with pep8 1.3.

  [ Dmitrijs Ledkovs ]
  * Clear "Read release notes or update the installer" if neither action
    are possible. (LP: #1066302)
  * If there is only one disk & use_device recipe is used, change next step
    button to "Install Now". (LP: #1050044)
  * When auto-partitioning is not possible, allow to manually partition
    the same drive installation medium is on. (LP: #1053030)
  * Fix the question_dialog height-for-width (LP: #862270)
  * Fonconfig-voodoo is gone, not sure if some other "fontconfig"ury
    should be called instead. (LP: #1043031)
  * Fix partman test_windows_only: if resize option is available, use_disk
    should be available as well.
  * Fix test_translated, after moving question dialog into glade from
    construction by hand.
  * Automatic update of included source packages: base-installer
    1.122ubuntu14, debian-installer-utils 1.91ubuntu6, flash-kernel
    3.0~rc.4ubuntu28.

  [ Martin Pitt ]
  * ubiquity/gtkwidgets.py: Don't use GObject.constants, just use the
    constants from GObject as intended. Fixes a crash with pygobject
    3.7.2.
  * Use glib API from the GLib GI module instead of GObject. The latter
    has been deprecated for a long time and triggers warnings with pygobject
    3.7.2.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 27 Nov 2012 11:47:01 +0000

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers