encrypt home folder needs to be checkbox not radio button

Bug #1066225 reported by Jackson Doak on 2012-10-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Scott Kitterman

Bug Description

the page in the kubuntu installer with the option to auto-login or require password to log-in has "encript my home folder" as a separate radio button instead of a checkbox like normal ubiquity. if this is not a bug it needs rewording. the radio button labelled encript my home folder needs to be replaced with a checkbox that says the same thing.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Sat Oct 13 08:14:35 2012
InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121012.3)
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1066225

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

Are you sure you meant Xubuntu? You reported it from Kubuntu?!

Note that all flavours use gtk frontend (with different themes), apart from kubuntu which uses qt frontend.

tags: added: kubuntu
Jackson Doak (noskcaj) wrote :

i did mean kubuntu sorry

description: updated
Scott Kitterman (kitterman) wrote :

It's been this way for a couple of years, so you'll need to be specific about what needs changing and why. This is not an RC bug.

Jackson Doak (noskcaj) on 2012-10-13
description: updated

What's inadequate about the current situation. It does not allow for the
choice of encrypted home, but no password. I think that's fine because I think
that's not a reasonable choice to offer.

Jackson Doak (noskcaj) wrote :

it needs rewording at least, encript my home folder is meant to be an
option on top of the require or dont require password buttons

On Sun, Oct 14, 2012 at 7:07 AM, Scott Kitterman <email address hidden>wrote:

> What's inadequate about the current situation. It does not allow for the
> choice of encrypted home, but no password. I think that's fine because I
> think
> that's not a reasonable choice to offer.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1066225
>
> Title:
> encript home folder needs to be checkbox not radio button
>
> Status in “ubiquity” package in Ubuntu:
> New
>
> Bug description:
> the page in the kubuntu installer with the option to auto-login or
> require password to log-in has "encript my home folder" as a separate
> radio button instead of a checkbox like normal ubiquity. if this is
> not a bug it needs rewording. the radio button labelled encript my
> home folder needs to be replaced with a checkbox that says the same
> thing.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: ubiquity (not installed)
> ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
> Uname: Linux 3.5.0-17-generic x86_64
> ApportVersion: 2.6.1-0ubuntu3
> Architecture: amd64
> Date: Sat Oct 13 08:14:35 2012
> InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper
> maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
> InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121012.3)
> ProcEnviron:
> LANGUAGE=en_AU:en
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_AU.UTF-8
> SHELL=/bin/bash
> SourcePackage: ubiquity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1066225/+subscriptions
>

your right scott but it is meant to be a checkbox that can be ticked only if require password is selected already

Graeme Hewson (ghewson) wrote :

In Kubuntu 12.10 Beta 2, in the User Info section, at the bottom of the panel are three radio buttons labelled "Require my password to log in", "Log in automatically" and "Encrypt my home folder".

Obviously, there's a binary choice to be made between the first two options. However, if you click the third button, it seems to be a bug that you're not able to choose either of the first two options. Indeed, I searched for this bug report because I thought there was a bug. I was focused on wanting to choose "Require my password to log in" AND "Encrypt my home folder", found I couldn't, and didn't step back and think this was working as designed.

In fact, it's not made clear (though maybe the positioning of the buttons, third under first, is an indication) that selecting "Encrypt my home folder" will also automatically "Require my password to log in". People installing in future might still think there's been a mistake.

Perhaps the text of the third button should be something like "Require my password to log in and encrypt my home folder". Maybe the buttons should be positioned in a single column, with "Log in automatically" at the top, so going from top to bottom the security increases.

summary: - encript home folder needs to be checkbox not radio button
+ encrypt home folder needs to be checkbox not radio button
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu):
status: New → In Progress
assignee: nobody → Scott Kitterman (kitterman)
milestone: none → ubuntu-13.04-alpha-2
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Rick Timmis (rick-timmis) wrote :

I've been giving this some thought:

Under nix law each user account must have a password, whether or not automatic login is enabled.

Whilst it seems illogical to Encrypt /home when automatic login takes place, there are use cases where an Encrypted /home despite Autologin makes sense, perhaps where /home is on a separate device.

To clarify perhaps creating a line of separation between "Require my password to login" - "Log in automatically", with additional text "Secure my Documents, Information and Data"

Remember, some windows users will not know what "home folder" is. I know that sounds crazy, but it's true. They think it's "My Documents". I'm pitching for the lowest common denominator here.

Finally thinking about said lowest common denominator, would it help install simplicity if the default was "Encrypted, Require Password Login" and these questions hidden behind and Advanced > section ?

all good ideas, especially the last one. either way you are making it even
better than the other *buntus. i just find calling it documents, photos
etc. a little unnessissary as kubuntu is used by near only users with
linux experience already.

Dimitri John Ledkov (xnox) wrote :

you can have user accounts without password.
ubiquity by default installs an all-in-one / single partition.
enabling ecryptfs by default is out of the scope, due to performance impact & not desired if the desktop will be further configured to use e.g. nfs mounted home directories.
assuming that kubuntu is only by users with "linux experience" is a far stretch, kubuntu can be used by people with any computer literacy levels.

The fix for this bug has been committed into ubiquity trunk and will be available for wider testing after next ubiquity upload.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.13.8

---------------
ubiquity (2.13.8) raring; urgency=low

  [ Colin Watson ]
  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

  [ Dmitrijs Ledkovs ]
  * Moving question dialog to use a glade ui file, made it non
    "re-entrant" safe, i.e. it started to remember previous action area
    buttons. The fix is to clear action area, all other parts of the
    dialog are always reset with something fresh. (LP: #1087823)
  * ubiquity-dm: compiz actually doesn't have bg-image.
  * ubi-partman: Do not allow to select encryption without lvm
    (LP: #1093957).
  * Automatic update of included source packages: debian-installer-utils
    1.94ubuntu1, flash-kernel 3.0~rc.4ubuntu29, localechooser
    2.49ubuntu1, netcfg 1.68ubuntu17, partman-auto 105ubuntu2, partman-
    auto-lvm 46ubuntu2, partman-base 163ubuntu1, partman-ext3 74ubuntu1,
    partman-jfs 38, partman-partitioning 89ubuntu1, partman-target
    80ubuntu1, preseed 1.57ubuntu2, user-setup 1.47ubuntu1.

  [ Scott Kitterman ]
  * Change encrypt home question to checkbox and indent it under the login
    option to make it clear it is a sub question to the login option
    (LP: #1066225)

  [ Jesse Sung ]
  * Fix multiple issues with Back/Stop and Continue/Connect buttons on
    wireless page (LP: #883615).
 -- Dmitrijs Ledkovs <email address hidden> Wed, 09 Jan 2013 15:40:19 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Jackson Doak (noskcaj) wrote :

That cannot count as fixed, you have simply removed that part of the install. now i can't choose if i want to auto-login or not.

Jackson Doak (noskcaj) wrote :

here is the new issue, note the lack of anything at the bottom.

Graeme Hewson (ghewson) wrote :

Comment 14 said "Change encrypt home question to checkbox and indent it under the login option to make it clear it is a sub question to the login option", but there is no question and no checkbox in the screenshot.

Scott Kitterman (kitterman) wrote :

None of which was intentional.

Jonathan Riddell (jr) wrote :

sorry missing layout in the parent widget I think, investigating..

Jonathan Riddell (jr) wrote :

should be fixed better in next upload

Jackson Doak (noskcaj) wrote :

it's fixed for 13.04, now is it possible to be fixed in time for 12.04.3?

Dimitri John Ledkov (xnox) wrote :

for the record finally fully fixed in 2.13.10, I believe.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers