ubiquity crashed with TypeError in partman_dialog(): 'NoneType' object is not subscriptable

Bug #1064151 reported by William Cronk on 2012-10-09
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Have tried multiple drives 500GB is main attempt, 250GB, and 120GB. Have tried pre-configuring partitions both Linux and Windows 7, but no matter what disk drive or configuration they do not show up as adrives available to install onto in the tool.

However, what does show in the tools as active partitions, are the two partitions of my Windows 7 drive.

Also tried SATA port position for all drives.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.5
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CasperVersion: 1.324
Date: Tue Oct 9 01:46:49 2012
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InterpreterPath: /usr/bin/python3.2mu
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120926)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3085/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with TypeError in partman_dialog(): 'NoneType' object is not subscriptable
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

William Cronk (ngc3132) wrote :
tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

Could you try booting the cd, pressing F6 and selecting nodmraid option? Thanks in advance.

This may be the same bug as bug 1062625.

information type: Private → Public
Changed in ubiquity (Ubuntu):
status: New → Incomplete
Dimitri John Ledkov (xnox) wrote :

The reason why you cannot edit the partition, is because RAID capable controller got detected and activated. You can boot with nodmraid option to work around that.

The crash, which was probably produced by double clicking on the entries, should be now fixed and that is bug 1057690.

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
Serhiy Zahoriya (xintx-ua) wrote :

Asus X502CA, nodmraid didn't change anything.
Ubiquity 2.15.26

This is critical, I cannot install using Lubuntu 13.10 LiveUSB.

Changed in ubiquity (Ubuntu):
status: Expired → Confirmed
sanfilippo (amo-niak) wrote :
Štefan Baebler (stefanba) wrote :

It happens when trying to install 14.04 LTS using multibootusb.
HP Elitebook 850 G1, 1TB HDD, 32GB Intel SRT cache.
Booting to live works ok.

14.10 doesn't boot due to other problems with syslinux.

Frederic Hutow (fhutow) wrote :

I also have this problem. I have a system using Windows 8.1 that I want to convert to Ubuntu.

No devices are listed in the "Installation Type" screen. I have tried the "nodmraid" option and still have the problem.

Booting using CD trying to install Ubuntu 14.10. Using "Test Ubuntu" loads Ubuntu correctly.

Ubuiquty 2.20.0

Computer : HP Pavilion Elite HPE

EML (dweezil) wrote :

I'm also having the same issue installing 14.04. I'm booting via USB.

Cliff (vzmith) wrote :

I also ran into this problem (Mint 17.1 64bit Mate live DVD, single core AMD 64 bit processor 4gig RAM).
nodmraid boot option did not fix it (before and after --)
nodmraid option to ubiquity did not fix it (ubiquity refused to run)

I'm not an expert on this, but there are software and hardware RAID controllers and my Windows may actually use something that is technically RAID.

Make a backup. A good habit to get into. I keep a few large USB drives for this. Move your large files (videos, ISO's, etc.) off to the backup drive and use a clonezilla live CD to back up your whole hard drive. I go a step farther after that and use gparted live CD to shrink my older OS's because they won't be used much any more and make another backup after that.

If you are not actually running a RAID setup then one work around listed elsewhere is to erase the RAID metadata. I could not find any statement that said that was always perfectly safe (I suspect that it is perfectly safe because the metadata must pass strong checksum requirements). Use this from a terminal prompt to find which of your drives have RAID on them:
  sudo dmraid -r -c

Then use this to erase dmraid metadata (replace /dev/sda with something else as needed):
  sudo dmraid -r -E /dev/sda

The previous is probably the best way for most people, but I was afraid of borking my Windows install as it was not my computer and I didn't know if it might have had software RAID in Windows.

Of course if you are simply reusing an old drive and just want to completely erase everything that is on it you can just wipe the whole thing with dd or ddrescue or dd_rescue and that will get rid of any RAID signatures.

As another option that doesn't erase the RAID metadata, I worked around the problem by starting the live DVD normally, starting a terminal and entering:
  sudo apt-get purge dmraid
then running the Linux installer without rebooting in between.

Note that this only temporarily removes dmraid from the live DVD environment. It is back again after rebooting the live DVD.

The new installed bootloader did not include my other operating systems because of the same dmraid issues, so after booting the newly installed Linux OS I had to bring up a terminal and enter these:
  sudo apt-get purge dmraid
  sudo update-grub

Also note that your grub configuration will have 'nodmraid' configured in /etc/default/grub so you won't be able to use RAID without changing that and running sudo update-grub, but most newbies don't need Linux RAID.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers