apt-install fails during success-command because target environment cannot resolve DNS

Bug #1061242 reported by Max Brustkern on 2012-10-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
UTAH
High
Dimitri John Ledkov
ubiquity (Ubuntu)
High
Unassigned

Bug Description

I'm trying to preseed an install using a quantal amd64 desktop image:
Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121002)
with md5sum 5d984d0bcf7e4f8752a7110fafca9201. apt-install commands run during the ubiquity success-command in a preseed are failing. When I open a console and chroot into /target, I don't appear to have DNS resolution.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.7
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
CasperVersion: 1.325
Date: Wed Oct 3 21:15:16 2012
InstallCmdLine: automatic-ubiquity boot=casper keyboard-configuration/layoutcode=us noprompt
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121002)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Max Brustkern (nuclearbob) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Gema Gomez (gema) on 2012-12-06
tags: added: rls-r-incoming
tags: added: iso-testing qa-daily-testing
Dimitri John Ledkov (xnox) wrote :

Looking at the logs:
https://jenkins.qa.ubuntu.com/view/Raring/view/Smoke%20Testing/job/raring-desktop-amd64-smoke-default/20/

The bug description does not much the logs.

Looking at lp:utah the code there does not much the generated late-command in the jenkins job.

Can you please clarify the source code that generates the late-command?

To fix the issue you are experiencing please try the following in the late_command:
* bind mount /run as /target/run before chroot into /target

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Changed in utah:
status: New → Triaged
importance: Undecided → High
Changed in utah:
status: Triaged → Confirmed
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in utah:
status: Confirmed → Triaged
Changed in utah:
status: Triaged → In Progress
Changed in utah:
status: In Progress → Fix Committed
Changed in utah:
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Given that this was fixed in UTAH, I'm going to assume the ubiquity task is Invalid.

Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers