ubiquity kde frontend is broken in current kubuntu daily builds

Bug #1055967 reported by Pantelis Koukousoulas
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
Critical
Jonathan Riddell
Precise
Fix Released
Critical
Unassigned
Quantal
Fix Released
Critical
Jonathan Riddell

Bug Description

How to repeat:

1) Get e.g., http://cdimage.ubuntu.com/kubuntu/precise/daily-live/20120924.1/precise-desktop-amd64.iso

2) Try to boot it in a VM (qemu/KVM or virtualbox should do fine)

3) Experience the crash

Please don't ask stacktrace etc since I can't get any (it refuses to load any debug information,
--pdb doesn't seem to work either).

A little debugging with --debug shows:
kubuntu-ubiquity(3341)/kdeui (kdelibs): Session bus not found

12.04.1 livecd works fine. The major change between that version and now was KDE
4.8.4 -> 4.8.5 and a small update in dbus-x11 (but my hunch is that the first is the culprit).

I think the problem is that KDE added a new way to (try to) access the session bus
under the hood, at a time when ubiquity doesn't expect and so is running as root,
causing the problem.

strace shows many -EAGAINs in what seems to be D-bus communication before
the crash, which seems to support this.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Can you switch to tty and run ubuntu-bug ubiquity? or at least copy /var/log/syslog and /var/log/installer/* if there are any?

tags: added: kubuntu
Changed in ubiquity (Ubuntu Quantal):
status: New → Invalid
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1055967

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
Revision history for this message
Jonathan Riddell (jr) wrote :

This occurs on today's quantal daily CD. Reported as bug 1056079

Changed in ubiquity (Ubuntu Quantal):
status: Invalid → Confirmed
Revision history for this message
Jonathan Riddell (jr) wrote :

This is caused by the recent security update to dbus

using dbus 1.6.4-1ubuntu1 packages on quantal it runs fine

Changed in ubiquity (Ubuntu Quantal):
importance: Undecided → Critical
Changed in ubiquity (Ubuntu Precise):
importance: Undecided → Critical
Jonathan Riddell (jr)
summary: - ubiquity kde frontend is broken in current kubuntu "stable" daily builds
+ ubiquity kde frontend is broken in current kubuntu daily builds
Revision history for this message
Colin Watson (cjwatson) wrote :

Jonathan has committed a fix to trunk, and I've backported it to our precise-proposed branch.

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in ubiquity (Ubuntu Precise):
status: Confirmed → In Progress
Changed in ubiquity (Ubuntu Quantal):
assignee: nobody → Jonathan Riddell (jr)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.5

---------------
ubiquity (2.12.5) quantal; urgency=low

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967

  [ Colin Watson ]
  * Partially revert r5662 (removal of more Python 2 support, from ubiquity
    2.11.33). 'from __future__ import print_function' is needed to make
    pyflakes do its job properly.
  * Remove some dead code from bin/ubiquity.
  * Improve tests/run-pyflakes to check relevant files in bin/ and tests/.
 -- Colin Watson <email address hidden> Tue, 25 Sep 2012 23:38:59 +0100

Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Released
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Pantelis, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.21 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Adam Conrad (adconrad) wrote :

Hello Pantelis, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Downloaded precise kubuntu-daily ubiquity comes up and the installation works.

Colin Watson (cjwatson)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.23

---------------
ubiquity (2.10.23) precise-proposed; urgency=low

  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

ubiquity (2.10.22) precise-proposed; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab. (LP: #1024343)
    (LP: #1068178)

  [ Colin Watson ]
  * Don't remove kernel headers just because we're removing signed kernel
    images of the same flavour (LP: #1070427).

ubiquity (2.10.21) precise-proposed; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Support UEFI Secure Boot (LP: #1075181):
    - Try to install a signed kernel if base-installer asks for one, and
      don't leave signed kernels installed if it doesn't.
    - If the SecureBoot EFI variable is set, then ensure that
      grub-efi-amd64-signed and shim-signed remain installed.
    - Copy the signed kernel from /cdrom if it is not in the squashfs. If
      there is a signed kernel there but no unsigned one, then use sbattach
      to remove the signature and construct the unsigned kernel on the fly.
  * Automatic update of included source packages: base-installer
    1.122ubuntu7.2, grub-installer 1.68ubuntu5.1.

  [ Mario Limonciello ]
  * Don't let oem-config crash from an invalid server return on the timezone
    page. (LP: #887879)

  [ Dmitrijs Ledkovs ]
  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Prevent progress label to expand & shrink the window (LP: #1046241)

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967
 -- Colin Watson <email address hidden> Thu, 06 Dec 2012 17:20:32 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers