During installation, flashplugin fails to install with: IOError: [Errno socket error] [Errno -2] Name or service not known

Bug #1055326 reported by Jean-Baptiste Lallement on 2012-09-24
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Quantal
High
Colin Watson

Bug Description

Quantal Desktop 20120920

I'm filing this bug against Ubiquity not update-notifier because it occurs only during installation, the hook works correctly after installation.

If the user selects to installation 3rd party software during installation with network fully operational, flashplugin fails to download with the following error:
 Processing triggers for update-notifier-common ...
 Traceback (most recent call last):
   File "/usr/lib/update-notifier/package-data-downloader", line 234, in process_download_requests
     dest_file = urllib.urlretrieve(files[i])[0]
   File "/usr/lib/python2.7/urllib.py", line 93, in urlretrieve
     return _urlopener.retrieve(url, filename, reporthook, data)
   File "/usr/lib/python2.7/urllib.py", line 239, in retrieve
     fp = self.open(url, data)
   File "/usr/lib/python2.7/urllib.py", line 207, in open
     return getattr(self, name)(url)
   File "/usr/lib/python2.7/urllib.py", line 344, in open_http
     h.endheaders(data)
   File "/usr/lib/python2.7/httplib.py", line 958, in endheaders
     self._send_output(message_body)
   File "/usr/lib/python2.7/httplib.py", line 818, in _send_output
     self.send(msg)
   File "/usr/lib/python2.7/httplib.py", line 780, in send
     self.connect()
   File "/usr/lib/python2.7/httplib.py", line 761, in connect
     self.timeout, self.source_address)
   File "/usr/lib/python2.7/socket.py", line 553, in create_connection
     for res in getaddrinfo(host, port, 0, SOCK_STREAM):
 IOError: [Errno socket error] [Errno -2] Name or service not known
 flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.238.orig.tar.gz

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Mon Sep 24 09:00:33 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120923)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1055326

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

I was able to recreate this bug.

Changed in ubiquity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Brian Murray (brian-murray) wrote :

Testing this after choosing 'Try Ubuntu' the flashplugin was successfully downloaded and installed so it may be releated to the ubiquity-only environment.

tags: added: rls-q-incoming
tags: removed: rls-q-incoming

I haven't independently confirmed this bug, but it seems to me that DNS resolution isn't properly working. The file referred to does exist on the URL that its supposed to.

Brian Murray (brian-murray) wrote :

Later on we see:

ubuntu ubiquity: sudo: unable to resolve host ubuntu

Colin Watson (cjwatson) wrote :

I suspect this is a missing bind-mount of /run. Testing.

Changed in ubiquity (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Colin Watson (cjwatson) on 2012-09-27
Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.6

---------------
ubiquity (2.12.6) quantal; urgency=low

  * Make the accessibility indicator menu items translatable (LP: #1040438).
    Note that this just adds the necessary infrastructure; we still need
    actual translations for this to be useful.
  * Drop dependency on realpath, not needed since hw-detect 1.89 (ubiquity
    2.11.14).
  * Bind-mount /run while installing packages in the target chroot, so that
    name resolution works (LP: #1055326).
  * Update translations from Launchpad (LP: #1056029).
  * Upgrade to Automake 1.11.6.
  * Automatic update of included source packages: debian-installer-utils
    1.91ubuntu5, flash-kernel 3.0~rc.4ubuntu26.
 -- Colin Watson <email address hidden> Fri, 28 Sep 2012 00:41:00 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers