highly confusing UI on desktop when installation media is big enough and no external storage is attached

Bug #1053030 reported by Dimitri John Ledkov on 2012-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Medium
Colin Watson
ubiquity (Ubuntu)
High
Dimitri John Ledkov
Quantal
High
Dimitri John Ledkov
Raring
High
Dimitri John Ledkov

Bug Description

When you boot desktop panda board image for installation with no external storage attached the installation UI is highly confusing.

The ask page is not shown, you are dropped into manual partitioning without warning, you get a warning about installation media being present somewhere, the finish button is sensitive, yet clicking it straight away simply crashes ubiquity and apport pops up.

Related branches

Dimitri John Ledkov (xnox) wrote :

@ Release Notes:
Please make it explicit that external storage is expected on panda-boards.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: needs-design
summary: - highly confusing UI on panda when no external storage is attached
+ highly confusing UI on desktop panda when no external storage is
+ attached
Changed in ubuntu-release-notes:
importance: Undecided → Medium
summary: - highly confusing UI on desktop panda when no external storage is
- attached
+ highly confusing UI on desktop when installation media is big enough and
+ no external storage is attached
Changed in ubiquity (Ubuntu Quantal):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Colin Watson (cjwatson) wrote :

Release-noted (feel free to modify as necessary - https://wiki.ubuntu.com/QuantalQuetzal/ReleaseNotes/CommonInfrastructure):

 * On ARM Panda boards with no external storage attached, the installer interface will be confusing and installation is likely to fail. We strongly recommend attaching an external hard disk when installing on Panda boards. (Bug:1053030)

Changed in ubuntu-release-notes:
status: New → Fix Released
assignee: nobody → Colin Watson (cjwatson)
Dimitri John Ledkov (xnox) wrote :

Thanks Colin for the release note. I did do a quick update to the installation instructions that also encourage users to use external storage. https://wiki.ubuntu.com/ARM/OmapDesktopInstall .

Marking quantal task won't fix, and queuing this up for r-series.

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Triaged
status: Triaged → Won't Fix
tags: removed: needs-design
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.13.4

---------------
ubiquity (2.13.4) raring; urgency=low

  [ Colin Watson ]
  * Huge pile of minor changes to make ubiquity compatible with pep8 1.3.

  [ Dmitrijs Ledkovs ]
  * Clear "Read release notes or update the installer" if neither action
    are possible. (LP: #1066302)
  * If there is only one disk & use_device recipe is used, change next step
    button to "Install Now". (LP: #1050044)
  * When auto-partitioning is not possible, allow to manually partition
    the same drive installation medium is on. (LP: #1053030)
  * Fix the question_dialog height-for-width (LP: #862270)
  * Fonconfig-voodoo is gone, not sure if some other "fontconfig"ury
    should be called instead. (LP: #1043031)
  * Fix partman test_windows_only: if resize option is available, use_disk
    should be available as well.
  * Fix test_translated, after moving question dialog into glade from
    construction by hand.
  * Automatic update of included source packages: base-installer
    1.122ubuntu14, debian-installer-utils 1.91ubuntu6, flash-kernel
    3.0~rc.4ubuntu28.

  [ Martin Pitt ]
  * ubiquity/gtkwidgets.py: Don't use GObject.constants, just use the
    constants from GObject as intended. Fixes a crash with pygobject
    3.7.2.
  * Use glib API from the GLib GI module instead of GObject. The latter
    has been deprecated for a long time and triggers warnings with pygobject
    3.7.2.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 27 Nov 2012 11:47:01 +0000

Changed in ubiquity (Ubuntu Raring):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers