Installing over old installation crashes installer -"/usr/share/ubiquity/plugininstall.py", line 1708, in <module>install.run()

Bug #1051400 reported by axion
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

I installed ubuntu over a previously existing system, this happened from the first alpha I tried, and every live-(daily)disk beta/alpha version afterward.

To replicate:

1 Install ubuntu on a system ( in my case I used btrfs as the filesystem, and separate home and root partitions )
2 install ubuntu on the same system, but now do not format the partitions.
2a have a nice crash.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.33
ProcVersionSignature: Ubuntu 3.5.0-14.19-generic 3.5.3
Uname: Linux 3.5.0-14-generic i686
ApportVersion: 2.5.1-0ubuntu7
Architecture: i386
CasperVersion: 1.323
Date: Sat Sep 15 22:01:16 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120915)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
axion (bugzilla-axion) wrote :
Revision history for this message
axion (bugzilla-axion) wrote :

The crash happens after the manual part of the installation. The installer text is: Creating user....

A new window opens with the following text:

Installer crashed

We're sorry, the installer crashed. After you close this window, we'll allow you to file a bug
report using the integrated bug reporting tool. This will gather information about your
system and your installation process. The details will be sent to our bug tracker and a
developer will attend to the problem as soon as possible.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

In UbiquitySyslog.txt:

Sep 15 19:59:01 ubuntu user-setup: adduser: Only one or two names allowed.
Sep 15 19:59:02 ubuntu ubiquity: chpasswd: (user ) pam_chauthtok() failed, error:
Sep 15 19:59:02 ubuntu ubiquity: Authentication token manipulation error
Sep 15 19:59:02 ubuntu ubiquity: chpasswd: (line 1, user ) password not changed
Sep 15 19:59:02 ubuntu plugininstall.py: log-output -t ubiquity umount /target/cdrom
Sep 15 19:59:02 ubuntu finish-install: Disabling CD in sources.list
Sep 15 19:59:02 ubuntu plugininstall.py: Exception during installation:
Sep 15 19:59:02 ubuntu plugininstall.py: Traceback (most recent call last):
Sep 15 19:59:02 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1708, in <module>
Sep 15 19:59:02 ubuntu plugininstall.py: install.run()
Sep 15 19:59:02 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 79, in wrapper
Sep 15 19:59:02 ubuntu plugininstall.py: func(self)
Sep 15 19:59:02 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 189, in run
Sep 15 19:59:02 ubuntu plugininstall.py: self.configure_plugins()
Sep 15 19:59:02 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 545, in configure_plugins
Sep 15 19:59:02 ubuntu plugininstall.py: "Plugin %s failed with code %s" % (plugin.NAME, ret))
Sep 15 19:59:02 ubuntu plugininstall.py: ubiquity.install_misc.InstallStepError: Plugin usersetup failed with code 1
Sep 15 19:59:02 ubuntu plugininstall.py:
Sep 15 20:01:16 ubuntu ubiquity: Gtk-Message: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

Yes, clear to see; direct on/after user creation.

Thank you for reporting, axion.

summary: Installing over old installation crashes installer
+ -"/usr/share/ubiquity/plugininstall.py", line 1708, in
+ <module>install.run()
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
axion (bugzilla-axion) wrote :

The worst thing about this bug is, the fact that the previous user info should be reused, and not a new user created. You see there was not even a user creation dialog, since I did not erase the filesystems.

Revision history for this message
axion (bugzilla-axion) wrote :

Todays daily live does the same. 16-09-2012

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Can you please provide exact steps to reproduce?
Do you simply perform Advanced Partitioning with /home & /etc re-mounted without formatting (reused)

Alternatively you could:
* start Try ubuntu
* launch terminal
* ubiquity --debug
* reproduce the bug
* attach /var/log/installer/debug to this bug report

If ubiquity is running in the debug mode, there will see more information why usersetup plugin failed.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
axion (bugzilla-axion) wrote :

I just verified in a virtual installation.
1 install a system with 3 primary partitions: 1: root(btrfs) 2: home (btrfs) 3:swap
2 reinstall on the same system using the same partitions but without formatting any of the partitions ( during this installation it should not ask for the user-name or password)

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers