12.04 LST dualboot on SSD, grub not installed right

Bug #1050444 reported by Jakub Juzl
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

I was having some problems installing Ubuntu 12.04 LST alongside Windows 7.
Installation of Ubuntu went fine, but after rebooting the system booted straight into Windows without any choice of OS. I tried the installation twice, once choosing the Install alongside Windows 7 option and once setting up the partitions myself (same result). I managed to fix the problem using Boot-Repair live CD using the automated repair option.
I have two discs:
SSD (for windows and Ubuntu)
HDD (other data)

(original discussion on ubuntuforums: http://ubuntuforums.org/showthread.php?t=2056980 )

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
Date: Thu Sep 13 16:02:41 2012
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash --
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jakub Juzl (feek-404) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
YannUbuntu (yannubuntu)
description: updated
Revision history for this message
pareshkumar brahmbhatt (paresh471) wrote :

Suggestion: please check which sata port the SSD uses. If the SSD is in a slot that is subsequent to the HDD, then the boot will be installed on HDD (sata0 or sda). You may have to select "custom" option and select the correct drive. This can all be avoided if the SSD is in sata0 port. The sata port information can be found in BIOS, and if not, then look on the motherboard for small words near the SATA port. That's my guess which I came up with only becuase I flipped through BIOS and noticed that I had the drives plugged in weird. So I did custom install, and the default selected drive was my HDD.

Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers