"install alongside" fails with uefi laptop using precise

Bug #1049919 reported by Nick Moffitt
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Expired
High
Unassigned

Bug Description

I'm not sure if this is ubiquity's bailiwick or parted or grub or whatever other sub-tool holds the logic, but I recently tried to do a dual boot install on a coworker's Lenovo e320 from a 12.04 (and later 12.04.1) USB installer drive. The install proceeded fine, but it failed to do whatever EFI/UEFI magic was needed to let Ubuntu boot. No matter how many times I went through the install, it would reboot immediately into the Windows partition afterward.

I went into the BIOS and enabled "legacy" boot, and called on the Canonical Support team's assistance. They went through the install and deleted the EFI partition during a remote-managed install, and then the system booted happily into grub.

UEFI is in the wild now, and precise at least was unprepared for this.

Tags: precise
Revision history for this message
Nick Moffitt (nick-moffitt) wrote :

(Also I just want to thank moustafa from the Canonical Support team again for helping me work around this!)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: precise
Changed in ubiquity (Ubuntu):
importance: Undecided → High
summary: - "install alongside" fails with uefi laptop
+ "install alongside" fails with uefi laptop using precise
Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers