Install fails when using a preseed file that adds a PPA using: d-i apt-setup/local0/...

Bug #1049535 reported by Christopher Lee on 2012-09-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer-utils (Ubuntu)
Medium
Colin Watson
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

I'm using a preseed file for some automated installs that setup 2 PPAs using:
    d-i apt-setup/local0/repository string deb http://ppa.launchpad.net/unity-team/staging/ubuntu quantal main
    d-i apt-setup/local0/comment string Unity-Team Staging ppa
    d-i apt-setup/local0/key string http://keyserver.ubuntu.com:11371/pks/lookup?search=0x23C9D8EB108A45A92AEDBFEE6E9205C51236960C&op=get

The error that I'm seeing in /var/log/syslog is:
    ubuntu ubiquity: /usr/lib/ubiquity/apt-setuo/generators/60local: 36 /usr/lib/ubiquity/apt-setuo/generators/60local: fetch-url: not found

Colin Watson (cjwatson) on 2012-09-12
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.32

---------------
ubiquity (2.11.32) quantal; urgency=low

  [ Jeremy Bicha ]
  * Allow specifying a manual mount point in advanced partitioner
    (LP: #1047275).

  [ Dmitrijs Ledkovs ]
  * Revert test string, to a user friendly one as it is visible in the UI.
  * Automatic update of included source packages: base-installer
    1.122ubuntu11, partman-auto-lvm 45ubuntu3, tzsetup 1:0.26ubuntu12.
  * pep8 fixes in Riddell's code

  [ Colin Watson ]
  * Remove a couple of vestiges of migration-assistant.
  * Catch OverflowError as well as ValueError from datetime functions, for
    forward-compatibility with Python 3.3.
  * Use importlib rather than __import__.
  * Install fetch-url for apt-setup's local generator (LP: #1049535).

  [ Jonathan Riddell ]
  * ubiquity/plugins/ubi-partman.py and
    ubiquity/frontend/kde_components/PartAuto.py
   - add options for LUKS and LVM automatic partitioning to KDE frontend
     (LP: #1048712)

  [ Simon Steinbeiß ]
  * Disable xfwm4's compositor in ubiquity-dm to prevent screen-corruption
    (LP: #924909)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 12 Sep 2012 22:45:51 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Christopher Lee (veebers) wrote :

I was able to test an install with the ISO this fix went into, it is still failing although in a slightly different place.

The error message is:
    ubuntu ubiquity" /bin/fetch-url: 4 .: Can't open /lib/preseed/preseed.sh

/lib/preseed doesn't appear to exist at all.

I wasn't certain if I needed to create a new bug report for this, if you need that I'm happy to do so.

Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
Colin Watson (cjwatson) on 2012-09-14
Changed in debian-installer-utils (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer-utils - 1.91ubuntu4

---------------
debian-installer-utils (1.91ubuntu4) quantal; urgency=low

  * Remove unnecessary sourcing of preseed.sh from fetch-url (LP: #1049535).
 -- Colin Watson <email address hidden> Fri, 14 Sep 2012 12:28:43 +0100

Changed in debian-installer-utils (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.33

---------------
ubiquity (2.11.33) quantal; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make Add/Remove/Change toolbar not have a background. Thanks to
    askubuntu and andrewsomething.
  * Fix TypeError in a debug statement when resize is not possible due to
    small total disk space.
  * Remove more of Python 2 support. We are not going back to the __future__.
  * Use py3compile, instead of pycompile.

  [ Stéphane Graber ]
  * Fix drop_all_privileges to also set LOGNAME which is required by firefox
    to contact an existing instance. (LP: #446679)

  [ Colin Watson ]
  * Automatic update of included source packages: debian-installer-utils
    1.91ubuntu4 (LP: #1049535), flash-kernel 3.0~rc.4ubuntu23.
 -- Colin Watson <email address hidden> Fri, 14 Sep 2012 12:40:52 +0100

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Ryan Tandy (rtandy) wrote :

I believe I'm seeing this bug (or one very similar) in precise as well. I wasn't able to find the exact bzr commit fixing this; can someone comment on whether the change might be SRUable? Should I fill out the SRU template in the description of this bug? Thanks!

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers