Ubiquity fail to launch in 12.10 powerpc

Bug #1046619 reported by 2blue
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Lubuntu Beta 1 powerpc iso (downloanded 6. September, 01:44 AM Central European Time /Paris)

I have used the Beta 1 powerpc iso of lubuntu 12.10 Quantal availabe for download September 6 (01:44 Central European Time/Paris)
System: iBook G4, 1.42GHz CPU, 512MB RAM

There is a bug with the installer. iso boots fine into live CD, but the installer will not launch properly. The installer window will launch with faint outlines of the window, but does not show anything inside the frames. Other applications seems to work fine. This is a new bug in 12.10, as it worked fine in 12.04.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1046619

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Greg Faith (gregfaith) wrote :

Same problem network manager will not start as well iso-testing

Revision history for this message
Colin Watson (cjwatson) wrote :

I can't reproduce this in qemu-system-ppc; the installer is slow (of course, since it's all being emulated) but starts up fine. Perhaps this is a window management problem?

Revision history for this message
2blue (arild-lindseth) wrote :

Hi Colin

Yes it could be related to windows management. I booted live CD ones again, and it sounds (literally!) like the installer somehow works, but hard to maneuver or check because there is nothing inside the faintly outlinded window.

Would the coarse pixeled desktop image have anything to do with launcher not showing properly? I can launch terminal with out any noticeable trouble.

Revision history for this message
2blue (arild-lindseth) wrote :

Further info

CD boots better with the line "live video=ofonly" and installer window shows fine. However Ubiquity doesn't get much further. It freezes and haults the entire live CD session. I rebooted live CD three times and installer keeps freezing up.

tags: added: quantal
Walter Lapchynski (wxl)
tags: added: powerpc
Revision history for this message
Greg Faith (gregfaith) wrote :

Tried an alternate powerpc iso installation dated 20120912 with the same results on the network manager. The window box appears but has no data and the lightly outlined box. Other apts are affected as well catfish, file archiver but some work luckily pcmanfm and lxterminal seem to work okay. I will keep this install for awhyile in case additional data might help.

Pic attached:

Revision history for this message
Ron Mitchell (rm2892) wrote :

As of today - Sept 12 2012:

The only way I can get the live disk install or the alternate install to work is to use an outdated xorg.conf file from:

http://mac.linux.be/content/xorgconf-emac-g4125-radeon-9200-debian-lenny

With that file installed as xorg.conf in /etc/X11 my eMac runs both installs quite normally.

Ron Mitchell

Revision history for this message
Ron Mitchell (rm2892) wrote :

There is another more up-to-date solution which seems to be less machine-specific.

It requires the creation of a file in /usr/share/X11/xorg.conf.d/

called 10-monitor.conf

Details are described at:
http://samuelmartin.wordpress.com/2012/05/29/enabling-resolutions-in-ubuntu-12-04-lubuntu-12-04/

It cleared up the problem here on my eMac G4

Ron Mitchell

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

ubiquity-dm already fiddles with X by creating

    /etc/X11/xorg.conf.failsafe

Maybe we should add the powerpc quirks to ubiquity-dm?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers