gtk ubiquity reminds an accordion when installing lvm in "long" locales

Bug #1046241 reported by Dimitri John Ledkov on 2012-09-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
James M. Leddy
ubiquity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

LVM installations in "long" locales make ubiquity expand & shrink during partitioning. The expander label should wrap.

Changed in ubiquity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: bitesize quantal ui
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.31

---------------
ubiquity (2.11.31) quantal; urgency=low

  [ Colin Watson ]
  * Buffer reads from debconf-copydb. Python 3 defaults to unbuffered reads
    from byte streams, which is much slower.
  * Port oem-config-remove-gtk to Python 3, now that
    python3-aptdaemon.gtk3widgets exists; the final piece!
  * Remove Python 2 support. We aren't going back now.
  * Remove the rest of the long-dead PS3 port.

  [ Dmitrijs Ledkovs ]
  * Allow going from the encryption key setup page, to the disk space
    allocation page. (LP: #1046323)
  * Correctly apply styles to the title & progress sections and not the
    centre piece. This means themes are no longer required to provide non
    standard @dark_[fb]g_color colors, instead 'menubar' Gtk CSS style is
    used. This also fixes long standing a11y issues in HighContrast themes
    & requirements for non-standard color definitions. (LP: #744283)
  * Make lables in the segmented bar use the same colours as normal labels.
  * Changing the "Add/Remove/Change Partiontion" buttons to mixed
    symbolic/text buttons should make the screen comply with Ubiquity
    Design spec ( http://goo.gl/Kokw5 ) and address confusion about the
    updated screen. (LP: #1045799)
  * Fix the disappearance of crypto password field (LP: #1045716)
  * Fix misallignment of crypto password fields (LP: #1045712)
  * Make setup security key page go back to ask page (LP: #1045698)
  * Remove powerpc/ps3 low-memory profile, as it doesn't do anything any
    more. gnome-session-remove command is no longer present, and the init
    processes it tried to stop no longer exist under those names. We do
    want a low memory profile, which ubiquity-only mode now.
  * ubiquity-wrapper: Add support for udisks2 inhibit, drop devkit-disks
    inhibit. (LP: #719338)
  * Prevent progress label to expand & shrink the window (LP: #1046241)
  * Automatic update of included source packages: base-installer
    1.122ubuntu9.

  [ Dylan McCall ]
  * Fixed slideshow_get_available_locale missing new locales in
    extra_slides_dir. (LP: #1046511)
 -- Dmitrijs Ledkovs <email address hidden> Sat, 08 Sep 2012 00:47:54 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Shih-Yuan Lee (fourdollars) wrote :

Please help to backport this fix to precise, thanks.

Changed in oem-priority:
status: New → In Progress
tags: added: rls-p-tracking
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
Colin Watson (cjwatson) on 2012-11-08
Changed in ubiquity (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
status: Triaged → In Progress
Colin Watson (cjwatson) on 2012-11-08
Changed in ubiquity (Ubuntu Precise):
milestone: none → ubuntu-12.04.2

Hello Dmitrijs, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.21 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Magoun (smagoun) on 2012-11-26
Changed in oem-priority:
importance: Undecided → Medium
Changed in oem-priority:
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Dmitrijs, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Shih-Yuan Lee (fourdollars) wrote :

I have checked ubiquity=2.10.22 from precise-proposed and it works.

tags: added: verification-done
removed: verification-needed
Kent Lin (kent-jclin) wrote :

OEM Priority Bug 1046241

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.23

---------------
ubiquity (2.10.23) precise-proposed; urgency=low

  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

ubiquity (2.10.22) precise-proposed; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab. (LP: #1024343)
    (LP: #1068178)

  [ Colin Watson ]
  * Don't remove kernel headers just because we're removing signed kernel
    images of the same flavour (LP: #1070427).

ubiquity (2.10.21) precise-proposed; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Support UEFI Secure Boot (LP: #1075181):
    - Try to install a signed kernel if base-installer asks for one, and
      don't leave signed kernels installed if it doesn't.
    - If the SecureBoot EFI variable is set, then ensure that
      grub-efi-amd64-signed and shim-signed remain installed.
    - Copy the signed kernel from /cdrom if it is not in the squashfs. If
      there is a signed kernel there but no unsigned one, then use sbattach
      to remove the signature and construct the unsigned kernel on the fly.
  * Automatic update of included source packages: base-installer
    1.122ubuntu7.2, grub-installer 1.68ubuntu5.1.

  [ Mario Limonciello ]
  * Don't let oem-config crash from an invalid server return on the timezone
    page. (LP: #887879)

  [ Dmitrijs Ledkovs ]
  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Prevent progress label to expand & shrink the window (LP: #1046241)

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967
 -- Colin Watson <email address hidden> Thu, 06 Dec 2012 17:20:32 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers