[regression] Manual partitioner only creates primary partitions

Bug #1046175 reported by Jean-Baptiste Lallement
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
High
Dimitri John Ledkov
Quantal
Fix Released
High
Dimitri John Ledkov

Bug Description

Quantal Desktop 20120904.1

There is no option to select the type of partition - primary or logical - in the manual partitioner. It limits the number of partitions to 4 on a fresh drive and the remaining free space is marked as unusable. This is a regression over Alpha 3

If a logical partition already exists, logical partitions are automatically created when the limit of 4 primary partition is reached.

The specification says [1]:
"On a disk that uses MBR, if you choose “Use for: Windows (bootable)” for a new partition, it should be created as a primary partition. Any other type of new partition should be created as a logical partition"

[1] https://docs.google.com/a/canonical.com/document/d/1bZ4yQIVgGaUGSYu3qiUHnQt3ieBZoqunP_DcleHCr3I/edit?pli=1#heading=h.60495b75f2b9

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.29
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
CasperVersion: 1.321
Date: Wed Sep 5 07:08:09 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120904.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

This screenshot show the partitioner when the limit of 4 primary partition is reached.

description: updated
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1046175

tags: added: iso-testing
Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu):
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
tags: added: rls-q-tracking
removed: iso-testing
tags: added: iso-testing
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-1
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Erick Brunzell (lbsolost) wrote :

In deed, I believe bug 1045944 should be marked as a duplicate of this bug.

I did a repeat test this AM with the most recent Lubuntu live image and there is no option to create a logical partition.

In fact using a blank 80 GB drive and creating /boot, /, /home, and swap I end up with all primary partitions.

Please see the attached screenshot.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.30

---------------
ubiquity (2.11.30) quantal; urgency=low

  * Allow to select primary/logical partitions, instead of always hiding
    it (LP: #1046175).
 -- Dmitrijs Ledkovs <email address hidden> Wed, 05 Sep 2012 12:08:34 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Fix Released
Revision history for this message
Erick Brunzell (lbsolost) wrote :

I hope this spurs a rebuild for the Beta 1 images :^)

Is there any chance of getting a fix for bug 1045799 included also? If not it should be high on the list when it comes to release notes!

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

@lbsolost
Please check images, I believe they already have been respun for those flavours that wanted to pick it up.
bug 1045799 has not been fixed and requires design changes before doing so.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers