Partitioner failed with "Failed to partition hard drive" with LVM selected

Bug #1045812 reported by Jean-Baptiste Lallement
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-auto-lvm (Ubuntu)
Fix Released
High
Dimitri John Ledkov
ubiquity (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Quantal Desktop 20120903.4

TEST CASE:
1. Boot from Quantal Desktop ISO
2. At ubiquity-dm select "French" and press "Essayer Ubuntu"
3. Let the live session start and start ubiquity
4. Proceed to partman and check "LVM"
5. Press "Continue"

Expected Result:
Installation continue

Actual Result:
This failure with the error message in attachment

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.28 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
CasperVersion: 1.321
Date: Tue Sep 4 13:08:09 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120903.4)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

The dialog basically says:
"This failure was likely caused by too many primary partitions in the partitions table"

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

From syslog:
Sep 4 13:06:35 ubuntu ubiquity[4990]: switched to page partman
Sep 4 13:06:41 ubuntu partman-lvm: Logical volume "root" successfully removed
Sep 4 13:06:41 ubuntu partman-lvm: Logical volume "swap_1" successfully removed
Sep 4 13:06:41 ubuntu partman-lvm: 0 logical volume(s) in volume group "ubuntu" now active
Sep 4 13:06:41 ubuntu partman-lvm: Volume group "ubuntu" successfully removed
Sep 4 13:06:42 ubuntu partman-lvm: Labels on physical volume "/dev/sda5" successfully wiped
Sep 4 13:06:43 ubuntu ubiquity: /var/lib/partman/devices/=dev=sda
Sep 4 13:06:44 ubuntu partman-lvm:
Sep 4 13:06:44 ubuntu partman-lvm: Writing physical volume data to disk "/dev/sda5"
Sep 4 13:06:44 ubuntu partman-lvm:
Sep 4 13:06:44 ubuntu partman-lvm: Physical volume "/dev/sda5" successfully created
Sep 4 13:06:44 ubuntu partman-lvm: Volume group "ubuntu" successfully created
Sep 4 13:06:45 ubuntu ubiquity: expr:
Sep 4 13:06:45 ubuntu ubiquity: non-integer argument
Sep 4 13:06:45 ubuntu ubiquity:
Sep 4 13:06:45 ubuntu ubiquity: /bin/perform_recipe_by_lvm: 136: [: Illegal number: 16919822,34
Sep 4 13:06:45 ubuntu partman-lvm:
Sep 4 13:06:45 ubuntu partman-lvm: Volume group "ubuntu" has insufficient free space (4034 extents): 4028254 required.
Sep 4 13:06:45 ubuntu partman-lvm:

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

I had a similar crash on another installation (same error in syslog) but the error dialog was different (see screenshot) which means:
"
No root filesystem

No root filesystem selected
Fix it from the partitioning menu
"

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Sep 4 13:06:45 ubuntu ubiquity: /bin/perform_recipe_by_lvm: 136: [: Illegal number: 16919822,34
Sep 4 13:06:45 ubuntu partman-lvm:
Sep 4 13:06:45 ubuntu partman-lvm: Volume group "ubuntu" has insufficient free space (4034 extents): 4028254 required.
Sep 4 13:06:45 ubuntu partman-lvm:

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1045812

tags: added: iso-testing
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

debug log with ubiquity -d

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Same error in Russian. The key seems to be to select the language from ubiquity-dm to start the live session in that language

Changed in partman-lvm (Ubuntu):
status: New → Triaged
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Changed in partman-lvm (Ubuntu):
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
no longer affects: partman-lvm (Ubuntu)
Changed in partman-auto-lvm (Ubuntu):
status: New → Fix Committed
status: Fix Committed → In Progress
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
tags: added: testcase
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto-lvm - 45ubuntu2

---------------
partman-auto-lvm (45ubuntu2) quantal; urgency=low

  * Set locale to "C" when calling vgs for available free space. (LP: #1045812)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 04 Sep 2012 17:07:23 +0100

Changed in partman-auto-lvm (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.29

---------------
ubiquity (2.11.29) quantal; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Update translations from Launchpad (LP: #1045695).

  [ Dmitrijs Ledkovs ]
  * Automatic update of included source packages: partman-auto-lvm
    45ubuntu2. (LP: #1045812)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 04 Sep 2012 18:48:04 +0100

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers