no contrast with Adwaita theme (as seen in the ubiquity)

Bug #1044788 reported by Jeremy Bicha on 2012-09-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-themes-standard (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

While preparing the Ubuntu GNOME remix image, I noticed that the installer is barely usable with Adwaita.

1. Install gnome-themes-standard
2. Open System Settings>Appearance and set the theme to Adwaita
3. Install ubiquity-frontend-gtk and ubiquity-ubuntu-artwork
4. Run ubiquity

This also affects the High Contrast theme when running ubiquity from installed Ubuntu; notably selecting High Contrast from a live CD doesn't really change the theme colors as expected but makes the text larger (and it's not possible to get the text back to normal but that's a different bug).

From installed Ubuntu
1. Open System Settings>Appearance and set the theme to HighContrast
2. Install ubiquity-frontend-gtk and ubiquity-ubuntu-artwork
3. Run ubiquity
4. With HighContrast, it's even worse as there is white on white text and it's not even possible to select the text to see what the text says.

I guess Ubiquity is using custom widgets/theming. Screenshots attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.26
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
Date: Sat Sep 1 14:09:48 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120827)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
Dimitri John Ledkov (xnox) wrote :

The high contrast theme bug is duplicate of bug 744283

We have a custom cairo background / highlight around the tick boxes. There is consensus to remove those.

But in the adwaita theme the buttons look odd, and ubiquity is simply using stock buttons there.

The ubiquity task is duplicate of bug 744283, the Adwaita theme bug is new as far as I know.
I am closing ubiquity task & opening adwaita theme bug.

Changed in ubiquity (Ubuntu):
status: New → Invalid
summary: - Installer is barely readable with Adwaita theme
+ stock buttons are barely readable with Adwaita theme (as seen in the
+ ubiquity)

I believe this is a ubiquity bug, not a gnome-themes-standard bug.
1. I looked in lp:~ubuntu-art-pkg/light-themes/trunk but there is no custom code there for ubiquity.
2. Ubiquity also looks terrible when run with the High Contrast theme (not just the High Contrast toggle in the live CD)
3. Adwaita looks fine with other GNOME apps like System Settings which should have a similar look and feel.

It's not just the buttons that are broken, but the text itself is barely readable. I don't know where the black background comes from.

Anyway if it is an Adwaita issue, then a bug and patch would need to be submitted to GNOME.

summary: - stock buttons are barely readable with Adwaita theme (as seen in the
- ubiquity)
+ no contrast with Adwaita theme (as seen in the ubiquity)
Dimitri John Ledkov (xnox) wrote :

Can you please confirm if Adwaita theme provides the following CSS color properties:
@dark_fg_color;
@dark_bg_color;
@fg_color;

These theme colors are used by ubiquity as can be seen in:
http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/view/head:/ubiquity/frontend/gtk_ui.py

The intended upstream design is to have Dark title bar with Light color font text, light color centre stage with dark font text, and a dark progress area with light font text (visible during installation progress).

These are standard features / colors provided by the gtk-theme engines. Please make sure Adwaita theme supports / provides sensible values there.

Dimitri John Ledkov (xnox) wrote :

Ubiquity Gtk frontend looks & works correctly in many themes as seen in: Ubuntu, Xubuntu, Lubuntu & Ubuntu Studio. Therefore I do not believe this is a bug with ubiquity, but rather a bug in the theme engine.

The background shadow around the tickboxes on the prepare page is custom theming which is/can be wrong and that part is a known bug pointed out earlier.

Dimitri John Ledkov (xnox) wrote :

Hmmm... looking more into this I see that this bug is probably duplicate of bug 880872
And that dark colors are not that wide spread.

My recommendation is to add desired dark colors to the adwaite / gnome-standard themes in the ubuntu package.

Or else please suggest patches / alternative solutions of how can we achieve intended themeble dark/light (zebra pattern) combinations of colors on a single layout.

Jeremy Bicha (jbicha) wrote :

Thanks, Dmitrijs for the pointers to the CSS properties. gnome-themes-standard doesn't use any of them. As Adwaita is the standard GTK3 theme, those can't be standard features. ;)

What I'd expect is for Ubiquity to do like gnome-control-center and use a top toolbar with the menubar style
http://git.gnome.org/browse/gnome-control-center/tree/shell/shell.ui#n15

System Settings looks a lot like Ubiquity with a dark top toolbar and a light grey background for the main content area. And it shouldn't be too hard to get white either (like is used in the Keyboard Shortcuts panel). By the way, Adwaita uses a medium gray color for the menubar style, not dark gray so don't assume that the text there should be white. I'm attaching a screenshot of what System Settings looks like for Adwaita, which is how I would expect Ubiquity to look like.

Jeremy Bicha (jbicha) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-themes-standard (Ubuntu):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

after understanding window/no-window gtk widgets (Eventboxes&Windows vs All-other-widgets), the fix was evident.

Changed in gnome-themes-standard (Ubuntu):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu):
status: Invalid → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers