[l10n][zh_CN] Indicator menus should be fully localized for installer

Bug #1037001 reported by Elsa Wang on 2012-08-15
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
High
Unassigned

Bug Description

Summary:
Install Qin precise image and during installation check installer localization, drop down menus for indicators such as input method, network connection, volume, system settings are not localized.

Steps to reproduce:
1. Install Qin precise image
2. Check localization for installer

Expected results:
Full localization.

Actual results:
All strings for drop down menus are still in English not translated to Chinese.

Elsa Wang (elsawang) wrote :
Gary Ekker (gekker) wrote :

Sebastien, this is against 12.04.1 ISO image for China. Can you verify that we have the correct ubuntu-defaults package installed and that it is pulling in the correct language packs, this should be translated at 100% for 12.04.

Sebastien Bacher (seb128) wrote :

Confirmed, the translations and on disk and used in the live session, it seems like the ubiquity panel service is not started with the right locale there...

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

15:58 < seb128> cjwatson, ev, stgraber: do you know if https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1037001 is a known issue?
15:58 < ubottu> Launchpad bug 1037001 in ubiquity (Ubuntu) "[l10n][zh_CN] Indicator menus should be fully localized for installer" [High,New]
15:58 -!- mdz_ [~<email address hidden>] has quit [Read error: Connection reset by peer]
15:58 < seb128> seems like the ubiquity panel process (in ubiquity only mode) is not running under the right locale
15:58 < seb128> the translations are there and used in live session mode
15:59 < stgraber> seb128: I don't think it's a known issue but I can certainly see what's going on
15:59 < stgraber> seb128: the problem is that the installer always starts in the default locale (english)
15:59 -!- Streamstormer [~<email address hidden>] has quit [Remote host closed the connection]
16:00 < stgraber> then it changes to whatever the language is in the preseed or chosen in the dialog
16:00 < seb128> I guess it's too late to fix for .1 now?
16:00 < stgraber> ubiquity itself updates to use the right language, but the rest of the environment can't be updated
16:00 < stgraber> I think so, because I have no idea how to solve it

Stéphane Graber (stgraber) wrote :

A potential workaround might be to set /etc/default/locale to zh_CN through ubuntu-defaults, but in either case, it's not likely to happen for 12.04.1. Targeting to 12.04.2 for now.

Changed in ubiquity (Ubuntu Precise):
milestone: none → ubuntu-12.04.2
Changed in ubiquity (Ubuntu Quantal):
status: New → Fix Committed
Changed in ubiquity (Ubuntu Precise):
status: New → In Progress

Hello Elsa, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.20 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Tested on a repacked chinese image.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.20

---------------
ubiquity (2.10.20) precise-proposed; urgency=low

  * Fix ubiquity upstart job to use /etc/default/locale as the source of
    LANG and LANGUAGE instead of /etc/environment (LP: #1037001)
 -- Stephane Graber <email address hidden> Wed, 15 Aug 2012 16:34:37 -0400

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.22

---------------
ubiquity (2.11.22) quantal; urgency=low

  [ Stéphane Graber ]
  * Fix ubiquity upstart job to use /etc/default/locale as the source of
    LANG and LANGUAGE instead of /etc/environment (LP: #1037001)

  [ Dmitrijs Ledkovs ]
  * Remove pictograms from the partAsk page
  * Make full disk encryption tickbox visible by default
  * Make the security key page layout centered and fixed
  * Automatic update of included source packages: partman-crypto
    54ubuntu1.
 -- Dmitrijs Ledkovs <email address hidden> Fri, 17 Aug 2012 10:37:21 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Elsa Wang (elsawang) wrote :

"Accessibility" still not be localized

Sebastien Bacher (seb128) wrote :

the accessibility menu is from gnome-settings-daemon I think, maybe similar issue for that process?

Stéphane Graber (stgraber) wrote :

The accessibility menu is built into ubiquity (gtk_ui.py), the strings are apparently translatable (looking at the .ui file).

As I mentioned by e-mail, please file a new bug specifically for this issue as it'll likely need a quite different fix, including get translators to translate the strings.

Elsa Wang (elsawang) wrote :

@ Stéphane, opened a new bug #1040438 to track "Accessibility" menu issue. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers