Improve graphical timezone chooser, provide choice to enter actual timezones

Bug #103583 reported by Fabián Rodríguez on 2007-04-06
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubiquity

A suggestion received at Canonical support, sent by a user, edited for language.

"I would like to provide you with a suggestion. This is not an issue with Ubuntu specifically but it is an area in which you could improve a quirk that has bugged me about Linux for ages.

Please let me enter my time zone. This whole "please select a city in your time zone and country" is counter-intuitive.

Take a look at the map. The entire central section of the USA is empty. Try to find a city in the CST time zone that is in the USA. You cannot. There isn't a SINGLE ONE.

I know I can select a city such as Mexico, but why make me search for a city that matches my time zone when I can just select the correct damn time zone?

An alternative would be a time zone selector, which would look pretty, showing all the time zone delineations and allowing you to select the one that matches. But searching for the closest applicable city is awful."

I agree this could use some improvement. I am not sure about the appropriate package though. I will also search for this upstream.

Colin Watson (cjwatson) wrote :

The reason you have to select a city is that the timezone selection is also used to select your country for locale purposes. The user is mistaken that there are no cities in US/Central in the USA - Chicago is one.

The map should have finer zoom-steps.
Many cities almost share the same pixel.
For example: Jerusalem, Amman, Gazza.

Ian (superian) wrote :

Another problem with the current installer timezone selector is that, once the map is zoomed, it can be very difficult to select the correct zone/city because of how sensitive it is to movement of the cursor. Particularly with a laptop 'nipple' or touchpad, you can find the cursor flying across the globe as you try to select a target just a few pixels across.

It's very lovely to be able to do it via a map, but there should be an option to select timezone via text drop-down as well.

I've also had problems with this in the past while using a 800x600 screen - does the graphical selector fit in smaller screen sizes?

Evan (ev) wrote :

Ian,

Your first point is bug 195159. It already is possible to select the timezone via a drop down, and ubiquity fits in a 800x600 screen on the Hardy daily Live CDs.

Thanks!

ikesterhaney (ikesterhaney) wrote :

The issue was a lack of cities in my particular region of the USA.
I know that I am in the USA/Central Timezone, yet there was no option to select the timezone directly.
Also, selecting the City from the drop down list did not reveal the timezone it was in.

My suggestion was that the drop down list should include the basic +/- GMT hours and the USA/Central options.

Changed in ubiquity:
importance: Undecided → Wishlist
status: New → Confirmed
Jan Owoc (jsowoc) wrote :

I had a problem choosing my timezone on Ubuntu 8.04 during install, but the problem is of a slightly different nature.

My timezone is Canada/Edmonton. When I move my mouse over Canada, the map zooms into Canada automatically. When I move my mouse toward Edmonton (about 500 km north of the Canada/US border), the map zooms into the US.
Eventually I noticed I didn't need to actually click on Edmonton, and if I clicked 500 km north it would still work.

As a suggestion to the graphical interface, one of the earlier versions of Ubuntu (6.04 ?, 6.10 ?) had a selector where I would first click on Canada, then could click on the city without having the map moving all over the place. I found this more user-friendly to click twice, than to have the map autoscroll.

AusIV (linux-ausiv) wrote :

I'd also like to see it easier to select an American city in the central time zone. Chicago is on the far east end of the central time zone, and it's easy to hit Indiana / Petersburg instead. Putting something like Kansas City on the list would give a solid, middle of the time-zone option that would be easy to select.

zog (zogbench) wrote :

After reading through comments and responses about this issue, and having experienced this first hand SOOO many times, it appears the best solution would be to split this city selection down into two selections, one for the country and one for the timezone.

My understanding is that the city selection is being used for both selecting country related settings, like language, and also setting the timezone.

(There should also be a check box to indicate whether daylight savings is observed or not.)

If users are unsure what timezone they are in, then having a more comprehensive list of cities would also help (although they probably have other issues to deal with...)

As a previous comment mentioned, I also live in Houston, which is the 3rd (4th?) largest city in the US, but this city is not on the list. In contrast, cities like Whitehorse in the Yukon territory are selectable (that's in Canada, btw). I used to live in Whitehorse, which only had a population of about 22k people at the time, so I am not saying it should be removed, but let's be serious...Whitehorse and NOT Houston?!?

I would be more than happy to help update the city list with more relevant city names and locations... :)

Matthew Paul Thomas (mpt) wrote :

This bug report is confusing a problem (hard to choose US/Central) with one possible solution (adding a separate time zone selector).

Adding a specific time zone field might fix the reported problem, but it could also be rather confusing. For example, it's fairly obvious that selecting something from the map changes the values in the two menus, and vice versa; but it would be more difficult to visually explain that choosing something from a third menu changes the values of the first two menus, and vice versa. And anything new in the window would reduce the amount of space available for the map itself.

A simpler solution to the initial problem would be to add one or two more longitudinally-central US/Central cities to the map.

Now that the map highlights time zones, making it navigable with the keyboard (bug 344327) would also satisfy much the same purpose as a dedicated time zone control.

zog, please report any strange choice of cities separately (as I've done in bug 344348 for example).

Michael Terry (mterry) wrote :

I'm tentatively marking this Fix Released. In Karmic, the timezone dropdown boxes are a little more intelligent.

The left box offers both a selection of countries based on your language in which you're likely to be as well as the continent list.

The right box offers (for the countries where it makes sense -- namely CA/US/MX), human-understandable timezones like Eastern, Central, Mountain as well as the previous list of city-zones. Such choices aren't reflected in map-clicks, which still use city-zones, but they are selectable through the dropbox.

I believe this hits the main point in this bug: desire to be able to select zones in US as denizens know them (Pacific, Central, etc).

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released

That sounds perfect!
Thank you for making the change.

Regards,
 Ian

On Fri, Aug 28, 2009 at 12:41 PM, Michael Terry <<email address hidden>
> wrote:

> I'm tentatively marking this Fix Released. In Karmic, the timezone
> dropdown boxes are a little more intelligent.
>
> The left box offers both a selection of countries based on your language
> in which you're likely to be as well as the continent list.
>
> The right box offers (for the countries where it makes sense -- namely
> CA/US/MX), human-understandable timezones like Eastern, Central,
> Mountain as well as the previous list of city-zones. Such choices
> aren't reflected in map-clicks, which still use city-zones, but they are
> selectable through the dropbox.
>
> I believe this hits the main point in this bug: desire to be able to
> select zones in US as denizens know them (Pacific, Central, etc).
>
> ** Changed in: ubiquity (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> Improve graphical timezone chooser, provide choice to enter actual
> timezones
> https://bugs.launchpad.net/bugs/103583
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers