ubiquity crashed with KeyError in _load_file(): 'fr'

Bug #1034960 reported by Carla Sella on 2012-08-09
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Quantal
High
Colin Watson

Bug Description

I was carrying out this test: http://iso.qa.ubuntu.com/qatracker/milestones/219/builds/20576/testcases/1302/results with this iso: http://cdimage.ubuntu.com/daily-live/20120809.1/quantal-desktop-amd64.iso on this hardware: http://wiki.ubuntu-it.org/CarlaSella/lshw.
After selecting English language in the initial screen I went on until the keyboard screen presented me with the English keyboard (as at the beginning I selected English language), but I have an Italian keyboard an so I clicked on "Detect keyboard layout" to try to detect my italian keyboard.
When I was asked to type this key: ç after that Ubiquity crashed.
I had to abort the installation and got brought to live USB key ubuntu desktop (I was installing from a live USB key to my PC).

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.19
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
CasperVersion: 1.320
Date: Thu Aug 9 17:34:04 2012
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InterpreterPath: /usr/bin/python3.2mu
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120809.1)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3289/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with KeyError in _load_file(): 'fr'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Carla Sella (carla-sella) wrote :
description: updated
description: updated
tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1034960

tags: added: iso-testing
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: ubi-console-setup
Carla Sella (carla-sella) wrote :

Also happended on this ISO: http://cdimage.ubuntu.com/daily-live/20120811.1/quantal-desktop-amd64.iso for Ubuntu Desktop amd64 install.

Same problem with http://cdimage.ubuntu.com/daily-live/20120812.1/quantal-desktop-i386.iso, happened after clicking the Next button in the screen "Where are you?" with location Brussels.

I selected Nederlands at the welcome screen.

Changed in ubiquity (Ubuntu):
importance: Medium → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) on 2012-08-13
Changed in ubiquity (Ubuntu Quantal):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Confirmed → In Progress
Colin Watson (cjwatson) on 2012-08-13
Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.20

---------------
ubiquity (2.11.20) quantal; urgency=low

  * Fix incomplete simplification of KeyboardNames._load_file
    (LP: #1034960).
  * Automatic update of included source packages: flash-kernel
    3.0~rc.4ubuntu20, partman-partitioning 87ubuntu1, preseed 1.54ubuntu1.
 -- Colin Watson <email address hidden> Mon, 13 Aug 2012 10:39:35 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers