ubiquity crashed with ValueError in command(): I/O operation on closed file.

Bug #1027648 reported by Sasa Paporovic
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
High
Dimitri John Ledkov
Precise
Fix Released
High
Dimitri John Ledkov
Quantal
Fix Released
High
Dimitri John Ledkov

Bug Description

[Test Case] See bug 792652. [I'm not sure why this wasn't marked as a duplicate originally. --cjwatson]

I use Ubuntu12.10 Qantal daily build amd64 from 22.7.2012.

This occures on a installation try from a usb stick.

To be exactly on clicking the abort button on the Install Type dialog(Whole disk, paritioning...).

This is the first time that I observe this on this daily build(some runs this day).

So, I have no reliable reproducing procedure.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.17
ProcVersionSignature: Ubuntu 3.5.0-5.5-generic 3.5.0-rc7
Uname: Linux 3.5.0-5-generic x86_64
ApportVersion: 2.4-0ubuntu4
Architecture: amd64
CasperVersion: 1.320
Date: Sun Jul 22 15:11:28 2012
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InterpreterPath: /usr/bin/python3.2mu
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120718.1)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/15722/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with ValueError in command(): I/O operation on closed file.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Revision history for this message
Sasa Paporovic (melchiaros) wrote :
visibility: private → public
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

In UbiquitySyslog.txt:

ul 22 15:11:11 ubuntu ubiquity[15722]: log-output -t ubiquity debconf-copydb configdb targetdb -p ^console-setup/ --config=Name:targetdb --config=Driver:File --config=Mode:0644 --config=Filename:/target/var/cache/debconf/config.dat
Jul 22 15:11:28 ubuntu ubiquity[15722]: Exception in GTK frontend (invoking crash handler):
Jul 22 15:11:28 ubuntu ubiquity[15722]: Traceback (most recent call last):
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 1449, in watch_debconf_fd_helper
Jul 22 15:11:28 ubuntu ubiquity[15722]: return callback(source, debconf_condition)
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 257, in process_input
Jul 22 15:11:28 ubuntu ubiquity[15722]: self.status = self.wait()
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 153, in wait
Jul 22 15:11:28 ubuntu ubiquity[15722]: self.cleanup()
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 2989, in cleanup
Jul 22 15:11:28 ubuntu ubiquity[15722]: self.preseed('grub-installer/bootdev', self.ui.get_grub_choice())
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 348, in preseed
Jul 22 15:11:28 ubuntu ubiquity[15722]: self.db.set(name, value)
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/python3/dist-packages/debconf.py", line 62, in <lambda>
Jul 22 15:11:28 ubuntu ubiquity[15722]: lambda *args, **kw: self.command(command, *args, **kw))
Jul 22 15:11:28 ubuntu ubiquity[15722]: File "/usr/lib/python3/dist-packages/debconf.py", line 66, in command
Jul 22 15:11:28 ubuntu ubiquity[15722]: self.write.write("%s %s\n" % (command, ' '.join(map(str, params))))
Jul 22 15:11:28 ubuntu ubiquity[15722]: ValueError: I/O operation on closed file.
Jul 22 15:11:28 ubuntu ubiquity[15722]:
Jul 22 15:11:44 ubuntu wpa_supplicant[2987]: wlan0: WPA: Group rekeying completed with 00:1c:28:aa:09:d7 [GTK=TKIP]

tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

I have found bug 791543 ,which lags most of usefaull information, but the stacktrace is so familiar with this here that I am pretty sure it is the same. To orientate at the bugnumber this crasher must be an old nable.

description: updated
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

Zack90 wrote in bug 986804:

I tried to install ubuntu with the live daily build of 21/04/2012, choosing how to partition the system manually. I own to my hard drive with 2 partitions windows 7 and Ubuntu 11.10 x86_64 .. this last has 4 partitions: / (ext4 journaling), / boot (ext2, without journaling), / home (ext4 journaling) and swap .. not touching anything, I just canceled the installation and the window partition crashed! and top right is another pop icon keyboard!

tags: added: oneiric
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

Sebastian Backer wrote in bug 986804 :

the title matches https://errors.ubuntu.com/bucket/?id=/usr/lib/ubiquity/bin/ubiquity:ValueError:watch_debconf_fd_helper:process_input:wait:cleanup:preseed:%3Clambda%3E:command which is one of the most reported precise issue

"Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 1391, in watch_debconf_fd_helper
    return callback(source, debconf_condition)
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 252, in process_input
    self.status = self.wait()
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 148, in wait
    self.cleanup()
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 2867, in cleanup
    self.preseed('grub-installer/bootdev', self.ui.get_grub_choice())
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 342, in preseed
    self.db.set(name, value)
  File "/usr/lib/python2.7/dist-packages/debconf.py", line 60, in <lambda>
    lambda *args, **kw: self.command(command, *args, **kw))
  File "/usr/lib/python2.7/dist-packages/debconf.py", line 64, in command
    self.write.write("%s %s\n" % (command, ' '.join(map(str, params))))
ValueError: I/O operation on closed file"

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

I have ment Sebastien Bacher in comment #6

Revision history for this message
Simon Cahill (familyguy59) wrote :

I am also experiencing this on a USB stick, but have never experienced this before.
This also only occurs, when Ubuntu fails to create the ext4 partition, and tries to exit the setup...

Revision history for this message
newbuntu nick (rose-howard-eom967yx) wrote :

trying to install 12.04 LTS 32 bit from DVD.

opted to create my own partitions with XFS. Tried to back out to previous menu. crash. repeatable, frustatingly enough.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

@ all who comes new here

It is good practice to use

"This bug affects 2 person. Does this bug affect you?"

on this side(upper left -> a little bit down)

@ all who comes new here

Steve Langasek (vorlon)
Changed in ubiquity (Ubuntu):
importance: Medium → High
Steve Langasek (vorlon)
Changed in ubiquity (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04.2
Changed in ubiquity (Ubuntu Quantal):
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.3

---------------
ubiquity (2.12.3) quantal; urgency=low

  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Automatic update of included source packages: yaboot-installer
    1.1.22ubuntu2.
 -- Dmitrijs Ledkovs <email address hidden> Mon, 24 Sep 2012 11:23:57 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in ubiquity (Ubuntu Precise):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Revision history for this message
Colin Watson (cjwatson) wrote :

I've backported Dmitrijs' fix to our precise-proposed bzr branch.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → In Progress
Revision history for this message
Kurt Zacharias (gerd-zacharias) wrote :

Installtion auf Festplatte klappt nicht

Colin Watson (cjwatson)
description: updated
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello melchiaros, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.21 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Adam Conrad (adconrad) wrote :

Hello melchiaros, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Triggering this bug is inherently racy. I have tried to trigger it back & forth myself with precise-daily image and did not manage so. Second time around, this bug was brought to our attention through crash database.

The statistics for this crash signature are here: https://errors.ubuntu.com/bucket/?id=%2Fusr%2Flib%2Fubiquity%2Fbin%2Fubiquity%3AValueError%3Awatch_debconf_fd_helper%3Aprocess_input%3Await%3Acleanup%3Apreseed%3A%3Clambda%3E%3Acommand

There are no reports for versions 2.10.21, 2.10.22 and 2.10.23 which are currently in precise-proposed testing.

Please consider this bug verified for precise SRU.

Colin Watson (cjwatson)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.23

---------------
ubiquity (2.10.23) precise-proposed; urgency=low

  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

ubiquity (2.10.22) precise-proposed; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab. (LP: #1024343)
    (LP: #1068178)

  [ Colin Watson ]
  * Don't remove kernel headers just because we're removing signed kernel
    images of the same flavour (LP: #1070427).

ubiquity (2.10.21) precise-proposed; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Support UEFI Secure Boot (LP: #1075181):
    - Try to install a signed kernel if base-installer asks for one, and
      don't leave signed kernels installed if it doesn't.
    - If the SecureBoot EFI variable is set, then ensure that
      grub-efi-amd64-signed and shim-signed remain installed.
    - Copy the signed kernel from /cdrom if it is not in the squashfs. If
      there is a signed kernel there but no unsigned one, then use sbattach
      to remove the signature and construct the unsigned kernel on the fly.
  * Automatic update of included source packages: base-installer
    1.122ubuntu7.2, grub-installer 1.68ubuntu5.1.

  [ Mario Limonciello ]
  * Don't let oem-config crash from an invalid server return on the timezone
    page. (LP: #887879)

  [ Dmitrijs Ledkovs ]
  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Prevent progress label to expand & shrink the window (LP: #1046241)

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967
 -- Colin Watson <email address hidden> Thu, 06 Dec 2012 17:20:32 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in ubiquity (Ubuntu Quantal):
status: Fix Released → In Progress
Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Released
Revision history for this message
Thomas Sisson (thomas-sisson-1) wrote :

I believe the ISO image for the Ubuntu 12.04 LTS that I had was either defective or missing the appropriate rescue options. Many people have posted that they receive the error that rescue cannot find the Linux Kernel. I know I have a Linux Kernel, because it boots. I'm trying to run Rescue because it won't boot to the desktop.

1. I booted from the Live CD.
2. I started installation from the install shortcut.
3. I chose "Choose another option" hoping that it might r.ecognize my installation and give me an option to fix it.
4. It went straight to select partions with no way to choose other options besides defining my partitions.
5. There was no Cancel optioin, so I closed the window.

For those who have this exact issue. The only suggestion is to do what I plan to do. Either I will reinstall from scratch, or I will download yet another rescue image to repair my installation.

For those who care or are interested, it quit working after I tried to install LightDM

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers