Ubiquity installs grub-efi on non-GPT disk

Bug #1026616 reported by Erwan Moreau on 2012-07-19
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

First please notice that I'm not an expert!

See the full story here:

The main problem is: when doing a fresh installation of Ubuntu 12.04 64 bits from a USB drive on a dual-boot system (with Windows 7), grub-efi is installed instead of grub-pc, which causes grub not to be installed in the MBR.

Here are some details (don't know exactly what matters and what doesn't):

- when booting on the USB drive I can see the message "error: "prefix" is not set" (but the Ubuntu menu shows normally after a few seconds)

- during the install process I selected "something else" in "installation type" in order to select a specific partition. "device for boot loader installation" changes automatically to /dev/sda after selecting the partition, as expected.

- the result of dpkg --get-selections | grep grub is
grub-common install
grub-efi install
grub-efi-amd64 install
grub-efi-amd64-bin install
grub2-common install

- after the installation I tried
sudo update-grub
sudo grub-install /dev/sda
none of of these gave any errors, but grub was still not in the MBR after that.

- the problem is fixed by simply installing grub-pc:
sudo apt-get install grub-pc

- the BootInfo output is at
(done after booting from the USB drive, selecting "try Ubuntu")

- important: as explained in the original thread http://ubuntuforums.org/showthread.php?t=2028699, I did a second install in order to reproduce the problem (first install on /dev/sda6, second on /dev/sda7). Since I had corrected the problem (from /dev/sda6), you can see grub in the MBR -> but it's not the one which should have been installed the second time (see original thread for details)

did not see how to attach two distinct files to this bug report (???), so I'm concatenating /var/log/installer/syslog and /var/log/installer/partman -> search the "#####"

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: ubiquity-2.10.16
tags: added: precise
YannUbuntu (yannubuntu) wrote :

Maybe duplicate of Bug #1013595

Vance Berry (cvberry) wrote :

I encountered this or a similar problem on an ubuntu install from a usb key on a pc with windows 7 already installed. Using the automatic dual boot configuration in the installer, the bootloader was apparently installed to the usb key, not my hard drive, and the computer could not be booted to ubuntu without using the bootloader on the usb key (which, after the install, mounted the hard drive's partition as root instead of the ubuntu install on the key itself). I was able to correctly install grub to the hard disk with the "boot-repair" utility.

Markus Klyver (markusklyver) wrote :

Any solution for this bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers