Quantal desktop encrypted home unable to install due to ubi-usersetup failing with exit code 1

Bug #1024343 reported by Gema Gomez on 2012-07-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Colin Watson
Precise
Critical
Unassigned

Bug Description

Encrypted home installs unable to finish due to ubi-usersetup failing with exit code 1. Buildnumber: 20120712.2

Unable to log in on any console to extract the log, attached image of the crash.

Log shows:
DEBUG:root:Jul 13 10:18:07 ubuntu dbus[2322]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Jul 13 10:18:07 ubuntu dbus[2322]: [system] Successfully activated service 'org.freedesktop.ColorManager'
Jul 13 10:18:07 ubuntu dbus[2322]: [system] Activating service name='org.freedesktop.colord-sane' (using servicehelper)
Jul 13 10:18:07 ubuntu dbus[2322]: [system] Successfully activated service 'org.freedesktop.colord-sane'
Jul 13 10:18:07 ubuntu NetworkManager[2696]: <info> (eth0): IP6 addrconf timed out or failed.
Jul 13 10:18:08 ubuntu NetworkManager[2696]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Jul 13 10:18:08 ubuntu NetworkManager[2696]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Jul 13 10:18:08 ubuntu NetworkManager[2696]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Jul 13 10:18:12 ubuntu ubiquity[3150]: log-output -t ubiquity laptop-detect
Jul 13 10:18:13 ubuntu ubiquity[3150]: log-output -t ubiquity fontconfig-voodoo --auto --force --quiet
DEBUG:root:Checking VM state for test case 159b755a-a651-4eee-90ec-e4d922235323
DEBUG:root:Cmd: ['virsh', 'domstate', '159b755a-a651-4eee-90ec-e4d922235323']
DEBUG:root:running
DEBUG:root:Capturing current d-i syslog for test case 159b755a-a651-4eee-90ec-e4d922235323
DEBUG:root:Jul 13 10:18:49 ubuntu ubiquity: boots. If you want to update it now, run 'setupcon' from a virtual console.
Jul 13 10:18:49 ubuntu ubiquity[3150]: log-output -t ubiquity setxkbmap -model pc105 -layout fr -variant oss -option
Jul 13 10:18:49 ubuntu ubiquity[3150]: debconffilter_done: ubi-console-setup (current: ubi-console-setup)
Jul 13 10:18:49 ubuntu ubiquity[3150]: Step_before = stepLanguage
Jul 13 10:18:49 ubuntu ubiquity: cp:
Jul 13 10:18:49 ubuntu ubiquity: cannot stat `/target/etc/fstab'
Jul 13 10:18:49 ubuntu ubiquity: : No such file or directory
Jul 13 10:18:49 ubuntu ubiquity:
Jul 13 10:18:49 ubuntu ubiquity[3150]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
Jul 13 10:18:49 ubuntu ubiquity[3150]: dbfilter_handle_status: ('ubi-usersetup', 1)

Gema Gomez (gema) wrote :

Image of the crash attached.

Gema Gomez (gema) wrote :

Screenshot of a different terminal.

tags: added: iso-testing qa-daily-testing
Changed in ubuntu:
importance: Undecided → Critical
status: New → Confirmed
tags: added: rls-q-incoming
Gema Gomez (gema) on 2012-07-13
affects: ubuntu → ubiquity (Ubuntu)
Gema Gomez (gema) on 2012-07-13
description: updated
Colin Watson (cjwatson) wrote :

This is in scripts/user-setup-encrypted-swap. I suspect that it's specific to the case where you're preseeding ubiquity, because it only happens if user-setup manages to complete before partitioning has finished.

Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Triaged
tags: added: rls-q-tracking
removed: rls-q-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.15

---------------
ubiquity (2.11.15) quantal; urgency=low

  * Drop hw-detect debugging attempts.
  * Terminate status-to-debconf subprocess in DebconfInstallProgress more
    gracefully to avoid desynchronising the debconf protocol if the
    subprocess is killed between sending a command and receiving the
    response (LP: #1023036).
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab (LP: #1024343).
  * Don't try and fail to set up encrypted swap if no swap partitions are
    configured (LP: #989279).
 -- Colin Watson <email address hidden> Sat, 14 Jul 2012 00:17:31 +0100

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released

Hello Gema, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Dimitri John Ledkov (xnox) wrote :

As can be seen here:

https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-desktop-amd64_encryptedhome/

https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-desktop-i386_encryptedhome/

1st of December jobs consistently passed on both architectures, which previously failed to succeed due to the race described in this bug.

I hope this is enough to consider this bug as verification-done.

Steve Langasek (vorlon) on 2012-12-06
tags: added: verification-done
removed: verification-needed
Changed in ubiquity (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Critical

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.23

---------------
ubiquity (2.10.23) precise-proposed; urgency=low

  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

ubiquity (2.10.22) precise-proposed; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab. (LP: #1024343)
    (LP: #1068178)

  [ Colin Watson ]
  * Don't remove kernel headers just because we're removing signed kernel
    images of the same flavour (LP: #1070427).

ubiquity (2.10.21) precise-proposed; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Support UEFI Secure Boot (LP: #1075181):
    - Try to install a signed kernel if base-installer asks for one, and
      don't leave signed kernels installed if it doesn't.
    - If the SecureBoot EFI variable is set, then ensure that
      grub-efi-amd64-signed and shim-signed remain installed.
    - Copy the signed kernel from /cdrom if it is not in the squashfs. If
      there is a signed kernel there but no unsigned one, then use sbattach
      to remove the signature and construct the unsigned kernel on the fly.
  * Automatic update of included source packages: base-installer
    1.122ubuntu7.2, grub-installer 1.68ubuntu5.1.

  [ Mario Limonciello ]
  * Don't let oem-config crash from an invalid server return on the timezone
    page. (LP: #887879)

  [ Dmitrijs Ledkovs ]
  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Prevent progress label to expand & shrink the window (LP: #1046241)

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967
 -- Colin Watson <email address hidden> Thu, 06 Dec 2012 17:20:32 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers