Ubiquity crashes in install_misc.py", line 900, in do_install : AttributeError: 'DebconfInstallProgress' object has no attribute 'finishUpdate'

Bug #1024043 reported by Brendan Donegan on 2012-07-12
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

This is a crash encountered when installing Quantal on a Dell Vostro 3350.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.12
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic x86_64
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
CasperVersion: 1.319
Date: Thu Jul 12 09:39:06 2012
InstallCmdLine: url=http://207.96.102.101/cgi-bin/preseed.cgi boot=casper initrd=initrd.lz netboot=nfs nfsroot=10.193.37.1:/srv/blackberry.canonical.com/www/rsync.cdimage.ubuntu.com/cdimage/daily-live/current/quantal-desktop-amd64 log_host=10.193.37.1 log_port=5501 automatic-ubiquity BOOT_IMAGE=vmlinuz BOOTIF=01-f0-4d-a2-c1-7d-fa
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120712.1)
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

summary: - ubiquity crashes
+ [Dell Vostro 3350] Ubiquity crashes

Jul 12 13:01:48 ubuntu plugininstall.py: Exception during installation:
Jul 12 13:01:48 ubuntu plugininstall.py: Traceback (most recent call last):
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/lib/ubiquity/ubiquity/install_misc.py", line 890, in do_install
Jul 12 13:01:48 ubuntu plugininstall.py: fetchprogress, installprogress):
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/lib/ubiquity/ubiquity/install_misc.py", line 776, in commit_with_verify
Jul 12 13:01:48 ubuntu plugininstall.py: res = cache._fetch_archives(fetcher, pm)
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/lib/python3/dist-packages/apt/cache.py", line 304, in _fetch_archives
Jul 12 13:01:48 ubuntu plugininstall.py: return self._run_fetcher(fetcher)
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/lib/python3/dist-packages/apt/cache.py", line 286, in _run_fetcher
Jul 12 13:01:48 ubuntu plugininstall.py: raise FetchFailedException(err_msg)
Jul 12 13:01:48 ubuntu plugininstall.py: apt.cache.FetchFailedException: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird-locale-en-us_14.0~b4+build1-0ubuntu1_all.deb Connection failed [IP: 91.189.91.13 80]
Jul 12 13:01:48 ubuntu plugininstall.py: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/s/scowl/wbritish_7.1-1_all.deb Could not connect to us.archive.ubuntu.com:80 (91.189.91.13). - connect (110: Connection timed out) [IP: 91.189.91.13 80]
Jul 12 13:01:48 ubuntu plugininstall.py:
Jul 12 13:01:48 ubuntu plugininstall.py:
Jul 12 13:01:48 ubuntu plugininstall.py: During handling of the above exception, another exception occurred:
Jul 12 13:01:48 ubuntu plugininstall.py:
Jul 12 13:01:48 ubuntu plugininstall.py: Traceback (most recent call last):
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1687, in <module>
Jul 12 13:01:48 ubuntu plugininstall.py: install.run()
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 56, in wrapper
Jul 12 13:01:48 ubuntu plugininstall.py: func(self)
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 174, in run
Jul 12 13:01:48 ubuntu plugininstall.py: self.install_language_packs()
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 664, in install_language_packs
Jul 12 13:01:48 ubuntu plugininstall.py: self.do_install(self.langpacks, langpacks=True)
Jul 12 13:01:48 ubuntu plugininstall.py: File "/usr/lib/ubiquity/ubiquity/install_misc.py", line 900, in do_install
Jul 12 13:01:48 ubuntu plugininstall.py: installprogress.finishUpdate()
Jul 12 13:01:48 ubuntu plugininstall.py: AttributeError: 'DebconfInstallProgress' object has no attribute 'finishUpdate'

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

According to the duplicate this crash seems to occurs when package download is interrupted. In Brendan's report download timeout, in the duplicate it was cancelled by the user.

tags: added: rls-q-tracking
tags: added: rls-q-incoming
removed: rls-q-tracking
summary: - [Dell Vostro 3350] Ubiquity crashes
+ [Dell Vostro 3350] Ubiquity crashes in install_misc.py", line 900, in
+ do_install : AttributeError: 'DebconfInstallProgress' object has no
+ attribute 'finishUpdate'
summary: - [Dell Vostro 3350] Ubiquity crashes in install_misc.py", line 900, in
- do_install : AttributeError: 'DebconfInstallProgress' object has no
- attribute 'finishUpdate'
+ Ubiquity crashes in install_misc.py", line 900, in do_install :
+ AttributeError: 'DebconfInstallProgress' object has no attribute
+ 'finishUpdate'
Colin Watson (cjwatson) on 2012-08-03
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.19

---------------
ubiquity (2.11.19) quantal; urgency=low

  [ Colin Watson ]
  * Simplify DebconfFilter.process_line slightly.
  * Simplify KeyboardNames._load_file using collections.defaultdict.
  * Call installprogress.finish_update() when a download fails or is
    cancelled, not installprogress.finishUpdate() (LP: #1024043).

  [ Dmitrijs Ledkovs ]
  * Make the UI layout test print the failed page/step name.
  * Add crypt security key setup page and move crypt/lvm checkboxes to the
    ask page.
  * Refactor password validation from ubi-usersetup into a reusable
    component (for ubi-partman).
  * Refactor set_autopartition_options method in ubi-partman.py.
  * Add crypto option to ubi-partman.
  * Add command line flag to enable crypt checkbox on the ask page.
  * Add partman-crypto to the dependencies.
  * Add translation strings for crypto.
  * Add graphviz diagram of available ask page options.
  * Automatic update of included source packages: flash-kernel
    3.0~rc.4ubuntu17, yaboot-installer 1.1.21ubuntu1.
  * Update translations.
  * Mark test_pages_fit_on_a_netbook as expected failure. See comment.
 -- Dmitrijs Ledkovs <email address hidden> Wed, 08 Aug 2012 14:34:07 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers