daily live cd boots silent in virtualbox

Bug #1016969 reported by Alan Bell on 2012-06-23
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
pulseaudio (Debian)
Fix Released
Unknown
pulseaudio (Ubuntu)
High
David Henningsson
Quantal
High
David Henningsson
ubiquity (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

in a virtualbox VM booting the quantal 64 bit daily live CD it boots to ubiquity but there are no drums and ctrl+s to start orca does not start speech (though orca starts)
clicking on try ubuntu and booting to a desktop allows me to see the pulse audio settings, the two Analog output devices don't work but the LFE devices work fine.

For users depending on Orca booting to a silent desktop is a critical issue.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic x86_64
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
Date: Sat Jun 23 21:01:48 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120421)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: Upgraded to quantal on 2012-06-21 (1 days ago)
---
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
CasperVersion: 1.318
DistroRelease: Ubuntu 12.10
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
Package: ubiquity 2.11.7
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
Tags: quantal running-unity ubiquity-2.11.7
Uname: Linux 3.5.0-2-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Alan Bell (alanbell) wrote :
Alan Bell (alanbell) wrote :

screenshot showing pulse audio output devices, top two work with the test sound dialog, bottom two don't.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1016969

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

What release is the host operating system?

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Alan Bell (alanbell) wrote :

the host is also Quantal, but upgraded from Precise. Others have reproduced with Precise as the host I think. I am using the Oracle Virtualbox 4.1.18. I will try alpha2 on real hardware.

Alan Bell (alanbell) wrote :

output of alsa-info.sh

tags: added: apport-collected ubiquity-2.11.7
description: updated

apport information

apport information

apport information

apport information

pvagner (peter-v) wrote :

I am running virtualbox on ubuntu 12.04 and I cant hear sound in guest quantal as well.

Alan Bell (alanbell) wrote :

the layout of the pulse audio settings screen has changed a bit now, they are not presenting as separate devices but connectors on the analog output device. Same basic problem though, it boots silent. You also can't get to the indicators using the keyboard to fix it without a mouse so blind users would require sighted assistance.

Joanmarie (joanmarie-diggs) wrote :

I stumbled across this problem via Google. Fedora 17 host, Fedora 18 guest, and -- you guessed it -- VirtualBox. And the symptoms are the same. I had no audio for the users until I switched those from the default to the LFE.

On the bright side for you, it does not seem to a downstream bug. ;) Sadly, so far, it's not clear to me whose bug it is.

Joanmarie (joanmarie-diggs) wrote :

Annnnd, thanks to the googlespheres: the answer. (At least it solved my problem in Fedora.)
https://launchpad.net/debian/experimental/+source/pulseaudio/2.1-1

<quote>
* debian/patches/remove-analog-mono.patch:
    - Added. Remove analog-output-lfe-on-mono mixer path, although in principle
      Ac '97 hardware has a seperate mono LFE pin nothing seems to use it. To
      make matters worse it does confused pulseaudios port selection slightly
      which causes audio in virtualbox not to work out of the box
      (Closes: #673847)
</quote>

Changed in pulseaudio (Ubuntu):
importance: Undecided → High
Changed in pulseaudio (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Changed in pulseaudio (Ubuntu Quantal):
assignee: nobody → David Henningsson (diwic)
status: New → In Progress
Changed in pulseaudio (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:2.1-0ubuntu4

---------------
pulseaudio (1:2.1-0ubuntu4) quantal-proposed; urgency=low

  * 0101-alsa-mixer-Remove-analog-output-lfe-on-mono.patch:
    Fix muted audio on startup in Virtualbox VM (LP: #1016969)
  * 0020-stream-Return-error-in-case-a-client-peeks-to-early.patch:
    Fix clients crashing when asking for data, but there is no data
    to hand out (LP: #1058200)
 -- David Henningsson <email address hidden> Thu, 04 Oct 2012 14:43:27 +0200

Changed in pulseaudio (Ubuntu Quantal):
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/1016969

tags: added: laptop-testing
Dimitri John Ledkov (xnox) wrote :

verified with ubuntu amd64 20121009

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.