Ubiquity displays scrollbars inside of slideshow

Bug #1008717 reported by Nicholas Skaggs
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Invalid
Medium
Unassigned
Quantal
Invalid
Medium
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
Invalid
Undecided
Unassigned
Quantal
Invalid
Undecided
Unassigned

Bug Description

Scrollbars are present during installtion when looking at slideshow. See attached screenshot

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic i686
ApportVersion: 2.1.1-0ubuntu2
Architecture: i386
Date: Mon Jun 4 16:25:00 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120604.2)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Nicholas Skaggs (nskaggs) wrote :
Revision history for this message
Nicholas Skaggs (nskaggs) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1008717

tags: added: iso-testing
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Did you attach the right screenshot ?
I don't see any scrollbar on the one attached to this report.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Here is a screenshot showing the problem. This occurred during the end user configuration of an OEM installation.
Screenshot is in French but the problem is exactly the same in English.

tags: added: qa-manual-testing
Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
tags: added: rls-mgr-q-tracking
Revision history for this message
Nicholas Skaggs (nskaggs) wrote :

Here's another screenshot -- sorry my original was botched :-)

Revision history for this message
Jackson Doak (noskcaj) wrote :

in xubuntu the scroll bars are only necessary because of themselves i.e. you only have to scroll through space that is covered by scroll bars. is this a separate bug or a part of this one?

tags: removed: rls-mgr-q-tracking
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Adding light-themes task for triange.

We are running ubiquity-only mode in special mode (well metacity without compiz/llvmpipe). Some other ~ similar bug reports on the internet (e.g. firefox) with 1px wide scrollbars indicate that this is potentially a theming issue: just-fit contents requires scrollbars, when the scrollbars have a 1px wide border.

Also note that we are getting "fat" gtk scrollbars instead of overlay scrollbars. Do overlay scrollbars require 3D-accel / compositing?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Can anyone please try to reproduce this bug with images from 20120924 onwards?
If you can please:
- specify image details: full name & buildstamp/date
- take a screenshot & attach it here

Changed in light-themes (Ubuntu Quantal):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu Quantal):
status: Triaged → Incomplete
Revision history for this message
Nicholas Skaggs (nskaggs) wrote :

I have not seen this recently.. But I can re-try to make it happen :-)

Revision history for this message
Carla Sella (carla-sella) wrote :

I used to have this problem when installing Ubuntu on a Panda board, it has not been happening anymore for some time now.

affects: light-themes (Ubuntu Quantal) → ubiquity-slideshow-ubuntu (Ubuntu Quantal)
Changed in ubiquity-slideshow-ubuntu (Ubuntu Quantal):
status: Invalid → New
Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: [Bug 1008717] Re: Ubiquity displays scrollbars inside of slideshow

On 28 September 2012 21:36, Adolfo Jayme Barrientos
<email address hidden> wrote:
> ** Package changed: light-themes (Ubuntu Quantal) => ubiquity-slideshow-
> ubuntu (Ubuntu Quantal)
>
> ** Changed in: ubiquity-slideshow-ubuntu (Ubuntu Quantal)
> Status: Invalid => New
>

Did you manage to reproduce this problem?
Do you have screenshots and logs?

Revision history for this message
Dylan McCall (dylanmccall) wrote :

A recent screenshot would be nice to see. This bug loves to pop up unexpectedly, but I could have sworn it went away with Precise. (At any rate, overlay scrollbars should solve this on their own, so I'm curious that they aren't here).

Did you happen to open and close the Details pane? I have only seen it change the window height so the slideshow stays as it is, but maybe something odd happened.

I can add overflow:hidden to the body element in the slideshow and that should handle its part in this. I'm worried it could cause something unexpected, though, since Webkit is a fickle beast and I'm not sure how the the webview's resizing works right now. Okay if I make that change early on for Ubuntu R?

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

On 28 September 2012 22:55, Dylan McCall <email address hidden> wrote:
> A recent screenshot would be nice to see. This bug loves to pop up
> unexpectedly, but I could have sworn it went away with Precise. (At any
> rate, overlay scrollbars should solve this on their own, so I'm curious
> that they aren't here).
>
> Did you happen to open and close the Details pane? I have only seen it
> change the window height so the slideshow stays as it is, but maybe
> something odd happened.
>
> I can add overflow:hidden to the body element in the slideshow and that
> should handle its part in this. I'm worried it could cause something
> unexpected, though, since Webkit is a fickle beast and I'm not sure how
> the the webview's resizing works right now. Okay if I make that change
> early on for Ubuntu R?
>

Huh?!

The scrollbars were broken in the ubiquity-only mode vs
desktop-session, which I have now fixed. After I did that fix I've
asked to retest for this bug, because the available screenshots of the
bug were: from ubiquity-only mode & ubuntu flavour only.

The reason they were broken is because they moved from being an
automatic LD_PRELOAD to become a proper gtk module and hence required
changes to ubiquity-dm.

I didn't want to spell out this over here, because we never found out
the root cause for this bug, hence the speculation that changes in the
scrollbars were causing this.

Changed in ubiquity-slideshow-ubuntu (Ubuntu Quantal):
status: New → Invalid
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

At any rate, the webkit webview & the scrollablewindow port & the whole ubiquity-only session is all code in the ubiquity and not in the slideshows.

Changed in ubiquity (Ubuntu Quantal):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers