Ubuquity quits after entering user info -> continue

Bug #1008661 reported by arpanaut on 2012-06-04
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Canonical Foundations Team
Quantal
High
Canonical Foundations Team

Bug Description

Jun 4 17:34:35 ubuntu ubiquity: Traceback (most recent call last):
Jun 4 17:34:35 ubuntu ubiquity: File "/usr/share/ubiquity/plugininstall.py", line 1685, in <module>
Jun 4 17:34:35 ubuntu ubiquity: install = Install()
Jun 4 17:34:35 ubuntu ubiquity: File "/usr/share/ubiquity/plugininstall.py", line 101, in __init__
Jun 4 17:34:35 ubuntu ubiquity: if self.db.get('base-installer/install-recommends') == 'false':
Jun 4 17:34:35 ubuntu ubiquity: File "/usr/lib/python3/dist-packages/debconf.py", line 62, in <lambda>
Jun 4 17:34:35 ubuntu ubiquity: lambda *args, **kw: self.command(command, *args, **kw))
Jun 4 17:34:35 ubuntu ubiquity: File "/usr/lib/python3/dist-packages/debconf.py", line 67, in command
Jun 4 17:34:35 ubuntu ubiquity: self.write.flush()
Jun 4 17:34:35 ubuntu ubiquity: IOError: [Errno 32] Broken pipe

Installing from USB flash drive, used dd method for copy to usb.
Installation works up to entering user info and continuing from there.
Copying files to "Target" has completed, Slideshow begins, UI crashes.

apport does not catch this crash, cursor turns to "spinner"
Live Session continues to work just fine, can restart ubiquity
It crashes at same point, or very nearly same point.
Start ubiquity from terminal same behavior, no feedback when UI quits.

I have been having this problem since Nov. 2011 with Live-CD
Reproducable ad infinitum on my hardware. dozens of tries.
Only avenue of install for me is Alternate-CD.

ProblemType: BugDistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.4
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic i686
ApportVersion: 2.1.1-0ubuntu2
Architecture: i386
CasperVersion: 1.317
Date: Mon Jun 4 14:17:47 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquityLiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120604.2)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

arpanaut (johnmac) wrote :
arpanaut (johnmac) on 2012-06-04
tags: added: also qa-quantal-iso.
tags: removed: also
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1008661

tags: added: iso-testing
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Dale Beaudoin (twocamels) wrote :

yep .. exact same thing here with this alpha1 qq release. Never encountered htis problem until now. Preivious alpha releases did not have this problem.

sojourner (itsmealso2) wrote :

same here but hangs at the second installer window , don't even get to user info . happened with live cds from jun 3,4,5 . whether from usb stick or dvd . many other problems with ubiquity also for instance it sees hard drives in my sys as being mounted which definitely are not and have not been since booting the live session and do not show as being mounted .

Changed in ubiquity (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: rls-q-incoming
arpanaut (johnmac) wrote :

Tried to install June 6 daily-live i-386. Failed again at same point .

Additional info: Ubiquity 2.11.5
Debug: ** (ubiquity:4455): WARNING **: The connection is closed

(ubiquity:4455): Pango-WARNING **: error opening config file '/root/.pangorc': Permission denied

Error opening file for reading: Permission denied
update_release_notes_label()
update_release_notes_label()
Error opening file for reading: Permission denied

End of syslog:
Jun 7 01:51:46 ubuntu ubiquity[4455]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
Jun 7 01:51:46 ubuntu ubiquity[4455]: Step_before = stepUserInfo
Jun 7 01:51:52 ubuntu ubiquity: Traceback (most recent call last):
Jun 7 01:51:52 ubuntu ubiquity: File "/usr/share/ubiquity/plugininstall.py", line 1685, in <module>
Jun 7 01:51:52 ubuntu ubiquity: install = Install()
Jun 7 01:51:52 ubuntu ubiquity: File "/usr/share/ubiquity/plugininstall.py", line 101, in __init__
Jun 7 01:51:52 ubuntu ubiquity: if self.db.get('base-installer/install-recommends') == 'false':
Jun 7 01:51:52 ubuntu ubiquity: File "/usr/lib/python3/dist-packages/debconf.py", line 62, in <lambda>
Jun 7 01:51:52 ubuntu ubiquity: lambda *args, **kw: self.command(command, *args, **kw))
Jun 7 01:51:52 ubuntu ubiquity: File "/usr/lib/python3/dist-packages/debconf.py", line 67, in command
Jun 7 01:51:52 ubuntu ubiquity: self.write.flush()
Jun 7 01:51:52 ubuntu ubiquity: IOError: [Errno 32] Broken pipe
Jun 7 01:51:52 ubuntu kernel: [ 1048.547328] BUG: Bad rss-counter state mm:efa57c40 idx:1 val:-2
Jun 7 01:51:52 ubuntu kernel: [ 1048.547334] BUG: Bad rss-counter state mm:efa57c40 idx:2 val:2

tags: removed: rls-q-incoming
Mauricio (darthsteel) wrote :

Ubiquity crash on try install Kubuntu 64bits quantal 12.10 daily 07-19-2012

Mauricio (darthsteel) wrote :
Mauricio (darthsteel) wrote :
Mauricio (darthsteel) wrote :
arpanaut (johnmac) wrote :

As of release of Alpha3 iso this seems to be resolved.
At least on my i386 hardware. I had been removing
ubiquity-slideshow-ubuntu from the live session resulting
in successful installs.

It appears that the recent changes in ubiquity have been
successful in resolving this issue. Thank You!

Steve Langasek (vorlon) wrote :

Thanks for the info, marking as resolved.

Cristian, if you're still seeing this, feel free to reopen the bug report.

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Fix Released
Mauricio (darthsteel) wrote :

Kubuntu Alpha 3 now install successful :)

Dallman Ross (spamless) wrote :

This bug either was never actually fixed or has returned. I have had it hit me several times on several machines trying to install Xubuntu 13.04 final and the beta2 before that. I am typing this now from a Live "CD" where the install just failed. This is an older HP/Dell 32-bit Intel machine and has three installations of Ubuntu on it already: Precise, Quantal, and Raring. (I decided to re-install Raring from scratch because I am having some unrelated problems. But so far, I can't install it.)

I think the problem is when one boots from an ISO mounted on the same device as the one intended for installation. E.g., I booted the ISO from grub, and it's stored on /dev/sda6 (so /dev/sda is mounted), but I want to install to free space at what will be /dev/sda8. No-go.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers