ubiquity installer lists my networking chipset as a wireless network and wants me to connect to it

Bug #1006179 reported by Matt Fischer on 2012-05-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned

Bug Description

When installing Precise 12.04, with ubiquity 2.10.16, the "Wireless" screen lists my wifi chipset (Broadcom BCM 4312) as a wireless network and prompts me to login to it. I entered my wifi password expecting it to then lists networks, but nothing happened. See attached screenshot.

I am installing from a USB stick onto an HP Mini 110.

Matt Fischer (mfisch) wrote :
Matt Fischer (mfisch) wrote :

Note, I cannot reproduce this in Quantal, using ubiquity 2.11.3, in that version I do not get a Wireless screen at all.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't start working on it yet, because your description didn't include enough information.

Please execute the following command 'ubuntu-bug ubiquity' as it will gather detailed information regarding your installation. Thanks in advance.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Matt Fischer (mfisch) wrote :

Can I run that from the middle of an install?

Matt Fischer (mfisch) wrote :

I just realized too that I have no networking active on this during the install. If I plug in wired networking then I won't get this box prompting me for wireless, and the image doesn't support my drivers anyway (which is likely the cause of this). I usually have to add the drivers later with jockey. Without networking will running ubuntu-bug be useful?

Matt Fischer (mfisch) wrote :

Gathered info with apport-cli --save=foo ubiquity attached below.

Changed in ubiquity (Ubuntu):
status: Incomplete → New
Brian Murray (brian-murray) wrote :

Here is something in ubiquity's syslog:

 Feb 14 00:31:49 ubuntu kernel: [ 74.375683] b43-phy0 ERROR: Firmware file "b43/ucode15.fw" not found
 Feb 14 00:31:49 ubuntu kernel: [ 74.375697] b43-phy0 ERROR: Firmware file "b43-open/ucode15.fw" not found
 Feb 14 00:31:49 ubuntu kernel: [ 74.375707] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
 Feb 14 00:31:49 ubuntu NetworkManager[2545]: <warn> (wlan0): firmware may be missing.
 Feb 14 00:31:49 ubuntu NetworkManager[2545]: <info> (wlan0): deactivating device (reason 'managed') [2]
 Feb 14 00:31:49 ubuntu kernel: [ 74.389195] ADDRCONF(NETDEV_UP): wlan0: link is not ready

ubiquity shouldn't be listing this as a network.

Matt Fischer (mfisch) wrote :

Full syslog

Matt Fischer (mfisch) wrote :

/var/log/installer/debug

tags: added: ubi-netwok
tags: added: precise
Changed in ubiquity (Ubuntu):
status: New → Triaged
Tom Reynolds (tomreyn) wrote :

This issue still affects 18.04.1. As soon as you try to install with an unsupported wireless chipset, the chipset name is listed as a wireless network to connect to (and attempting to connect to it obviously fails, though without message).

What should instead happen is that a message is displayed indicating that this wireless chipset is not (or may not be) supported. The system I tried this on is a GPD Pocket (v1) which comes with a Broadcom 4356 802.11ac chipset. Wired network was not available at the time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers