Ubiquity slideshow is crammed with Traditional Chinese

Bug #712101 reported by Patrick Wright on 2011-02-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

In order fully display the next button arrow ">" the display area must be scrolled. I have not seen this with other languages during the install.

Description: Ubuntu natty (development branch)
Release: 11.04

N: 未发现软件包 pkgname

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Thu Feb 3 04:11:07 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 LANGUAGE=zh_CN:zh:en_GB:en
 PATH=(custom, no user)
 LANG=zh_CN.UTF-8
 LC_MESSAGES=zh_CN.utf8
 SHELL=/bin/bash
SourcePackage: ubiquity

Patrick Wright (patrickmwright) wrote :
tags: added: iso-testing
Milo Casagrande (milo) wrote :

Assigning to the Ubuntu Chinese Translators so that they can take a look at it.

Changed in ubuntu-translations:
assignee: nobody → Ubuntu Simplified Chinese Translators (ubuntu-l10n-zh-cn)
Aron Xu (happyaron) wrote :

Hello Patrick, could you attach some screeshots to illustrate the problem?

affects: ubiquity (Ubuntu Natty) → ubiquity-slideshow-ubuntu (Ubuntu Natty)
Dylan McCall (dylanmccall) wrote :

Oh, that is interesting. I can't find anything with this locale running in the tester or in my browser pointing at http://people.ubuntu.com/~dylanmccall/ubiquity-slideshow-ubuntu/preview/ubuntu/slides/index.html#?locale=zh_CN

Is it possible this is something happening in Ubiquity? Perhaps a label that expects to be longer than it is with zh_CN, changing the layout somehow…

tags: added: qa
Dylan McCall (dylanmccall) wrote :

Is anyone able to reproduce this consistently in the installer? I think it is related to another bug that pops up from time to time, where the slideshow just isn't being given enough space.

Patrick Wright (patrickmwright) wrote :

See attached for the visual defect. Dylan is correct.

Something to note: this only occurs when select the Install Ubuntu button when Ubiquity first starts. The glitch does not occur when running the installer in Live mode.

Changed in ubuntu-translations:
assignee: Ubuntu Simplified Chinese Translators (ubuntu-l10n-zh-cn) → Patrick Wright (patrickmwright)
affects: ubuntu-translations → ubiquity-slideshow-ubuntu
Patrick Wright (patrickmwright) wrote :

Hi Dylan,
Do you happen to recall the bug you mentioned in comment 5? If its a dup I'd like to mark it as such. Otherwise, I'd like to get see about getting this bug triaged.
Thanks!

Changed in ubiquity-slideshow-ubuntu:
assignee: Patrick Wright (patrickmwright) → nobody
Dylan McCall (dylanmccall) wrote :

Now that you mention it, I don't think this is filed anywhere. I'll add Ubiquity to this, then :)

Changed in ubiquity-slideshow-ubuntu:
status: New → Won't Fix
status: Won't Fix → Invalid
Changed in ubiquity-slideshow-ubuntu (Ubuntu Natty):
status: New → Invalid
Dylan McCall (dylanmccall) wrote :

Oh, I know what this is! In Patrick's screenshot, Ubiquity is the correct size. This problem comes from the fact that scrollbars take up space, inviting more scrollbars. (From which emerges an evil chicken & egg conundrum).

If a window starts off too small, the vertical scroll bar appears. Because the vertical scroll bar takes up space, the horizontal scroll bar appears. Now the actual content area is a lot smaller, so even if you bring the window up to the correct size the scrollbars will be present. For the scrollbars to go away, you need to make the window bigger than it needed to be at first, then you can shrink it again.
I bump into it a lot doing web design :)

With Ubuntu, we're going to have those fancy new overlay scrollbars that don't take up space, so I bet this problem will magically go away there, but we'll still have this occur for other distributions that use Ubiquity.

This could still be a Ubiquity thing, but now I understand the problem better I am reopening for the slideshow. I can't think of any case where content would extend past the bottom of the page (and overflow:hidden in the slideshow container should deal with that), but I could be missing something…

Changed in ubiquity-slideshow-ubuntu:
status: Invalid → Triaged
assignee: nobody → Dylan McCall (dylanmccall)
importance: Undecided → Medium
milestone: none → natty-b1
Changed in ubiquity (Ubuntu Natty):
status: New → Triaged
importance: Undecided → Medium
Evan (ev) wrote :

ubiquity sets the size_request for the webkit view to be exactly what's specified in slideshow.conf, so I suspect something in the slideshow is causing it to grow beyond that size.

Changed in ubiquity (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Evan (ev) wrote :

I've committed a workaround to ubiquity for natty to deal with the scrollbars by never showing them.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Invalid → Confirmed
Changed in ubiquity-slideshow-ubuntu (Ubuntu Natty):
status: Invalid → Confirmed
Colin Watson (cjwatson) wrote :

Guillem, why did you reopen the ubiquity-slideshow-ubuntu tasks? They were closed because this is a ubiquity problem, not a problem with the slideshow data. If you disagree, please provide reasoning.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Invalid
Changed in ubiquity-slideshow-ubuntu (Ubuntu Natty):
status: Confirmed → Invalid
Colin Watson (cjwatson) on 2011-06-14
Changed in ubiquity (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
Changed in ubiquity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
tags: added: ubiquity-2.5.14
Evan (ev) on 2012-03-15
Changed in ubiquity (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Changed in ubiquity (Ubuntu Natty):
assignee: Evan Dandrea (ev) → nobody
no longer affects: ubiquity-slideshow-ubuntu
dino99 (9d9) wrote :

outdated report, no activity

Changed in ubiquity (Ubuntu Natty):
status: Triaged → Invalid
Changed in ubiquity (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers