Some ubiquity slideshow titles go (smaller) to a new line

Bug #628159 reported by Sergio Zanchetta on 2010-09-01
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubiquity

Maverick Beta 20100901.1 Virtualbox install.

During the installation, Some ubiquity slideshow titles goes (smaller) to a new line in some languages.

An example in attachment.

The same problem is present in Lucid.

A preview of this for a lot of languages can be found here:
http://l10n.ubuntu.tla.ro/ubuntu-lucid-slideshow/ubuntu/slides/index.html#?controls?locale=it

tags: added: iso-testing
summary: - Some ubiquity slideshow titles goes (smaller) to a new line
+ Some ubiquity slideshow titles go (smaller) to a new line
Colin Watson (cjwatson) on 2010-09-02
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Evan (ev) on 2010-09-02
affects: ubiquity (Ubuntu) → ubiquity-slideshow-ubuntu (Ubuntu)
Dylan McCall (dylanmccall) wrote :

Yep, that's by design. The text shrinks because we don't want it filling more lines (and it looks kind of ugly to have big text over many lines).

This is happening with the new design as well, though to a lesser extent because the titles have more horizontal space. The second line is squeezed a little closer to the first line, too.
You can preview that here: http://people.ubuntu.com/~dylanmccall/ubiquity-slideshow-ubuntu/preview-maverick/

For the time being, we can't do much about the offending strings; the slideshow you see is for Lucid. We can definitely work on this for Maverick if it's important. Probably the best way is to leave a note with the respective translation teams to let them know when their strings are a bit too long. They may be able to shorten them.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Opinion
Sergio Zanchetta (primes2h) wrote :

Sorry, but it's not an opinion.
in a lot of cases you "can't" shorten sentences, by language design.

In Lucid I assure you we (italian translation team) tried to do that as much as possible.

As you can see in the screenshot (taken from a 'Maverick' Virtualbox installation) the issue is present in Maverick too.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Opinion → New
Dylan McCall (dylanmccall) wrote :

So, to me, having a title wrap over two lines seems okay. It isn't optimal, but it feels sane and it's an intentionally controlled behaviour that was tested for.
I'm honestly curious and would love to know: Is my feeling there perhaps something specific to English? Do different locales have different preferences that we could address somehow?

Really, beyond wrapping over two lines, there are two options I can see right now from my end: make the title font smaller so that even the biggest title will fit, or make the whole thing wider. The second option is happening in the upcoming Maverick design (the one I linked to, which unfortunately didn't make it to the beta). It offers 700 pixels for the title, though with a larger font. In pure horizontal space, that's over 300 pixels more than in Lucid. The font being used for the title is about 1.2 the width of the one in the last slideshow.
Hopefully that will make the situation better.

I want to help the translations here be excellent, but I'm at a loss for what else can be done. If something in particular would improve this, please do let us know.

AJenbo (ajenbo) on 2010-09-16
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
David Planella (dpm) wrote :

Thanks to everyone for the feedback.

I'm closing the translations task as Invalid, as the current behaviour is a design decision, and it does not stop the translations from being shown and readable.

The slideshow's package task remains open for now for further discussion if needed.

Changed in ubuntu-translations:
importance: Undecided → Low
status: New → Invalid
Chad A. Davis (chadadavis) wrote :

I would suggest reducing the point size of the heading in cases where the translation does not fit. This has the disadvantage that it might be inconsistent between slides, but leaving the second line significantly smaller than the first line is much more noticeable and difficult to read. Slightly reducing the point size such that everything is the same size, even if means using two lines, would look much cleaner. And many users will not notice if the point size on two different slides are slightly different.

Adolfo Jayme (fitojb) wrote :

I am for smaller headers as well. Maybe using the Ubuntu Light font will help a bit (apart from looking great).

no longer affects: ubuntu-translations
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Medium → Low

The next release (for Ubuntu Raring) should help with this. We're switching
to a 24px font size, and if there is a second line it appears at that same
size.
On 20 Mar 2013 04:21, "Adolfo Jayme Barrientos" <email address hidden>
wrote:

> I am for smaller headers as well. Maybe using the Ubuntu Light font will
> help a bit (apart from looking great).
>
> ** No longer affects: ubuntu-translations
>
> ** Changed in: ubiquity-slideshow-ubuntu (Ubuntu)
> Importance: Medium => Low
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/628159
>
> Title:
> Some ubiquity slideshow titles go (smaller) to a new line
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu/+bug/628159/+subscriptions
>

Adolfo Jayme (fitojb) on 2013-04-10
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers