Xubuntu slideshow does not support RTL

Bug #560220 reported by Dylan McCall on 2010-04-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Dylan McCall

Bug Description

Please grant a freeze exception for the following as this allows the Xubuntu slideshow to support RTL languages. The upload also updates translations from Launchpad, prunes unused translations (freeing up a small amount of space), and uses a higher resolution image of the personalize icon (the previous one was slightly pixelized).

Original report follows:

The Xubuntu slideshow does not support RTL. The script adds the rtl class to the correct element, but there is no CSS to handle it.

Unfortunately, the problem isn't dead simple to fix: bullet points are illogically aligned to the left of list items via the li:before selector, and there is also an li.nobullet class.

Thankfully, I just learned something! It _is_ possible to set list-style for individual LI elements; it isn't a global property for the entire list at all. Shouldn't be hard to remove the use of :before and maintain the same functionality, which will also magically support RTL. The rest should be pretty easy.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
assignee: nobody → Dylan McCall (dylanmccall)
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Fix Committed
Evan (ev) on 2010-04-17
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 22

---------------
ubiquity-slideshow-ubuntu (22) lucid; urgency=low

  [ Dylan McCall ]
  * Fixed RTL for Xubuntu slideshow (LP: #560220).

  [ Evan Dandrea ]
  * Add a higher resolution export of the personalize icon. Thanks
    Daniel Fore!
  * Update translations from Launchpad. Remove translations that are
    not included in localechooser and thus are not available in the
    installer.
 -- Evan Dandrea <email address hidden> Sat, 17 Apr 2010 11:07:49 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers