[UserInterface Freeze Exception]Merge new content in middle of slideshow

Bug #445102 reported by Dylan McCall on 2009-10-07
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity-slideshow-ubuntu

I am proposing that a set of 7 heavily edited slides for the slideshow be merged and released. The tone and points made remain similar, but the strings for those slides have been completely altered. (The beginning, end and Software Centre slides remain unchanged). It can be seen live at <http://www3.telus.net/northlight/dylan/ubiquity-slideshow-proposed/#controls>, so no need to download the source right away.
The lp:middle-tweaks branch contains the latest version of these changes.

Of course, this is all for a reason. The changes are in response to some feedback I have collected which suggested that the middle slides were rather 'incomplete' feeling. In response to that, I focused on adding a resolution for each slide that would stick nicely.
There are many small adjustments that I believe give this a more confident and consistent voice. While the word count has increased, I believe the goal of each slide is still streamlined, so it shouldn't effect comprehensibility (speak of the devil. What a word!) too much.

Naturally, since we are very frozen at this point, this needs the go-ahead. It would be nice to get this in before a release candidate since that is a point where we can expect many people to do clean installs and provide last-minute feedback which we could act upon if necessary.

I should mention that this change is not NEEDED. It is just something that would be nice. If it will be too difficult for a particular group, I would not mind pushing it to the side for Lucid Lynx.

I will be discussing this on relevant mailing lists shortly. At the moment, I have a completely unrelated paper to write. Adiós!

Related branches

Dylan McCall (dylanmccall) wrote :

Discussion on ubuntu-doc list. Awaiting moderator approval for discussion on ubuntu-translators list, because I forgot to sign up first :)

https://lists.ubuntu.com/archives/ubuntu-doc/2009-October/013783.html

Martin Pitt (pitti) wrote :

Thanks for updating the slides, in particular mentioning the correct firefox version now and the software-center rename.

ubuntu-doc had a concern about updating the icons to humanity, but the current slideshow version in karmic doesn't do that either, so it's not a regression.

Approved.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Vish (vish) wrote :

Hi,
There are a few differences between the slideshow and the Ubuntu default
system theme [Humanity].

The icons used in the slideshow are all from either Human or Breathe
icon theme.

The icons that need to be updated:
- Arrows in all slides = use human theme
- Accessibility , Help , Openoffice icons = human theme
- Ubuntu logo [Uses Human logo , not sure if this needs to be changed to
look similar to the Humanity theme]
- F-spot , Evolution icon = from breathe [especially breathe evolution
icon with a visible name 'breathe contact']
- Rhythmbox , the hicolor icon doesnt look very pretty so maybe we can
leave that one alone , to use the breathe icon ;)

You also might want to check with Kenneth Wimer , regarding this , he
had a few concerns.

Kenneth Wimer (kwwii) wrote :

I makes sense to use whatever icons are used in the system, currently the Humanity icons. The design team noticed this yesterday, I was tasked with working on it, so I'll keep an eye on this

tgpraveen (tgpraveen89) wrote :

it would be great to have information that empathy can do audio/video chat in the empathy slide maybe with a screenshot also.

Dylan McCall (dylanmccall) wrote :

Gee, I guess I fell asleep when I sent this last. Could have sworn I already did!
Ah well, sorry if I'm repeating myself.

Thanks for the feedback regarding icons! I may as well slip that in to the same release since it's also a popular request and totally makes sense.

That change is now in the middle-tweaks branch and up at the web space I mentioned earlier (<http://www3.telus.net/northlight/dylan/ubiquity-slideshow-proposed/#controls>). I'm replacing most of the icons with their Humanity counterparts except Rhythmbox (because the Breathe one is awesome, and, as mentioned, the regular one is really plain). The F-Spot one is now straight from F-Spot's source package.
The Ubuntu logo is still from the Human theme, because the one from Humanity's distributor-logo icon looks Really Weird at large sizes. (Is there a different image I should be using?).
The OpenOffice icon looks a bit funny to me, and I am a bit troubled by the last icon being a question mark. Suggestions for those two are welcome, and let me know if the Rhythmbox one should change to the usual :)

I found Humanity's go-next icon (which we were using for the arrow) to blend really poorly on here. I can't quite put my finger on why, but lightening the background may make it fit. As is, the Human arrows just look prettier. Sharper, better defined and generally more pointed. Will create a branch to tinker with that one. Maybe something custom-made will turn out to be the best option; just a black or dark grey arrow...
On the other hand, the only app I can think of which uses go-next for bullet points like this is Beagle, which isn't installed by default.

Sorry about the bug tracker noise; I just don't want to launch too many discussions in too many places for such a small thing.

Vish (vish) wrote :

Dylan McCall , it would be easier/quicker to ping Kenneth on the irc , either #ubuntu-desktop or #ubuntu-artwork

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 9

---------------
ubiquity-slideshow-ubuntu (9) karmic; urgency=low

  [ Evan Dandrea ]
  * The version of Firefox shipped with Ubuntu 9.10 is 3.5, not 3.0
    (LP: #442832).
  * Add an Ubuntu One slide.
  * Freeze exception (LP: #447383).
  * Updated Ubuntu and Ubuntu One logo license (LP: #451263).
  * Updated translations from Launchpad (source package).

  [ Dylan McCall ]
  * Merged middle-tweaks branch. Freeze exception (LP: #445102)
  * New strings for firefox.html, fspot.html, rhythmbox-totem.html,
    evolution.html, empathy.html, openoffice.html, accessibility.html,
    installing-software.html.
  * Changed order of slideshow; multimedia stuff slide appears first,
    accessibility near the end, before Installing Software.
  * Breathe icons have been replaced with icons from the Humanity icon theme:
    accessibility.svg, evolution.svg, fspot.svg, help.svg, openoffice.svg
    (LP: #428169)
  * Breathe icon fspot.svg has been replaced with its counterpart from the
    fspot source package.
  * Removed banshee.svg from source tree and removed mention of nonexistent
    icons from debian/copyright.
  * Updated translation templates for new slides.

  [ Daniel Holbert ]
  * Made images in slideshow non-draggable to work around pywebkitgtk crash
    (LP: #448703).

 -- Evan Dandrea <email address hidden> Thu, 15 Oct 2009 11:50:19 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers