Slideshow is empty

Bug #430719 reported by Patrice Vetsel on 2009-09-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity-slideshow-ubuntu

Under daily-live 20090915 and 20090916, using french as language at boot prompt, the slideshow is empty. We just can see the background but noting is shown (text+icon)

Dylan McCall (dylanmccall) wrote :

Thanks for your bug report, Patrice! It works in my end from the source tree, running index.html with #locale=fr from the build directory.

I downloaded the latest ubiquity-slideshow-ubuntu package in Karmic and it appears that the actual html files for individual locales have vanished. Even though the translated .html files are not there, directory.js still claims they are.

The package builds fine on my end (without this bug), but I do not recall any changes relating to this in the past few days. I suspect that changes to build-deps (revision 128 in lp:ubiquity-slideshow?) are the problem.

Dylan McCall (dylanmccall) wrote :

Pushed a new makefile to lp:ubiquity-slideshow. It doesn't fix the broken locales, but it fixes a related bug: directory.js reporting files that never got created. This way, the slideshow's Javascript will not know about locales that fail to build (for ANY reason) and will thus use the fallback. In the event that po2html is not present, the build output now contains about 12 prominently spaced error messages and the build directory is not littered with empty slides/locale.* directories.

Oh, and sorry Evan, I guess I should explain: the reason I subscribed you is because I am not very clued in on debian packaging, or what build-depends-indep even are... :)

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → In Progress
Dylan McCall (dylanmccall) wrote :

Oops, sorry about all the noise! (Reading the build logs _first_ would have helped).

The problem was that the --notidy option mysteriously vanished from po2html in Karmic. This is a problem, but for now it is fixed by simply not asking for it. This increases the file size of our package to 757.1 KB (thanks to considerably larger html files for our localizations).

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: In Progress → Fix Committed
Dylan McCall (dylanmccall) wrote :

Just to cap off my comment combo:

The --notidy option mysteriously disappears when python-utidylib is not installed, and then reappears when python-utidylib is present. That's very backwards, but we can rest assured that, if the build machines are without a --notidy option, they do not "tidy" the html.

All is well :)

Evan (ev) wrote :

I've added a build dependency on python-utidylib and added the --notidy option back.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 6

---------------
ubiquity-slideshow-ubuntu (6) karmic; urgency=low

  [ Evan Dandrea ]
  * The buildds do not install recommends by default, so add a build
    dependency on python-utidylib (LP: #430719).
  * Add the Firefox icon and a javascript-based reflection for it
    (LP: #421864).
  * Updated translations from Launchpad.

  [ Dylan McCall ]
  * Fixed comma splice in documentation.html
  * Corrected missing "with" in the third bullet point. Fixed title
    (LP: #427257, #427254).
  * Makefile now checks if po2html is installed and exits (slightly more)
    gracefully, albeit with rather horrendous looking output :)
  * Added --progress=names when calling po2html. Makefile output is now a bit
    tidier.

 -- Evan Dandrea <email address hidden> Thu, 17 Sep 2009 17:16:20 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Aron Xu (happyaron) on 2009-09-19
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Released → New
Aron Xu (happyaron) wrote :

Krasimir Chonov <email address hidden> report this bug still not fixed on Bulgarian language at <email address hidden>; André Gondim <email address hidden> also confirmed this for pt_BR; malditoastur <email address hidden> for "ast", Asturian language.
Mail archive are at https://lists.ubuntu.com/archives/ubuntu-translators/2009-September/002755.html and with a broken thread https://lists.ubuntu.com/archives/ubuntu-translators/2009-September/002761.html

I myself confirmed it for Portugues language on daily live 20090917.1.
Slides show up when I choose zh_CN, but with no Chinese strings but all English.

So, reopen this bug.

Evan (ev) wrote :

Please do not reopen bugs just because new CDs have not yet been built. This changes were released into the archive after the most recent CDs were created.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers