Timing is too fast if installing to slow media or having low speed Internet connection

Bug #423639 reported by Oliver Grawert on 2009-09-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubiquity-slideshow-ubuntu

an install from SD card to USB key on an armel system (which is a slow setup in itself plus using slow source and traget media by defaul) takes about 1h.
the slideshow is done after a few minutes though. it would be nice if the slideshow could adjust it's speed according to the used media so the install stays intresting for the whole duration.

Dylan McCall (dylanmccall) wrote :

This can be accomplished if the slideshow is passed an install time via the URL. Anyone know if Ubiquity has that type of information handy by the time it creates the progress bar?

However, I am hesitant to make the slides stick for too long. Right now it's possible to sit and read all of them, but if the slides stick for a few minutes each, for example, the entire usage changes to something we didn't design this for.

A richer slide capping the end could make for a nicer experience in these cases, though. (Maybe something interactive is in order for the future?).

Oliver Grawert (ogra) wrote :

well, in any case its not overly important to have that solved in karmic, i'll set this bug to whishlist if you dont mind :)

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → Wishlist
Colin Watson (cjwatson) wrote :

I had more or less the same suggestion as Oliver, namely that they should be spaced out - but I hadn't considered whether that was affected by slide design.

I don't suppose it would be worth spacing them out a *bit* more (maybe up to a cap of a minute or something), and then if necessary simply looping the slideshow?

Dylan McCall (dylanmccall) wrote :

Sorry this took so long. With the longer slide content in Bug #445102, it would definitely make even more sense than before to make these longer. How does 50 seconds sound? That means the show in total will be a bit over 8 minutes.

That also means it's something more passive instead of something we could expect the user to sit and watch with fixed eyes, which in retrospect makes a lot more sense anyway. Sending facepalm.png to my past self :)

Some time8 minutes still cannot fulfill the installation, because when
additional language pack is needed, or user has a not very fast link
speed to there region's main update sever, the installation will be
almost *frozen* at around 80% of the total progress. This is a problem
of Ubiquity, but before it is solved, our slide show may consider
about it.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Aron Xu (happyaron) on 2009-11-10
summary: - timing is to fast if installing to slow media
+ Timing is too fast if installing to slow media or having low speed
+ Internet connection
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 12

---------------
ubiquity-slideshow-ubuntu (12) lucid; urgency=low

  [ Dylan McCall ]
  * Removed unused overlay image from earlier design.
  * Added HTML comments to slides, which will become translator
    comments when all the pieces are in place. (LP: #435834)
  * Tidied up writing in the following slides:
    f-spot (streamlined discussion of tags), rhythmbox (removed
    codec licensing stuff), documentation (removed subtitles).
    (LP: #480382) (LP: #480383)
  * Consistently italicize names of applications in Ubuntu when
    referred to directly.
  * Consistently refer to applications by their names in the menu
    when directing the user to them.
  * Major adjustment to format for passing parameters to
    slideshow's Javascript via #parameter. Now using
    #?key?key=value format, for compatibility with
    WebKit.
  * Changed default slide interval for slideshows to 45s
    (LP: #423639)

  [ Evan Dandrea ]
  * Put Kubuntu slides in their own directory to avoid having to make
    each slideshow package conflict.
  * Update translations from Launchpad.
 -- Evan Dandrea <email address hidden> Mon, 11 Jan 2010 09:36:06 +0000

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
Dylan McCall (dylanmccall) wrote :

Heh, Launchpad Janitor is just too good! I actually wasn't intending to mark this as certainly FIXED, since the 45s change is mainly to test the waters. Not sure how I'll get feedback on this, but if someone has any to share, please do :)

The upgrade people want a more sophisticated system where the upgrade tool tells the slideshow the current progress percentage, so hopefully we'll have the technology in place for other solutions if they are necessary :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers