Ubiquity-slide-show fails to display an image for Internet Browsing

Bug #421864 reported by Dave Morley on 2009-08-31
118
This bug affects 19 people
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ubiquity-slideshow-ubuntu

The second slide I believe, is one for internet browsing. It has no image displayed instead showing the default icon for a holder.

Dylan McCall (dylanmccall) wrote :

This is happening due to licensing concerns. Until that gets figured out, we are not shipping the Firefox logo. (Using it is always a bit concerning). It springs to mind that we could use a pretty image that has nothing to do with a specific web browser, an icon in the Firefox style, or a generic web browser icon. Any suggestions? :)

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Aron Xu (happyaron) wrote :

I suggest to use a pretty icon do nothing to any specific web browser, because Firefox's licensing is something argued by some people, if not why those people re-brand it to iceweasel? We'd better avoid such trouble.

What's more I would like to say is about the 'Watching and Listening' section, I don't think the speaker is the best choice though I'm not sense in imaging what's better. As the name suggested, it's for watching and listening, something like totem's logo might be good choice.

Aron Xu (happyaron) wrote :

I suggest to use a pretty icon do nothing to any specific web browser, because Firefox's licensing is something argued by some people, if not why those people re-brand it to iceweasel? We'd better avoid such trouble.

What's more I would like to say is about the 'Watching and Listening' section, I don't think the speaker is the best choice though I'm not sense in imaging what's better. As the name suggested, it's for watching and listening, something like totem's

Ernst Zlo (ernst-zlo) wrote :

Suggestion for a generic internet icon
Somewhat with the idea of looking on our complete world ... have the world in view

perhaps this one:

Ernst Zlo (ernst-zlo) wrote :

or this one, where the eye is filled (so it wouldn't be grey but white even on grey background)

Dylan McCall (dylanmccall) wrote :

Interesting mockups, Ernst. I was thinking something like that, too, showcasing the variety of documents and tasks centralized around the web. (One of those pictures with many little icons within).

For now, in revision 141, I am throwing in Mozilla's unbranded globe icon (used in Firefox development builds and as an element in all their web icons). It also fits with the current style, which goes with bug #428169. I still think a custom icon would be awesome to have, but slow & steady wins the race, after all...

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Committed
Ernst Zlo (ernst-zlo) wrote :

Thank you, Dylan.

If I could have a link to the other 'approved' icons, I could make one based on my idea, but matching to the others. And with the correct size for further development.

If not, I'll have to go to the installation process and make screenshots. As this would be my 35th (or more?) installation of alpha5 it would be a bit boooooring and therefore definitely have to wait untill thursday [alpha 6] ;-)

Aron Xu (happyaron) wrote :

I think you could build the slides from source code and use your web browser for preview rather than run a installation.

Ernst Zlo (ernst-zlo) wrote :

hmm ...
As it was written on an ancient Babylonian text: there are no answers but links :^)

Where can I find the source of the slideshow? ('which ubiquity-slide-show' leads to nothing)

Aron Xu (happyaron) wrote :

just use bzr to checkout the branch:
bzr branch lp:ubiquity-slideshow-ubuntu
you might need refer to https://help.launchpad.net/BzrHowto to find some pre-steps before doing that. You'll see instructions in the source tree about how to build and view them.

Ernst Zlo (ernst-zlo) wrote :

Hello Dylan,
What about this one.
It's a combination of the other icons building an eyebrow over my web-eye with the base of the blue button (with the question mark). I've tested it in the slideshow [thank you Aron!] and IMHO it looks quite usable ;-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 6

---------------
ubiquity-slideshow-ubuntu (6) karmic; urgency=low

  [ Evan Dandrea ]
  * The buildds do not install recommends by default, so add a build
    dependency on python-utidylib (LP: #430719).
  * Add the Firefox icon and a javascript-based reflection for it
    (LP: #421864).
  * Updated translations from Launchpad.

  [ Dylan McCall ]
  * Fixed comma splice in documentation.html
  * Corrected missing "with" in the third bullet point. Fixed title
    (LP: #427257, #427254).
  * Makefile now checks if po2html is installed and exits (slightly more)
    gracefully, albeit with rather horrendous looking output :)
  * Added --progress=names when calling po2html. Makefile output is now a bit
    tidier.

 -- Evan Dandrea <email address hidden> Thu, 17 Sep 2009 17:16:20 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Ernst Zlo (ernst-zlo) wrote :

May I respectfully disagree?

I've just installed Karmic alpha 6 and:
1) no logo at all on the firefox screen
2) in addition to that, the first screen is empty

Ernst Zlo (ernst-zlo) wrote :
Ernst Zlo (ernst-zlo) wrote :

I am no native English speaker, therefore I possible be very wrong on that, but IMHO the text on the last screen
sounds a bit condescending:

"Ask your questions at ubuntuforums.org where advanced users help people just as you"

I'd write
"Ask your questions at ubuntuforums.org where advanced users help users, who are less experienced"

Luke Symes (allsymes) wrote :

Changing to "New", I am not seeing any icon here on Lucid Alpha 3, Ubiquity 2.1.27. Can anyone else confirm?

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Released → New
tags: added: iso-testing
Dylan McCall (dylanmccall) wrote :

Thanks for the tag.

This was fixed right after (alas, not for) alpha 3 by replacing the Firefox icon with the Internet category icon.[1] Whether that one is a good idea is still up for debate. For the actual Firefox icon, we're blocking on a different issue, which is that Firefox on Ubuntu ships with a needlessly small icon — that always looked rather ugly here. The unnecessary version number has also been pulled.

Luke, were you installing stock Ubuntu or a particular derivative?

So, marking this as Fix Committed. It should be shiny and happy for Beta 1 and the nearest daily builds. Thank you for the attention to detail! :)

[1] For some reason Chromium doesn't want to upload files today, so you can get a screenshot at http://people.ubuntu.com/~dylanmccall/screenshots/ubiquity-slideshow_15-firefox.png

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Fix Committed
Luke Symes (allsymes) wrote :

@Dylan McCall: I was installing stock Ubuntu Alpha 3. I'm glad to hear it will be good for Beta 1!

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → High
Dylan McCall (dylanmccall) wrote :

Evan fixed this again in the main bzr branch, now that we have a redesign where it works! firefox.html just refers directly to the real Firefox icon on the system and it finally looks good doing it :)

Should be landing in version 16, so that'll be beta 2 (hopefully).

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Erik B. Andersen (azendale) wrote :

This seems to be a problem again with the daily image from 4-3-2010. I attached a screenshot.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Released → New
Dylan McCall (dylanmccall) wrote :

Thank you, Erik, for testing the daily image!
I absent-mindedly encountered that and fixed it earlier, but this could do with a moment of pondering :o

This happened because Firefox's /usr/lib folder changed to /usr/lib/firefox-3.6.2 (from firefox-3.6), thus our image was pointing at a file that didn't exist. I fixed that in the latest revision where I changed the alignments. It's a little bit hair-raising, though…

Vish (vish) wrote :

@Dylan McCall: Have you spoken to the ubuntu mozilla team regarding this? If the folder keeps changing it is a bit worrying.
Maybe they can help?

Or have you considered pointing it to > /usr/share/pixmaps/firefox.png
It is a symlink , and I'm pretty sure this wont change everytime or atleast it would be updated if the folder changes

Vish (vish) wrote :

Or if you are having too much trouble , you can grab the 256px web-browser icon from gnome-icon-theme in git ;-)

Dylan McCall (dylanmccall) wrote :

Aha! Thank you, Vish. I was hoping there was a nice solution.
I'll point it at the symlink. It's installed by firefox-branding, which also installs the elusive icon in /usr/lib/*, so we should be safe using it :)

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Fix Committed
Roy Jamison (xteejx) wrote :

A simple coloured www with a ring around it I think would have done it, but who am I to argue with design choice ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 21

---------------
ubiquity-slideshow-ubuntu (21) lucid; urgency=low

  [ Dylan McCall ]
  * Ubuntu slideshow: New icons. Fixes centering (LP: #552510).
  * Added personalize.png and media.png, replacing accessibility.png
    and rhythmbox.png, respectively.
  * Small CSS changes: title block is narrower, exception for Firefox
    icon, removed icon.exact property.
  * Firefox icon now points to the correct file (LP: #421864).
  * Fixed RTL for Ubuntu slideshow (LP: #549357).
  * Fixed RTL for Kubuntu slideshow (LP: #537635).

  [ Jonathan Riddell ]
  * Update kubuntu-logo.png with new logo

  [ Evan Dandrea ]
  * Update translations from Launchpad.
 -- Evan Dandrea <email address hidden> Wed, 07 Apr 2010 09:35:22 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers