Ubuntu Studio Installation - Black Text on Dark Gray

Bug #1822134 reported by Erich Eickmeyer on 2019-03-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Studio
High
Erich Eickmeyer
materia-gtk-theme (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

While testing Ubuntu Studio Disco installation, I noticed with our theme change that the non-interactive text (header and footer) appeared with legibility issues (black on dark gray). A change to white text would be needed to correct this problem.

Erich Eickmeyer (eeickmeyer) wrote :

Screenshot showing the issue. Same dark text appears below the white area during installation, but unable to get an image of that.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Invalid
description: updated
Changed in ubuntustudio:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Erich Eickmeyer (eeickmeyer)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in materia-gtk-theme (Ubuntu):
status: New → Confirmed
Erich Eickmeyer (eeickmeyer) wrote :

Package is originally from upstream Debian. Created https://code.launchpad.net/~ubuntustudio-dev/ubuntustudio/+git/materia-gtk-theme to allow direct packaging until upstream can be fixed & merged.

Changed in ubuntustudio:
status: Confirmed → Fix Committed
Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid

The attachment "0001-Fix-for-Ubiquity-page-label-thanks-clobrano.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Ross Gammon (rosco2) on 2019-03-30
Changed in materia-gtk-theme (Ubuntu):
assignee: nobody → Ross Gammon (rosco2)
Ross Gammon (rosco2) wrote :

Hi Erich,

Fast work! Uploaded.

Made a couple of minor changes:
- I had to refresh the patch and remove the empty "series" patch from the series file.
- Also added a bit more of a description to the patch header, and added a link to the upstream Pull Request. Assuming it is merged there, it will be easier for the Debian Maintainer to confirm this later (if he checks).

Marked as Fix Commited, because I think due to the freeze it will need unblocking from the Release Team.

Changed in materia-gtk-theme (Ubuntu):
assignee: Ross Gammon (rosco2) → nobody
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package materia-gtk-theme - 20190201-1ubuntu1

---------------
materia-gtk-theme (20190201-1ubuntu1) disco; urgency=medium

  * Fix Ubiquity theming issue (LP: #1822134)

 -- Erich Eickmeyer <email address hidden> Thu, 28 Mar 2019 16:40:55 -0700

Changed in materia-gtk-theme (Ubuntu):
status: Fix Committed → Fix Released
Erich Eickmeyer (eeickmeyer) wrote :

Tried with the latest daily ISO for Ubuntu Studio, and the bug still exists.

Changed in materia-gtk-theme (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntustudio:
status: Fix Committed → In Progress
Erich Eickmeyer (eeickmeyer) wrote :

The following patch works, tested, packaged in git repo at https://code.launchpad.net/~ubuntustudio-dev/ubuntustudio/+git/materia-gtk-theme

Changed in materia-gtk-theme (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
Changed in ubuntustudio:
status: In Progress → Fix Committed
Changed in materia-gtk-theme (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package materia-gtk-theme - 20190201-1ubuntu2

---------------
materia-gtk-theme (20190201-1ubuntu2) disco; urgency=medium

  [ Erich Eickmeyer ]
  * Fix Ubiquity theming issue (LP: #1822134)
    - Previous change did not fix issue

 -- Ross Gammon <email address hidden> Tue, 09 Apr 2019 18:29:45 +0200

Changed in materia-gtk-theme (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntustudio:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers