[UIFe] New copy for Ubuntu installer slideshow

Bug #1056456 reported by Dylan McCall
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

This is a freeze exception request for ubiquity-slideshow-ubuntu. We are changing some copy for the Ubuntu slideshow. The changes are available with the merge request:
https://code.launchpad.net/~dylanmccall/ubiquity-slideshow-ubuntu/quantal-ubuntu-copy/+merge/126337

This will replace 13 strings that had previously been translated for 12.04.

The other visible changes for 12.10 — new screenshots and illustrations — will happen separately, because it is important we get these new strings in nice and quickly so they can be translated.

Tags: uife

Related branches

Revision history for this message
Dylan McCall (dylanmccall) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Revision history for this message
David Planella (dpm) wrote : Re: UIFe for ubiquity-slideshow-ubuntu

Al 25/09/12 23:23, En/na Dylan McCall ha escrit:
> Hi,
>
> I am requesting a UI freeze exception for ubiquity-slideshow-ubuntu:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu/+bug/1056456
>
> This will replace 13 strings with new ones contributed by the nice
> folks at Canonical. This is mostly aesthetic, with some changes to
> content: we're adding a mention of the new webapps feature and
> removing some boring technical stuff. The welcome slide no longer
> mentions Unity by name and the bit about Rhythmbox no longer babbles
> about "advanced playback options." Sorry to be landing right on the
> documentation string deadline with this one, but once this is merged
> that will be it for the Ubuntu slideshow string changes.
>
> Thank you :)
>
> Dylan
>

Hi Dylan,

Could you list the exact strings that are changed? I'd like to see them
before +1'ing this one.

The Ubiquity Slideshow is not part of the documentation string freeze
[1], and I would have expected changes to have landed much earlier. Any
late changes in things like the installer or the slideshow leave much
less time for translators to complete the translations, and most
importantly, to test them.

As they are not part of the language packs, they cannot be tested often,
and more than one team (mine included) has been bitten by having
completed translations just in time, having them deployed, and ending up
with a glaring typo that can no longer be fixed.

Now it might well be that the delay has been caused by the Canonical
team giving you the strings very late. If this is the case, please let
me know and I'll make sure to make this point clear to them.

In order to ease the work of translators, would it be possible to
include translations from LP on every slideshow upload from now on? Or
even better, I think a while ago you set up a web page with the
localized versions of the slideshow that were updated regularly. That
was extremely useful. Would it be possible to set that up again?

Thanks.

Cheers,
David.

[1] https://wiki.ubuntu.com/DocumentationStringFreeze

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Revision history for this message
Stéphane Graber (stgraber) wrote :

I'm pretty much the only uploader for this package and always bundle a new translation export from Launchpad when uploading.
The problem we had in the past was an invalid slide in the Xubuntu slideshow, preventing the pot generation which caused us not to have the right strings on LP for the past month or so....

Revision history for this message
Dylan McCall (dylanmccall) wrote :
Download full text (7.7 KiB)

Hi, David!

> Could you list the exact strings that are changed? I'd like to see them
> before +1'ing this one.

Sure. They're also listed in this merge request over here:
https://code.launchpad.net/~dylanmccall/ubiquity-slideshow-ubuntu/quantal-ubuntu-copy/+merge/126337
Of course, that isn't very fun to read, so here is that in a
(hopefully) more readable format.

"Access for everyone"
(Replacing "Customize Ubuntu")

"At the heart of the Ubuntu philosophy is the belief that computing is
for everyone. With advanced accessibility tools and options to change
language, colour scheme and text size, Ubuntu makes computing easy —
whoever and wherever you are."
(Replacing "At the heart of Ubuntu’s philosophy is a belief that
computing is for everyone. With advanced accessibility tools and
options like your preferred color scheme, text size, and language,
Ubuntu is for anyone. Whoever you are, and wherever you are.")

"Make the most of the web"
(Replacing "Browse the web")

"Ubuntu includes Firefox, the web browser used by millions of people
around the world. And web applications you use frequently (like
Facebook or Gmail, for example) can be pinned to your desktop for
faster access, just like apps on your computer."
(Replacing "Ubuntu includes Mozilla Firefox for fast and safe web
browsing. It’s easy to use and it’s backed by a non-profit foundation
that loves the web. If you aren’t a Firefox fan, there are also lots
of alternatives in the Ubuntu Software Center.")

"Check out <a href=\"http://askubuntu.com/\">askubuntu.com</a> for
answers to all your Ubuntu questions. There’s a good chance your
question will have been answered already and, if not, you’ll find
thousands of volunteers eager to help. For more support options, go to
<a href=\"http://www.ubuntu.com/support\">ubuntu.com/support</a>."
(Replacing "Check out <a href=\"http://askubuntu.com/\">Ask
Ubuntu</a>, the best place to get an answer about Ubuntu. With most
questions already answered, and thousands of people ready to help,
you’ll be sorted in no time at all. And if you need an answer on a
deadline, you can get commercial support and more at <a
href=\"http://www.ubuntu.com/support\">ubuntu.com/support</a>.")

"<a href=\"https://one.ubuntu.com/services/free/\">Ubuntu One</a>
gives you 5GB of free cloud storage to access your files, share your
photos and <a href=\"https://one.ubuntu.com/services/music/\">stream
your music</a> to your computers, tablets and smartphones. Any photo
you take appears on all your devices, the instant you take it. Ubuntu
One runs on Ubuntu, Windows, Mac, Android, iOS and the web."
(Replacing "An <a href=\"https://one.ubuntu.com/services/\">Ubuntu One
Free</a> account gives you 5GB of cloud storage, so you can store and
sync your files and photos across devices and access them wherever you
are in the world. Easily share them with friends, family and
colleagues. Take a photo on your mobile phone and immediately see it
on your desktop, or add <a
href=\"https://one.ubuntu.com/services/music/\">Music Streaming</a>
for mobile to enjoy your music on the move.")

"All the music you need"
(Replacing "Take your music with you")

"Ubuntu comes with Rhythmbox, for organisin...

Read more...

Revision history for this message
Dylan McCall (dylanmccall) wrote :

Okay, just about the last possible moment to do this reasonably (barring a sudden change in the schedule). I just want to make sure it hasn't fallen off everyone's radar, so… any hope of that +1? :)

Revision history for this message
Scott Kitterman (kitterman) wrote :

I don't see a clear +1 from translators and nothing from the docs team.

Revision history for this message
Dylan McCall (dylanmccall) wrote :

Oh, darn, how did I miss that? Message to ubuntu-doc mailing list, for what it's worth:
https://lists.ubuntu.com/archives/ubuntu-doc/2012-September/016937.html

As I said, this is mostly aesthetic. There are a few things that look pretty dumb being left as they were, so if we can get away with just two or three string changes (instead of the 13) that would be neat, but I don't know if that's an important factor for translation quality.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

+1 from Docs as this doesn't really affect the docs team.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1056456] Re: [UIFe] New copy for Ubuntu installer slideshow

I'd like dpm's view on 2 versus 13 before approving.

Revision history for this message
Dylan McCall (dylanmccall) wrote :

In that case, I'll do something a little abnormal (sorry!). Here is a
revised list of new copy. I'm going to list the top five because I
consider them the most important, but we can snip this at any point
(and I'm happy going with the top three):

"Fast and full of new features, the latest version of Ubuntu makes
computing easier than ever. Here are just a few cool new things to
look out for…"

"Make the most of the web"
"Ubuntu includes Firefox, the web browser used by millions of people
around the world. And web applications you use frequently (like
Facebook or Gmail, for example) can be pinned to your desktop for
faster access, just like apps on your computer."

"Say goodbye to searching the web for new software. With Ubuntu
Software Center, you can find and install new apps with ease. Just
type in what you’re looking for, or explore categories such as
Science, Education and Games, alongside helpful reviews from other
users."

"The messaging menu gives you an eagle-eye view of incoming messages
from all applications and social networks. So you can see straight
away when there’s something new to read, regardless of how it
arrived."

"Check out <a href=\"http://askubuntu.com/\">askubuntu.com</a> for
answers to all your Ubuntu questions. There’s a good chance your
question will have been answered already and, if not, you’ll find
thousands of volunteers eager to help. For more support options, go to
<a href=\"http://www.ubuntu.com/support\">ubuntu.com/support</a>."

-----

Some of these are quite similar to the original stuff, since the most
important changes also happen to be the ones that fix jargon and poor
wording.

I will excitedly merge whatever number of changes people are comfortable with :)

Dylan

Revision history for this message
Scott Kitterman (kitterman) wrote :

Thanks. Let's see what dpm has to say.

Revision history for this message
David Planella (dpm) wrote :

Thanks Dylan,

+1 to merge the top 5 copy changes from your latest comment (#11), plus this one:

"<a href=\"https://one.ubuntu.com/services/free/\">Ubuntu One</a>
gives you 5GB of free cloud storage to access your files, share your
photos and <a href=\"https://one.ubuntu.com/services/music/\">stream
your music</a> to your computers, tablets and smartphones. Any photo
you take appears on all your devices, the instant you take it. Ubuntu
One runs on Ubuntu, Windows, Mac, Android, iOS and the web."

For anyone reading this bug, please realise that introducing copy changes this late in the release does not really give time to the teams of volunteers to translate them. I understand everyone is busy, but that's why we've got milestones and checkpoints in the release process: to either deliver the changes on time or to raise any deviations from the schedule. This effectively means that some languages that had the installer fully translated in the previous release might be partially translated for 12.10, both for the official images and for any derived OEM builds.

I'm +1'ing this one as some of the changes were necessary, and because at least another translator on the mailing list said it's ok to go with these, but please, do respect the string freezes next cycle.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Thanks. Approved per dpm's plan.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Stéphane Graber (stgraber) wrote :

Dylan: Can you land those in the branch ASAP and comment in this bug (or even better, poke me on IRC) as soon as it's done?

I'll then do a review, re-generate the templates, pull the latest translations from LP and upload the package so we can have as much time as possible for translations. We should really have all that done today.

Revision history for this message
Dylan McCall (dylanmccall) wrote :

Okay, it's merged. Thanks for the help. I'm (slowly) uploading that to people.ubuntu.com/~dylanmccall/ubiquity-slideshow-ubuntu/preview/ right now, so the changes should be visible in an hour or so.

Revision history for this message
Stéphane Graber (stgraber) wrote :

Uploaded.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 64

---------------
ubiquity-slideshow-ubuntu (64) quantal; urgency=low

  [ Stéphane Graber ]
  * Fix invalid html in Xubuntu slideshow preventing pot files generation.
    (LP: #1043222)
  * Re-generate all po templates (was already manually imported in Launchpad)
  * Update translations from Launchpad.

  [ Dylan McCall ]
  * Updated copy for Ubuntu slideshow. (LP: #1056456, LP: #1054346)
 -- Stephane Graber <email address hidden> Mon, 01 Oct 2012 12:09:50 -0400

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Triaged → Fix Released
tags: added: uife
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers