[FFe] Support Nitrogen6x board

Bug #1838064 reported by Shrirang Bagul on 2019-07-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
u-boot (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

[Impact] The existing u-boot package doesn't build the binary u-boot-imx for Nitrogen6x 2G version. Also, we need to support the new subarch in livecd-rootfs for future image builds.

[Test Case] Since essentially these changes are related to hardware enablement (and no official images are yet being produced), the only possible test case is asking the HWE team to verify if the packages in -proposed work as expected on the target device.
For the livecd-rootfs changes - since all the other bits and pieces are still not available (gadget tree for instance), it is not really possible to test this at this point. That being said, addition of a new platform should be safe and the only acceptance criteria would be to make sure the new changes did not regress any existing builds.

[Regression Potential] None. The patches add config changes for a new target (nitrogen6x2g) to generate u-boot-imx.
The changes are tested on the Nitrogen6x board.
As for livecd-rootfs - there is also no possible regression potential. We are only adding new case conditionals for a new platform.

[Feature Freeze Exception]
Even though the required u-boot changes for Nitrogen6x support do not introduce any behavior change in existing packages per-se, the changes do enable a new, not-built previously target by default. All the Ubuntu-specific changes do not affect any existing users, since the nitrogen6q2g target was never officially built for both Ubuntu and Debian.
To reach as many users as possible and become a well-known distribution for IoT and embedded devices, it is important to support as many different devices as possible. Which is why I would like to request a Feature Freeze exception for any hardware-enablement work required for adding Nitrogen6x support.

Test builds of the u-boot package: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3796/+packages

Related branches

Shrirang Bagul (shrirang-bagul) wrote :

The patches can be pulled from lp:~shrirang-bagul/+git/u-boot:nitrogen6x2g

I am unable to create a LP merge proposal against lp:ubuntu/+source/u-boot:ubuntu/bionic-updates.
Are there any other ways to send patches?

Changed in u-boot (Ubuntu Bionic):
status: New → Confirmed
importance: Undecided → High
Anthony Wong (anthonywong) wrote :

Hi Shrirang,

Your changes look like good candidate for u-boot upstream, you should submit them upstream first. Once accepted, Eoan will pick them up and then SRU back to Bionic.

Łukasz Zemczak (sil2100) wrote :

Hey Shrirang, Anthony. I left a question regarding upstreamability of this change on the MP. Basically it feels to me like these changes are rather quite Ubuntu-specific. In that case, is this change even upstreamable?

summary: - Support Nitrogen6x board
+ [FFe] Support Nitrogen6x board
description: updated
description: updated
Steve Langasek (vorlon) wrote :

This looks fine for FF.

Łukasz Zemczak (sil2100) wrote :

(uploaded to eoan)

Changed in u-boot (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package u-boot - 2019.04+dfsg-2ubuntu3

---------------
u-boot (2019.04+dfsg-2ubuntu3) eoan; urgency=medium

  [ Shrirang Bagul ]
  * Enable Ubuntu support for the Nitrogen6x board (LP: #1838064)
    - Add d/p/ubuntu-nitrogen6q2g-config-tweaks.patch to tweak the
      nitrogen6q2g configs to better fit our Ubuntu usage.
    - Start building the nitrogen6x2g target for u-boot.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 03 Sep 2019 11:39:53 +0200

Changed in u-boot (Ubuntu):
status: Triaged → Fix Released
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.610

---------------
livecd-rootfs (2.610) eoan; urgency=medium

  * Fix a typo in the 999-ubuntu-image-customization.chroot hook.

livecd-rootfs (2.609) eoan; urgency=medium

  [ Ethan Hsieh ]
  * Add support for the Nitrogen6x board (LP: #1838064).

  [ Łukasz 'sil2100' Zemczak ]
  * Do not initialize EXTRA_SNAPS with an empty value. Allow overrides via the
    environment.
  * Make sure that currently all ubuntu-image built images ship the NoCloud
    system-boot clout-init datasource (as right now all u-i targets are
    physical devices).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 10 Sep 2019 17:35:00 +0200

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
description: updated

Hello Shrirang, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.30 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

All autopkgtests for the newly accepted livecd-rootfs (2.525.30) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-image/1.7+18.04ubuntu1 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#livecd-rootfs

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Łukasz Zemczak (sil2100) wrote :

The livecd-rootfs changes look correct, and since there's no real better way of verifying this right now - I'm setting this as verification-done. All autopkgtest regressions have been cleared. This should be good to go.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.30

---------------
livecd-rootfs (2.525.30) bionic; urgency=medium

  [ Robert C Jennings ]
  * ubuntu-cpc: Only produce explicitly specified artifacts (LP: #1837254)

  [ Ethan Hsieh ]
  * Add support for the Nitrogen6x board (LP: #1838064).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 10 Sep 2019 16:56:26 +0200

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released

Hello Shrirang, or anyone else affected,

Accepted u-boot into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/u-boot/2018.07~rc3+dfsg1-0ubuntu3~18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in u-boot (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done verification-done-bionic
tags: added: verification-done-bionic
removed: verification-needed-bionic
Chris Halse Rogers (raof) wrote :

Hi Shrirang! As you've marked the u-boot SRU as verified, could you please detail what testing was actually done on it and what you've done to make sure the version that was being tested is the SRU version ;).

Presumably that's just testing that the packages work for the rest of the HWE process, but in the SRU team we like to have what was tested and how specifically called out when releasing.

Thanks!

After some investigation, the pre-release image for Nitrogen6x is not pulling the u-boot.imx from -PROPOSED ppa.
Hence, changing back to 'verification-needed-bionic'

tags: added: verification-needed-bionic
removed: verification-done-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Shrirang, or anyone else affected,

Accepted u-boot into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/u-boot/2019.07+dfsg-1ubuntu4~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Let's release it as is since there is no harm in having it in -updates, even if it doesn't quite do what we want (but I'm positive that it does). Let's iterate on it further in the near future, if needed.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package u-boot - 2019.07+dfsg-1ubuntu4~18.04.1

---------------
u-boot (2019.07+dfsg-1ubuntu4~18.04.1) bionic; urgency=medium

  * Backport of 2019.07+dfsg1 to support Raspberry Pi 4 boot (LP: #1846329)
  * Handle differing root partition labels during migration
  * Ensure boot.scr is from recent flash-kernel

u-boot (2018.07~rc3+dfsg1-0ubuntu3~18.04.2) bionic; urgency=medium

  [ Shrirang Bagul ]
  * Enable Ubuntu support for the Nitrogen6x board (LP: #1838064)
    - Add d/p/ubuntu-nitrogen6q2g-config-tweaks.patch to tweak the
      nitrogen6q2g configs to better fit our Ubuntu usage.
    - Start building the nitrogen6x2g target for u-boot.

 -- Dave Jones <email address hidden> Thu, 19 Dec 2019 22:06:27 +0000

Changed in u-boot (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers