u-boot-tools missing binutils dependency

Bug #1814930 reported by Dave Jones on 2019-02-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
u-boot (Ubuntu)
Medium
Unassigned
Bionic
Low
Unassigned
Cosmic
Low
Unassigned

Bug Description

[Impact]

The u-boot-tools package, specifically the mkknlimg script within it, relies upon several external utilities (specifically perl, grep, tr, and strings). Whilst most are provided by "essential" packages, strings is provided by binutils which is not. On a fresh install of the RPi3 beta image, an upgrade involved u-boot succeeds, but nonetheless prints a warning that strings cannot be found.

All package upgrades from the beta state should upgrade without any errors or warnings.

[Test Case]

On a pi3 image (or a chroot without binutils installed) with the old u-boot-tools version, run mkknlimg:

`touch a; mkknlimg --dtok a b`

Confirm that the command succeeds but prints out: "sh: 1: strings: not found". Upgrade the package and re-run the same command:

`mkknlimg --dtok a b`

Confirm that no "not found" message is visible anymore. Check that binutils has been installed during the update process.

[Regression Potential]

None. This only adds a new dependency. The dependency is in main and seeded in almost all daily and daily-live images.

Łukasz Zemczak (sil2100) wrote :

+1 on that, let me sponsor it with a few tweaks to the changelog.

I guess we should try getting this change into Debian? I'm pretty sure they might be having the same problem. They might have binutils installed everywhere but since it's not essential there as well, I suppose they should have the dep explicitly stated.

I'll also backport it to bionic once it migrates.

Łukasz Zemczak (sil2100) wrote :

Sponsored for disco, will sponsor it for bionic (and possibly cosmic?) in a bit.

Changed in u-boot (Ubuntu):
status: New → Fix Committed
description: updated
Łukasz Zemczak (sil2100) wrote :

Sponsored for bionic and cosmic (waiting in the unapproved queue).

Changed in u-boot (Ubuntu):
importance: Undecided → Medium
Changed in u-boot (Ubuntu Bionic):
importance: Undecided → Low
Changed in u-boot (Ubuntu Cosmic):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package u-boot - 2018.07~rc3+dfsg1-0ubuntu2

---------------
u-boot (2018.07~rc3+dfsg1-0ubuntu2) disco; urgency=medium

  * d/control: Add missing dependency on binutils (for strings) (LP: #1814930)

 -- Dave Jones <email address hidden> Wed, 06 Feb 2019 16:40:22 +0000

Changed in u-boot (Ubuntu):
status: Fix Committed → Fix Released

Hello Dave, or anyone else affected,

Accepted u-boot into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/u-boot/2018.07~rc3+dfsg1-0ubuntu2~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in u-boot (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers