SRU: Detect RAM size automatically and other fixes

Bug #1976594 reported by Alexandre Ghiti
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
u-boot-nezha (Ubuntu)
Fix Released
Undecided
Graham Inggs
Jammy
Fix Released
Undecided
Unassigned

Bug Description

The same package as kinetic (https://launchpad.net/ubuntu/+source/u-boot-nezha/2022.04+git20220405.7446a472-0ubuntu1) should be uploaded to jammy with the following changelog:

u-boot-nezha (2022.04+git20220405.7446a472-0ubuntu0.1) jammy; urgency=medium

  * No-change backport to jammy to detect RAM size automatically
    and other fixes (LP: #1976594)

 -- Alexandre Ghiti <email address hidden> Thu, 16 Jun 2022 10:37:21 +0000

[Impact]

We need this new package because it allows to detect memory size at runtime: if the memory is not discovered automatically, the Nezha can't boot without an additional memory node in the device tree. The issue is that the Nezha boards comes now with 2 different amounts of memory, 1GB or 2GB. So the additional device tree node can't cover both boards.

In addition:
- we fixed the model string which changed in the last DTB from the kernel we'll use
- the vendor updated to version 2022.04, which brings more stability
- we added the Built-using field to the package so that we know which opensbi version we use

It is essential to backport this fix to Jammy as we intend to provide first support for the Nezha board in 22.04.1.

[Test Plan]

This package must be tested with the nezha-boot0 package whose SRU can be found in [1] and the corresponding package in [2]. It also requires a custom kernel (for now, but the kernel is working on its packaging) which can be found in [3].

I tested those packages on the Nezha board with 1G of RAM and the LicheeRV board with 512M of RAM.

[1] https://bugs.launchpad.net/ubuntu/+source/nezha-boot0/+bug/1965260
[2] https://launchpad.net/~alexghiti/+archive/ubuntu/riscv/+sourcepub/13653972/+listing-archive-extra
[3] https://github.com/AlexGhiti/riscv-linux/tree/int/alex/nezha_Ubuntu-unstable-5.17.0-8.8

[Where problems could occur]

This package was never used before (and should not have been) as we did not provide any image for Jammy 22.04, the plan is 22.04.1.

[Other Info]

We decided to update the version of the u-boot since the vendor patches were updated (some added) on this new release only.

summary: - Detect RAM size automatically and other fixes
+ SRU: Detect RAM size automatically and other fixes
Changed in u-boot-nezha (Ubuntu):
status: New → Fix Committed
status: Fix Committed → New
description: updated
description: updated
Revision history for this message
Graham Inggs (ginggs) wrote :

Uploaded to jammy, awaiting approval from SRU team:
https://launchpad.net/ubuntu/jammy/+queue?queue_state=1

Changed in u-boot-nezha (Ubuntu):
assignee: nobody → Graham Inggs (ginggs)
status: New → In Progress
description: updated
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Alexandre, or anyone else affected,

Accepted u-boot-nezha into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/u-boot-nezha/2022.04+git20220405.7446a472-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-jammy to verification-done-jammy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-jammy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in u-boot-nezha (Ubuntu Jammy):
status: New → Fix Committed
tags: added: verification-needed verification-needed-jammy
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

This is fine. Normally for new upstream releases we'd like a bit more testing, but since we don't yet officially support the Nezha, I think this is fine. I'm sure you'd react instantly if you saw something not working anymore.

Revision history for this message
Alexandre Ghiti (alexghiti) wrote :

I have just tested the package in -proposed, the package wrote itself into the right partition and the board rebooted fine.

ubuntu@ubuntu:~$ sudo dpkg -i u-boot-nezha_2022.04+git20220405.7446a472-0ubuntu0.1_all.deb
Preparing to unpack u-boot-nezha_2022.04+git20220405.7446a472-0ubuntu0.1_all.deb ...
Unpacking u-boot-nezha (2022.04+git20220405.7446a472-0ubuntu0.1) over (2022.04+git20220405.7446a472-0ubuntu1) ...
Setting up u-boot-nezha (2022.04+git20220405.7446a472-0ubuntu0.1) ...
1964+0 records in
1964+0 records out
1005568 bytes (1.0 MB, 982 KiB) copied, 0.385617 s, 2.6 MB/s

tags: added: verification-done verification-done-jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package u-boot-nezha - 2022.04+git20220405.7446a472-0ubuntu0.1

---------------
u-boot-nezha (2022.04+git20220405.7446a472-0ubuntu0.1) jammy; urgency=medium

  * No-change backport to jammy to detect RAM size automatically
    and other fixes (LP: #1976594)

u-boot-nezha (2022.04+git20220405.7446a472-0ubuntu1) kinetic; urgency=medium

  * Bump version to 2022.04
  * d/rules:
    + Add 'Built-Using' field for openSBI
  * d/postinst:
    + Fix model string 'NeZha' -> 'Nezha'
  * d/patches:
    + Remove now useless patches
    + Add patch that disables the watchdog as it results in a boot failure
    + Add patch that uses arm64 loading addresses as we will limit Ubuntu
      to devices with at least 1GB of RAM
    + Add patch that fixup kernel dtb with the memory node added by boot0

 -- Alexandre Ghiti <email address hidden> Thu, 16 Jun 2022 10:37:21 +0000

Changed in u-boot-nezha (Ubuntu Jammy):
status: Fix Committed → Fix Released
Changed in u-boot-nezha (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers