Latest version of u-boot for omap fails to load boot.scr

Bug #806107 reported by Tobin Davis on 2011-07-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
u-boot-linaro (Ubuntu)
High
John Rigby

Bug Description

The default bootcmd for u-boot on omap no longer loads boot.scr from mmc. This breaks all ubuntu images for omap.

Old u-boot:
bootcmd=if mmc rescan ${mmcdev}; then if run loadbootscript; then run bootscript; else if run loaduimage; then run mmcboot; else run nandboot; fi; fi; else run nandboot; fi
loadbootscript=fatload mmc ${mmcdev} ${loadaddr} boot.scr

New environment:
bootcmd=if mmc rescan ${mmcdev}; then echo SD/MMC found on device ${mmcdev};if run loadbootenv; then run importbootenv;fi;if test -n $uenvcmd; then echo Running uenvcmd ...;run uenvcmd;fi;if run loaduimage; then run mmcboot;fi;fi;run nandboot;
loadbootenv=fatload mmc ${mmcdev} ${loadaddr} uEnv.txt

This breaks for images that still rely on boot.scr (all of ubuntu images for example).

Version: u-boot-linaro-omap3-beagle 2011.06.1-0ubuntu1

Ricardo Salveti (rsalveti) wrote :

This is fixed already upstream, now just need John to update the package.

Upstream: http://git.linaro.org/gitweb?p=boot/u-boot-linaro-stable.git;a=summary

Changed in u-boot-linaro (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → John Rigby (jcrigby)
tags: added: iso-testing
John Rigby (jcrigby) wrote :

First fixed in version 2011.06.3 and remains fixed in .4 and .5.

Ricardo Salveti (rsalveti) wrote :

Yes, .5 was pushed 4 days ago but it's still not at the archive because it got stuck at the queue:
https://launchpad.net/ubuntu/oneiric/+queue

This happened because your src package is now generating 2 additional debs, and we need an archive admin to approve them.

Changed in u-boot-linaro (Ubuntu):
status: Confirmed → Fix Committed
Tobin Davis (gruemaster) wrote :

I haven't seen this issue in a while. Changing to fix released, unless there is a compelling reason not to.

Changed in u-boot-linaro (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers