Wget based geoip lookup ignores GNOME proxy settings

Bug #519241 reported by Pēteris Krišjānis on 2010-02-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tzsetup (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

In step 2, when ubiquity tries to lookup location of installer's IP, it creates subprocess of wget which tries to get simple answer from http://geoip.ubuntu.com/lookup. In result, installator waits very long time *if* machine is behind firewall with only access trough http proxy.

Result I got:
Waiting for very long time for wget request to time out.

Expected result:
When using a LiveCD GNOME env. it could respect GNOME proxy settings, but in installer-only mode it would be propably wise to limit waiting time for wget's answer.

ProblemType: Bug
Architecture: i386
Date: Tue Feb 9 12:55:05 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100209)
Package: ubiquity (not installed)
ProcEnviron:
 LANG=lv_LV.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: ubiquity
Uname: Linux 2.6.32-12-generic i686

Colin Watson (cjwatson) wrote :

I've filed bug 519756 separately about the default timeout, and will fix the inadvertent ignoring of GNOME's proxy configuration here.

affects: ubiquity (Ubuntu) → tzsetup (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzsetup - 1:0.26ubuntu5

---------------
tzsetup (1:0.26ubuntu5) lucid; urgency=low

  * Only set http_proxy if mirror/http/proxy is non-empty (LP: #519241).
 -- Colin Watson <email address hidden> Wed, 10 Feb 2010 11:44:53 +0000

Changed in tzsetup (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers