2010i available

Bug #572103 reported by Martin Pitt on 2010-04-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Hardy
Undecided
Martin Pitt
Jaunty
Undecided
Unassigned
Karmic
High
Martin Pitt
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: tzdata

There is a new tzdata version 2010i:

  - Morocco: Update DST rules (effective from May 2)
  - Taiwan: Update historic DST rules
  - SanLuis: Update DST rules (effective from April 11)

Martin Pitt (pitti) wrote :

Lucid already has 2010i.

Changed in tzdata (Ubuntu Lucid):
status: New → Fix Released
Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

Test case for San Luis, which decided to keep DST during winter:

Wrong result with 2010h, switches to winter time:

$ LANG= TZ=America/Argentina/San_Luis date
Fri Apr 30 03:43:32 WART 2010
$ LANG= TZ=America/Argentina/San_Luis date -d 'next week'
Fri May 7 03:43:35 WART 2010

Correct result with 2010i, keeps summer time:

$ LANG= TZ=America/Argentina/San_Luis date
Fri Apr 30 04:44:59 WARST 2010
$ LANG= TZ=America/Argentina/San_Luis date -d 'next week'
Fri May 7 04:45:02 WARST 2010

Accepted tzdata into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Changed in tzdata (Ubuntu Hardy):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Jaunty):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted langpack-locales into dapper-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Dapper):
status: New → Fix Committed
Changed in tzdata (Ubuntu Karmic):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Martin Pitt (pitti) wrote :

dapper, jaunty, karmic tested and working fine. However, there is a problem with the hardy build:

$ TZ=America/Argentina/San_Luis date
Fr 30. Apr 13:40:20 UTC 2010

$ zdump -v -c 2009,2011 America/Argentina/San_Luis
America/Argentina/San_Luis Sun Mar 8 02:59:59 2009 UTC = Sat Mar 7 23:59:59 2009 WARST isdst=1 gmtoff=-10800
America/Argentina/San_Luis Sun Mar 8 03:00:00 2009 UTC = Sat Mar 7 23:00:00 2009 WART isdst=0 gmtoff=-14400
America/Argentina/San_Luis Sun Oct 11 03:59:59 2009 UTC = Sat Oct 10 23:59:59 2009 WART isdst=0 gmtoff=-14400
America/Argentina/San_Luis Sun Oct 11 04:00:00 2009 UTC = Sun Oct 11 04:00:00 2009 UTC isdst=0 gmtoff=0

Note the last line, which ought to be

America/Argentina/San_Luis Sun Oct 11 04:00:00 2009 UTC = Sun Oct 11 01:00:00 2009 WARST isdst=1 gmtoff=-10800

Changed in tzdata (Ubuntu Hardy):
assignee: nobody → Martin Pitt (pitti)
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010i-0ubuntu0.9.10

---------------
tzdata (2010i-0ubuntu0.9.10) karmic-proposed; urgency=low

  * New upstream release 2010i: (LP: #572103)
    - Morocco: Update DST rules (effective from May 2)
    - Taiwan: Update historic DST rules
    - SanLuis: Update DST rules (effective from April 11)
 -- Martin Pitt <email address hidden> Fri, 30 Apr 2010 09:38:42 +0200

Changed in tzdata (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

dapper and karmic released to -updates.

Changed in tzdata (Ubuntu Dapper):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010i~repack-0ubuntu0.9.04

---------------
tzdata (2010i~repack-0ubuntu0.9.04) jaunty-proposed; urgency=low

  * New upstream release 2010i: (LP: #572103)
    - Morocco: Update DST rules (effective from May 2)
    - Taiwan: Update historic DST rules
    - SanLuis: Update DST rules (effective from April 11)
 -- Martin Pitt <email address hidden> Fri, 30 Apr 2010 10:02:54 +0200

Changed in tzdata (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

So on hardy the problem is not the actual tzdata .deb, but it seems zdump strikes again with open-ended summer time. This already hit us with Bangladesh a few months back, I'll investigate.

tags: added: regression-proposed verification-failed
removed: verification-needed
Martin Pitt (pitti) wrote :

I uploaded a workaround for hardy which works in the same way as the Bangladesh one from a few months ago. Now it's behaving:

$ LANG= TZ=America/Argentina/San_Luis date
Fri Apr 30 11:05:26 WARST 2010
$ LANG= TZ=America/Argentina/San_Luis date -d '1 year ago'
Thu Apr 30 10:06:20 WART 2009

$ zdump -v -c 2009,2011 America/Argentina/San_Luis
America/Argentina/San_Luis -9223372036854775808 = NULL
America/Argentina/San_Luis -9223372036854689408 = NULL
America/Argentina/San_Luis Sun Mar 8 02:59:59 2009 UTC = Sat Mar 7 23:59:59 2009 WARST isdst=1 gmtoff=-10800
America/Argentina/San_Luis Sun Mar 8 03:00:00 2009 UTC = Sat Mar 7 23:00:00 2009 WART isdst=0 gmtoff=-14400
America/Argentina/San_Luis Sun Oct 11 03:59:59 2009 UTC = Sat Oct 10 23:59:59 2009 WART isdst=0 gmtoff=-14400
America/Argentina/San_Luis Sun Oct 11 04:00:00 2009 UTC = Sun Oct 11 01:00:00 2009 WARST isdst=1 gmtoff=-10800

Changed in tzdata (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
removed: regression-proposed verification-failed
Martin Pitt (pitti) wrote :

I tested the new hardy-proposed debs, and there was no other negative feedback. Since Morocco's DST rules change today, I move the package to hardy-updates now.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010i~repack-0ubuntu0.8.04.1

---------------
tzdata (2010i~repack-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * Add warst-workaround.patch: Set an arbitrary end date to
    America/Argentina/San_Luis DST time (to Jan 1 2038), since open DST end
    dates confuse the tz compiler of our glibc. In practice this shouldn't
    matter much, given how unstable Argentina's DST rules are in the first
    place. :-) (LP: #572103)
 -- Martin Pitt <email address hidden> Fri, 30 Apr 2010 15:56:32 +0200

Changed in tzdata (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers