DST time is cancelled in Tunisia - 2010h available

Bug #550157 reported by Nizar Kerkeni on 2010-03-28
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
High
Martin Pitt
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
High
Martin Pitt

Bug Description

Binary package hint: tzdata

Since 2009 Tunisian government has decided to drop DST (see bug #347242), at first this was decided only for 2009 but now it's totally cancelled so Tunisia will stay at GMT +1 until another governmental decision.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 0d56e31ee2dc4564f4ca87a1235f5d4d
CheckboxSystem: 1ff432ae68dbf3d4a96bfd7a9ba17ef7
Date: Sun Mar 28 12:24:48 2010
DistroRelease: Ubuntu 9.10
Package: tzdata 2010e-0ubuntu0.9.10
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR.UTF-8
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: tzdata
Uname: Linux 2.6.31-20-generic x86_64

Nizar Kerkeni (nizarus) wrote :
Changed in tzdata (Ubuntu):
status: New → Confirmed
Oedipe (oedipe) wrote :

Confirmed here. This is important. Please assign this bug quickly !

madmed (medbelh) wrote :

this is very annoying. an option to activate/desactivate DST should be added to avoid these problems

Oedipe (oedipe) wrote :

24 hours later, still not assigned... and importance "undecided".... Viva Ubuntu ! Pfffffff...... :-(

Martin Pitt (pitti) wrote :

Discussed upstream at http://news.gmane.org/gmane.comp.time.tz/, 2010h will land in about a week.

Changed in tzdata (Ubuntu Lucid):
status: Confirmed → Triaged
dhiaeddine (dhiaeddine) wrote :

an option should be added to time/Date preferences to en/disable summer time

Changed in tzdata (Ubuntu Karmic):
status: New → Confirmed
dhiaeddine (dhiaeddine) wrote :

better should be an option to choose between NoSummerTime/SummerTime+1/SummerTime+2

Martin Pitt (pitti) on 2010-04-05
Changed in tzdata (Ubuntu Lucid):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

2010h changes:

   - Africa/Tunis (Tunesia): Drop DST permanently. (LP: #550157)
   - Asia/Karachi (Pakistan): Drop DST permanently.

summary: - DST time is cancelled in Tunisia
+ DST time is cancelled in Tunisia - 2010h available
Martin Pitt (pitti) wrote :

For lucid I will sync 2010h-1 from sid.

Changed in tzdata (Ubuntu Lucid):
milestone: none → ubuntu-10.04
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Test case:

Wrong result with old package:

$ LANG= TZ=Africa/Tunis date
Tue Apr 6 10:22:29 CEST 2010

$ zdump -v -c 2008,2011 Africa/Tunis
Africa/Tunis Sun Mar 30 00:59:59 2008 UTC = Sun Mar 30 01:59:59 2008 CET isdst=0 gmtoff=3600
Africa/Tunis Sun Mar 30 01:00:00 2008 UTC = Sun Mar 30 03:00:00 2008 CEST isdst=1 gmtoff=7200
Africa/Tunis Sun Oct 26 00:59:59 2008 UTC = Sun Oct 26 02:59:59 2008 CEST isdst=1 gmtoff=7200
Africa/Tunis Sun Oct 26 01:00:00 2008 UTC = Sun Oct 26 02:00:00 2008 CET isdst=0 gmtoff=3600
Africa/Tunis Sun Mar 28 00:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 CET isdst=0 gmtoff=3600
Africa/Tunis Sun Mar 28 01:00:00 2010 UTC = Sun Mar 28 03:00:00 2010 CEST isdst=1 gmtoff=7200
Africa/Tunis Sun Oct 31 00:59:59 2010 UTC = Sun Oct 31 02:59:59 2010 CEST isdst=1 gmtoff=7200
Africa/Tunis Sun Oct 31 01:00:00 2010 UTC = Sun Oct 31 02:00:00 2010 CET isdst=0 gmtoff=3600

Correct result with new package:

$ LANG= TZ=Africa/Tunis date
Tue Apr 6 09:24:00 CET 2010

$ zdump -v -c 2008,2011 Africa/Tunis
Africa/Tunis Sun Mar 30 00:59:59 2008 UTC = Sun Mar 30 01:59:59 2008 CET isdst=0 gmtoff=3600
Africa/Tunis Sun Mar 30 01:00:00 2008 UTC = Sun Mar 30 03:00:00 2008 CEST isdst=1 gmtoff=7200
Africa/Tunis Sun Oct 26 00:59:59 2008 UTC = Sun Oct 26 02:59:59 2008 CEST isdst=1 gmtoff=7200
Africa/Tunis Sun Oct 26 01:00:00 2008 UTC = Sun Oct 26 02:00:00 2008 CET isdst=0 gmtoff=3600

Nizar Kerkeni (nizarus) wrote :

@Martin : when it will be available as a package in the repositories ?

Accepted tzdata into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Karmic):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in tzdata (Ubuntu Jaunty):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Intrepid):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Hardy):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted langpack-locales into dapper-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Nizar Kerkeni [2010-04-06 8:38 -0000]:
> @Martin : when it will be available as a package in the repositories ?

Should land on archive.ubuntu.com in about 90 minutes.

Martin Pitt (pitti) on 2010-04-06
Changed in tzdata (Ubuntu Dapper):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

I updated to the *-proposed packages from archive.u.c. now, and confirm that the test in comment 10 works now (i. e. Tunis has no DST) and Asia/Karachi now also does not have DST. I also tested a few other time zones, which remain unchanged.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010h~repack-0ubuntu0.8.04

---------------
tzdata (2010h~repack-0ubuntu0.8.04) hardy-proposed; urgency=low

  * New upstream release 2010h:
    - Africa/Tunis (Tunesia): Drop DST permanently. (LP: #550157)
    - Asia/Karachi (Pakistan): Drop DST permanently.
 -- Martin Pitt <email address hidden> Tue, 06 Apr 2010 10:34:04 +0200

Changed in tzdata (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010h~repack-0ubuntu0.8.10

---------------
tzdata (2010h~repack-0ubuntu0.8.10) intrepid-proposed; urgency=low

  * New upstream release 2010h:
    - Africa/Tunis (Tunesia): Drop DST permanently. (LP: #550157)
    - Asia/Karachi (Pakistan): Drop DST permanently.
 -- Martin Pitt <email address hidden> Tue, 06 Apr 2010 10:30:29 +0200

Changed in tzdata (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010h~repack-0ubuntu0.9.04

---------------
tzdata (2010h~repack-0ubuntu0.9.04) jaunty-proposed; urgency=low

  * New upstream release 2010h:
    - Africa/Tunis (Tunesia): Drop DST permanently. (LP: #550157)
    - Asia/Karachi (Pakistan): Drop DST permanently.
 -- Martin Pitt <email address hidden> Tue, 06 Apr 2010 10:28:42 +0200

Changed in tzdata (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010h-0ubuntu0.9.10

---------------
tzdata (2010h-0ubuntu0.9.10) karmic-proposed; urgency=low

  * New upstream release 2010h:
    - Africa/Tunis (Tunesia): Drop DST permanently. (LP: #550157)
    - Asia/Karachi (Pakistan): Drop DST permanently.
 -- Martin Pitt <email address hidden> Tue, 06 Apr 2010 10:21:00 +0200

Changed in tzdata (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-04-06
Changed in tzdata (Ubuntu Dapper):
status: Fix Committed → Fix Released
madmed (medbelh) wrote :

I've just updated lucid and the time has not changed yet.

Martin Pitt (pitti) wrote :

madmed [2010-04-06 12:21 -0000]:
> I've just updated lucid and the time has not changed yet.

The lucid task is still open. Lucid is currently frozen due to beta-2
preparation. The updated packages were just provided for the stable
releases so far.

Nizar Kerkeni (nizarus) wrote :

I confirm the fix for karmic.

bahsouna (hassen-benayed) wrote :

I confirm here for karmic

dhiaeddine (dhiaeddine) wrote :

karmic fix confirm

Martin Pitt (pitti) wrote :

tzdata2010h synced from Debian into lucid

Changed in tzdata (Ubuntu Lucid):
status: Fix Committed → Fix Released
Nizar Kerkeni (nizarus) wrote :

I confirm the fix for Lucid too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers