Several timezone in Russia will moves to neighbors one since 28.03.2010

Bug #540295 reported by Guria on 2010-03-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tzdata (Debian)
Fix Released
Unknown
tzdata (Ubuntu)
Undecided
Gary Lasker
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Gary Lasker

Bug Description

Binary package hint: tzdata

Vladimir Putin has signed an orders which is concerns switching some Russian timezones to neighbor's one. For example, Europe\Samara timezone switches to Europe\Moscow.
http://www.rg.ru/2009/09/24/kemerovo-dok.html
http://www.rg.ru/2010/03/22/udmuria-shasy-dok.html
http://www.rg.ru/2010/03/22/samara-chasy-dok.html
http://www.rg.ru/2010/03/22/poyas-kamshatka-dok.html

The switch will occur on March 28, 2010. Switching to summer time will not occur in listed above regions. The Samara and Udmurtia region will have the regular time while all the rest regions of Russia will switch to summer time. Therefore, Moscow time will be equal to Samara time. In similar way switch will occur in other affected regions.

Please, provide this information upstream and for the other distributions.

Thanks Sandr1x (http://juick.com/sandr1x) for help with preparing this text.

Lorenzo De Liso (blackz) on 2010-03-17
Changed in tzdata (Ubuntu):
status: New → Confirmed
Guria (guria) on 2010-03-18
description: updated
Guria (guria) on 2010-03-24
description: updated
summary: - Europe\Samara will moves to Europe\Moscow since 28.03.2010
+ Several timezone in Russia will moves to neighbors one since 28.03.2010
Sam Stone (samstone) wrote :

new timezone files from updated Debian tzdata package. Includes Europe/Samara and Asia/Kamchatka.
Europe/Udmurtia possibly use Samara timezone, Asia/Kemerovo manually changes to Asia/Omsk ?.. (there are no tz files for Udmurtia & Kemerovo regions)

Martin Pitt (pitti) wrote :

Test case:

Old result with 2010e:

$ LANG= TZ=Europe/Samara date
Mon Mar 29 22:19:02 SAMST 2010

$ zdump -c 2009,2011 -v Europe/Samara
Europe/Samara Sat Mar 28 21:59:59 2009 UTC = Sun Mar 29 01:59:59 2009 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 28 22:00:00 2009 UTC = Sun Mar 29 03:00:00 2009 SAMST isdst=1 gmtoff=18000
Europe/Samara Sat Oct 24 21:59:59 2009 UTC = Sun Oct 25 02:59:59 2009 SAMST isdst=1 gmtoff=18000
Europe/Samara Sat Oct 24 22:00:00 2009 UTC = Sun Oct 25 02:00:00 2009 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 27 21:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 27 22:00:00 2010 UTC = Sun Mar 28 03:00:00 2010 SAMST isdst=1 gmtoff=18000
Europe/Samara Sat Oct 30 21:59:59 2010 UTC = Sun Oct 31 02:59:59 2010 SAMST isdst=1 gmtoff=18000
Europe/Samara Sat Oct 30 22:00:00 2010 UTC = Sun Oct 31 02:00:00 2010 SAMT isdst=0 gmtoff=14400

Updated and correct result with 2010g (moved one hour westwards):

$ LANG= TZ=Europe/Samara date
Mon Mar 29 21:20:48 SAMST 2010

$ zdump -c 2009,2011 -v Europe/Samara
Europe/Samara Sat Mar 28 21:59:59 2009 UTC = Sun Mar 29 01:59:59 2009 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 28 22:00:00 2009 UTC = Sun Mar 29 03:00:00 2009 SAMST isdst=1 gmtoff=18000
Europe/Samara Sat Oct 24 21:59:59 2009 UTC = Sun Oct 25 02:59:59 2009 SAMST isdst=1 gmtoff=18000
Europe/Samara Sat Oct 24 22:00:00 2009 UTC = Sun Oct 25 02:00:00 2009 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 27 21:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 27 22:00:00 2010 UTC = Sun Mar 28 02:00:00 2010 SAMST isdst=1 gmtoff=14400
Europe/Samara Sat Oct 30 22:59:59 2010 UTC = Sun Oct 31 02:59:59 2010 SAMST isdst=1 gmtoff=14400
Europe/Samara Sat Oct 30 23:00:00 2010 UTC = Sun Oct 31 02:00:00 2010 SAMT isdst=0 gmtoff=10800

Changed in tzdata (Ubuntu Lucid):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010g-0ubuntu1

---------------
tzdata (2010g-0ubuntu1) lucid; urgency=low

  * New upstream release 2010g:
    - DST rule updates: Bangladesh, Palestine, Syria, various Antarctica
      regions, Pacific/Apia.
    - Russia: Some time zones moved: Europe/Samara, Asia/Kamchatka,
      Asia/Anadyr (LP: #540295)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 19:04:07 +0200

Changed in tzdata (Ubuntu Lucid):
status: Fix Committed → Fix Released

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Changed in tzdata (Ubuntu Jaunty):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Intrepid):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Hardy):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata (Ubuntu Dapper):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into dapper-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

I successfully tested hardy to karmic updates. I need to rebuild my dapper chroot, so dapper still needs testing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010g~repack-0ubuntu0.8.04

---------------
tzdata (2010g~repack-0ubuntu0.8.04) hardy-proposed; urgency=low

  * New upstream release 2010g:
    - DST rule updates: Bangladesh, Palestine, Syria, various Antarctica
      regions, Pacific/Apia.
    - Russia: Some time zones moved: Europe/Samara, Asia/Kamchatka,
      Asia/Anadyr (LP: #540295)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 19:35:38 +0200

Changed in tzdata (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010g~repack-0ubuntu0.8.10

---------------
tzdata (2010g~repack-0ubuntu0.8.10) intrepid-proposed; urgency=low

  * New upstream release 2010g:
    - DST rule updates: Bangladesh, Palestine, Syria, various Antarctica
      regions, Pacific/Apia.
    - Russia: Some time zones moved: Europe/Samara, Asia/Kamchatka,
      Asia/Anadyr (LP: #540295)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 19:33:39 +0200

Changed in tzdata (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010g~repack-0ubuntu0.9.04

---------------
tzdata (2010g~repack-0ubuntu0.9.04) jaunty-proposed; urgency=low

  * New upstream release 2010g:
    - DST rule updates: Bangladesh, Palestine, Syria, various Antarctica
      regions, Pacific/Apia.
    - Russia: Some time zones moved: Europe/Samara, Asia/Kamchatka,
      Asia/Anadyr (LP: #540295)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 19:29:36 +0200

Changed in tzdata (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2010g-0ubuntu0.9.10

---------------
tzdata (2010g-0ubuntu0.9.10) karmic-proposed; urgency=low

  * New upstream release 2010g:
    - DST rule updates: Bangladesh, Palestine, Syria, various Antarctica
      regions, Pacific/Apia.
    - Russia: Some time zones moved: Europe/Samara, Asia/Kamchatka,
      Asia/Anadyr (LP: #540295)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 19:24:40 +0200

Changed in tzdata (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I tested the dapper-proposed package as well, works fine.

tags: added: verification-done
removed: verification-needed
Changed in tzdata (Ubuntu Dapper):
status: Fix Committed → Fix Released
Guria (guria) wrote :

Just looked at timezones more precisely. Unfortunately changes are wrong. In changed tz's was set only summer time, but winter time stays unchanged. This timezones doesn't exists already in fact. Europe/Samara is now exactly equal Europe/Moscow, Asia/Kamchatka is Asia/Magadan. Follow next link for details: http://wwp.greenwichmeantime.com/time-zone/russia/time-zones/index.htm Also, please don't forget to provide this info to upstream or other distributions.

Changed in tzdata (Ubuntu):
status: Fix Released → Incomplete
Steve Langasek (vorlon) wrote :

marking this as 'triaged' - 'incomplete' implies that there is information missing from the report.

pitti, can you confirm that this needs revision, and a new upload for all distroseries?

Changed in tzdata (Ubuntu):
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

This looks real indeed. I just don't have time this week to discuss it with upstream. Guria, do you have some time to mail <email address hidden> with references to get the change upstream? You are in a much better position to answer questions about original documents.

More links for upstream project: http://www.twinsun.com/tz/tz-link.htm

Martin Pitt (pitti) on 2010-05-14
Changed in tzdata (Ubuntu):
assignee: Martin Pitt (pitti) → Gary Lasker (gary-lasker)
Changed in tzdata (Ubuntu Intrepid):
status: Fix Released → Won't Fix
Changed in tzdata (Ubuntu Jaunty):
status: Fix Released → Confirmed
Changed in tzdata (Ubuntu Hardy):
status: Fix Released → Confirmed
Changed in tzdata (Ubuntu Lucid):
status: Fix Released → Confirmed
assignee: Martin Pitt (pitti) → Gary Lasker (gary-lasker)
Changed in tzdata (Ubuntu Karmic):
status: Fix Released → Confirmed
Changed in tzdata (Ubuntu Dapper):
status: Fix Released → Confirmed
Gary Lasker (gary-lasker) wrote :

Hello Guria! I forwarded your comment #16 to the time zone mailing list at <email address hidden> and received the following response (and a second response that I will add to the next comment):

Hi !

It says: There is an official decision to use Moscow time in Samara region http://www.svobodanews.ru/content/article/1991161.html (in Russian)

But there is a petition against this decision, and they hope to undo it during the next summer->winter switch: "По мнению члена штаба "Самарское время", депутата губернской думы Михаила Матвеева, если количество подписей под петицией об отмене московского времени будет увеличиваться, то осенью у Самары есть шанс вернуть самарское время". But it's purely theoretical: usually Russian rulers don't care about the people's petitions.

According to this http://www.svobodanews.ru/archive/ru_news_zone/20100328/17/17.html?id=1995554 the Udmurtia region is now using Moscow time as well (Europe/Samara was in use in exactly two regions: Samara and Udmurtia). This link says "the amount of time zones in Russia is reduced from 11 to 9". I think you can assume, that Samara and Kamchatka zones are not existing any more.

BR

Ilya Dogolazky
Maemo Devices
Nokia

Gary Lasker (gary-lasker) wrote :

And a second response on <email address hidden>, this from Arthur David Olson:

> "Europe/Samara is now exactly equal Europe/Moscow, Asia/Kamchatka is Asia/Magadan."
Which is not to say that Europe/Samara and Asia/Kamchatka will disappear as time zones--both for the benefit of folks who have their time zone environment variables set to those values and to ensure that lookups of past times in Samara and Kamchatka yield correct results.

    --ado

Gary Lasker (gary-lasker) wrote :

So it appears, based on the above responses, that the current time zone data for these releases are correct after all (I verified Europe/Samara equals Europe/Moscow and that Asia/Kamchatka equals Asia/Magadan, and the time zones Europe/Samara and Asia/Kamchatka should remain defined based on comment #20). Based on the info in comments #19 and #20, I'll set the status back to "Fix Released".

Guria, please be sure to comment here if you don't agree, or if there's something that I've missed. Thanks very much!

Changed in tzdata (Ubuntu):
status: Triaged → Fix Released
Changed in tzdata (Ubuntu Dapper):
status: Confirmed → Fix Released
Changed in tzdata (Ubuntu Hardy):
status: Confirmed → Fix Released
Changed in tzdata (Ubuntu Jaunty):
status: Confirmed → Fix Released
Changed in tzdata (Ubuntu Karmic):
status: Confirmed → Fix Released
Changed in tzdata (Ubuntu Lucid):
status: Confirmed → Fix Released
Guria (guria) wrote :

I didn't understand: have any changes mad since my last comment? I haven't received any updates for tzdata and in my system Europe/Samara (GMT+4/GMT+4) still not equal to Europe/Moscow (GMT+3/GMT+4). The same thing for Kamchatka and Magadan's zones.

Gary Lasker (gary-lasker) wrote :

Hi Guria, thanks for reporting back. I'm investigating this further as it does appear that this problem is not yet corrected and I may have re-closed this bug prematurely. My apologies if that is the case. Be assured that we will get this resolved asap.

For reference, could you tell me the version of Ubuntu that you are running (e.g Lucid 10.4, etc)? Also, please verify the version of tzdata installed on your system using the command:

  apt-cache policy tzdata

Thanks!

Gary Lasker (gary-lasker) wrote :
Download full text (3.6 KiB)

In Lucid, I get the following results when checking the two time zone changes called out in this bug. You can see that on the Sun Mar 28 switch to DST, the times do not match between Europe/Samara vs. Europe/Moscow and Asia/Kamchatka vs. Asia/Magadan:

$ apt-cache policy tzdata
tzdata:
  Installed: 2010i-1
  Candidate: 2010i-1
  Version table:
 *** 2010i-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
$ zdump -v -c 2010,2011 Europe/Moscow
Europe/Moscow Fri Dec 13 20:45:52 1901 UTC = Fri Dec 13 23:15:52 1901 MMT isdst=0 gmtoff=9000
Europe/Moscow Sat Dec 14 20:45:52 1901 UTC = Sat Dec 14 23:15:52 1901 MMT isdst=0 gmtoff=9000
Europe/Moscow Sat Mar 27 22:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 MSK isdst=0 gmtoff=10800
Europe/Moscow Sat Mar 27 23:00:00 2010 UTC = Sun Mar 28 03:00:00 2010 MSD isdst=1 gmtoff=14400
Europe/Moscow Sat Oct 30 22:59:59 2010 UTC = Sun Oct 31 02:59:59 2010 MSD isdst=1 gmtoff=14400
Europe/Moscow Sat Oct 30 23:00:00 2010 UTC = Sun Oct 31 02:00:00 2010 MSK isdst=0 gmtoff=10800
Europe/Moscow Mon Jan 18 03:14:07 2038 UTC = Mon Jan 18 06:14:07 2038 MSK isdst=0 gmtoff=10800
Europe/Moscow Tue Jan 19 03:14:07 2038 UTC = Tue Jan 19 06:14:07 2038 MSK isdst=0 gmtoff=10800
$ zdump -v -c 2010,2011 Europe/Samara
Europe/Samara Fri Dec 13 20:45:52 1901 UTC = Sat Dec 14 00:06:28 1901 LMT isdst=0 gmtoff=12036
Europe/Samara Sat Dec 14 20:45:52 1901 UTC = Sun Dec 15 00:06:28 1901 LMT isdst=0 gmtoff=12036
Europe/Samara Sat Mar 27 21:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 SAMT isdst=0 gmtoff=14400
Europe/Samara Sat Mar 27 22:00:00 2010 UTC = Sun Mar 28 02:00:00 2010 SAMST isdst=1 gmtoff=14400
Europe/Samara Sat Oct 30 22:59:59 2010 UTC = Sun Oct 31 02:59:59 2010 SAMST isdst=1 gmtoff=14400
Europe/Samara Sat Oct 30 23:00:00 2010 UTC = Sun Oct 31 02:00:00 2010 SAMT isdst=0 gmtoff=10800
Europe/Samara Mon Jan 18 03:14:07 2038 UTC = Mon Jan 18 06:14:07 2038 SAMT isdst=0 gmtoff=10800
Europe/Samara Tue Jan 19 03:14:07 2038 UTC = Tue Jan 19 06:14:07 2038 SAMT isdst=0 gmtoff=10800

$ zdump -v -c 2010,2011 Asia/Magadan
Asia/Magadan Fri Dec 13 20:45:52 1901 UTC = Sat Dec 14 06:49:04 1901 LMT isdst=0 gmtoff=36192
Asia/Magadan Sat Dec 14 20:45:52 1901 UTC = Sun Dec 15 06:49:04 1901 LMT isdst=0 gmtoff=36192
Asia/Magadan Sat Mar 27 14:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 MAGT isdst=0 gmtoff=39600
Asia/Magadan Sat Mar 27 15:00:00 2010 UTC = Sun Mar 28 03:00:00 2010 MAGST isdst=1 gmtoff=43200
Asia/Magadan Sat Oct 30 14:59:59 2010 UTC = Sun Oct 31 02:59:59 2010 MAGST isdst=1 gmtoff=43200
Asia/Magadan Sat Oct 30 15:00:00 2010 UTC = Sun Oct 31 02:00:00 2010 MAGT isdst=0 gmtoff=39600
Asia/Magadan Mon Jan 18 03:14:07 2038 UTC = Mon Jan 18 14:14:07 2038 MAGT isdst=0 gmtoff=39600
Asia/Magadan Tue Jan 19 03:14:07 2038 UTC = Tue Jan 19 14:14:07 2038 MAGT isdst=0 gmtoff=39600
$ zdump -v -c 2010,2011 Asia/Kamchatka
Asia/Kamchatka Fri Dec 13 20:45:52 1901 UTC = Sat Dec 14 07:20:28 1901 LMT isdst=0 gmtoff=38076
Asia/Kamchatka Sat Dec 14 20:45:52 1901 UTC = Sun Dec 15 07:20:28 1901 LMT isdst=0 gmtoff=38076
Asia/Kamchatka Sat Mar 27 13:59:59 2010 UTC = Sun Mar 28 01:59:59 2010 PE...

Read more...

Changed in tzdata (Ubuntu):
status: Fix Released → Incomplete
Gary Lasker (gary-lasker) wrote :

I set this as "Incomplete" pending Gurian's response and gathering/verification of further info from upstream.

Note that there is a current pending update to tzdata (bug 582529) and if we determine that a fix is indeed needed for this bug it should be incorporated in that update.

Martin Pitt (pitti) wrote :

Please note that bug 582529 (i. e. tzdata 2010j) does not change anything wrt. Russian time zones.

I also see the discrepancy wrt. winter time:

$ TZ=Europe/Moscow date -d '3 months ago'; TZ=Europe/Samara date -d '3 months ago'
Wed Mar 3 10:41:38 MSK 2010
Wed Mar 3 11:41:38 SAMT 2010

So this needs to be re-visited and fixed upstream indeed.

Martin Pitt (pitti) wrote :

Argh, sorry. Of course the time was different 3 months ago, since the change only happened _after_ that :) So the important check is if the times match _from now on_, which they do:

$ TZ=Europe/Moscow date -d '5 months'; TZ=Europe/Samara date -d '5 months'
Sun Oct 31 10:44:13 MSK 2010
Sun Oct 31 10:44:13 SAMT 2010
0 martin@tick:~
$ TZ=Europe/Moscow date -d '12 months'; TZ=Europe/Samara date -d '12 months'
Tue May 31 11:45:06 MSD 2011
Tue May 31 11:45:06 SAMST 2011
0 martin@tick:~
$ TZ=Europe/Moscow date -d '18 months'; TZ=Europe/Samara date -d '18 months'
Thu Dec 1 10:45:14 MSK 2011
Thu Dec 1 10:45:14 SAMT 2011

Martin Pitt (pitti) wrote :

Guria, please give us the version of your tzdata package, as with

  dpkg -l tzdata

What is still different for you?

Changed in tzdata (Ubuntu):
status: Incomplete → Fix Released
Guria (guria) wrote :

Thanks for providing the way to check tzdata. Above commands works exactly same for me. It seems there is an issue in another package, but I don't know which (I assume it clock applet). See the screenshot. This is menu for selecting timezone in edit location dialog.

Martin Pitt (pitti) wrote :

Ah, indeed. Can you please open a new bug report against gnome-panel for now? Thanks!

Gary Lasker (gary-lasker) wrote :

Ah, great! Martin, thanks a lot for clarifying this! And Gurian, thanks again for your responses.

Guria (guria) wrote :

Thanks to all. I've reported bug to gnome-panel:
https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/588593

Changed in tzdata (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in tzdata (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.