2009o available

Bug #456322 reported by Martin Pitt on 2009-10-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tzdata (Debian)
Fix Released
Unknown
tzdata (Ubuntu)
High
Martin Pitt
Dapper
Undecided
Martin Pitt
Hardy
High
Martin Pitt
Intrepid
High
Martin Pitt
Jaunty
High
Martin Pitt
Karmic
High
Martin Pitt

Bug Description

Binary package hint: tzdata

2009o is available:
 - Update DST information for Pakistan (DST stops November, not October) - urgent, effective date already passed
 - Update Bangladesh DST rules from 2010 on

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

synced 2009o-1 to karmic this morning.

Changed in tzdata (Ubuntu Karmic):
status: New → Fix Released
Changed in tzdata (Ubuntu Jaunty):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: New → In Progress
Changed in tzdata (Ubuntu Dapper):
status: New → In Progress
Changed in tzdata (Ubuntu Hardy):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
Changed in tzdata (Ubuntu Intrepid):
assignee: nobody → Martin Pitt (pitti)
Changed in tzdata (Ubuntu Dapper):
assignee: nobody → Martin Pitt (pitti)
Changed in tzdata (Ubuntu Intrepid):
status: New → In Progress
Martin Pitt (pitti) wrote :

Test case:

Wrong in Jaunty (2009n):
$ TZ=Asia/Karachi date
Wed Oct 21 23:34:04 PKT 2009

Correct in Karmic (2009o):
$ TZ=Asia/Karachi date
Do 22. Okt 00:32:39 PKST 2009

description: updated
Martin Pitt (pitti) wrote :

Other test case for Bangladesh:

Wrong in Jaunty (2009n):

$ TZ=Asia/Dhaka date -d 20100401
Thu Apr 1 00:00:00 BDT 2010

Correct in Karmic (2009o):

$ LANG= TZ=Asia/Dhaka date -d 20100401
Thu Apr 1 00:00:00 BDST 2010

(Bangladesh keeping DST)

Martin Pitt (pitti) wrote :

All uploaded, waiting for SRU processing.

Martin Pitt (pitti) wrote :

For the record, I had to rename the orig.tar.gz's like tzdata_2009o+repack now, since in karmic/sid, tzdata's packaging was changed from tar-in-tar to using pristine upstream tarballs.

Martin Pitt (pitti) on 2009-10-21
Changed in tzdata (Ubuntu Dapper):
status: In Progress → Fix Committed
Changed in tzdata (Ubuntu Hardy):
status: In Progress → Fix Committed
Changed in tzdata (Ubuntu Intrepid):
status: In Progress → Fix Committed
Changed in tzdata (Ubuntu Jaunty):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted tzdata into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted tzdata into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted tzdata into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted langpack-locales into dapper-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

I tested the packages from -proposed and verified that they now have the correct DST for Bangladesh and Pakistan. They instlall/upgrade without a problem.

Promoted langpack-locales to dapper-updates.

tags: added: verification-done
removed: verification-needed
Changed in tzdata (Ubuntu Dapper):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o+repack-0ubuntu0.8.04

---------------
tzdata (2009o+repack-0ubuntu0.8.04) hardy-proposed; urgency=low

  * New upstream version 2009n: (LP: #456322)
    - Update DST information for Pakistan (DST stops November, not October)
    - Update Bangladesh DST rules from 2010 on
  * Rename orig.tar.gz and upstream version to avoid conflict with Karmic's
    orig.tar.gz which got reorganized (pristine upstream tarball instead of
    tar-in-tar; this requires build system changes, though).

 -- Martin Pitt <email address hidden> Wed, 21 Oct 2009 20:43:26 +0200

Changed in tzdata (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o+repack-0ubuntu0.8.10

---------------
tzdata (2009o+repack-0ubuntu0.8.10) intrepid-proposed; urgency=low

  * New upstream version 2009n: (LP: #456322)
    - Update DST information for Pakistan (DST stops November, not October)
    - Update Bangladesh DST rules from 2010 on
  * Rename orig.tar.gz and upstream version to avoid conflict with Karmic's
    orig.tar.gz which got reorganized (pristine upstream tarball instead of
    tar-in-tar; this requires build system changes, though).

 -- Martin Pitt <email address hidden> Wed, 21 Oct 2009 20:38:43 +0200

Changed in tzdata (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o+repack-0ubuntu0.9.04

---------------
tzdata (2009o+repack-0ubuntu0.9.04) jaunty-proposed; urgency=low

  * New upstream version 2009n: (LP: #456322)
    - Update DST information for Pakistan (DST stops November, not October)
    - Update Bangladesh DST rules from 2010 on
  * Rename orig.tar.gz and upstream version to avoid conflict with Karmic's
    orig.tar.gz which got reorganized (pristine upstream tarball instead of
    tar-in-tar; this requires build system changes, though).

 -- Martin Pitt <email address hidden> Wed, 21 Oct 2009 20:31:42 +0200

Changed in tzdata (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in tzdata (Ubuntu Intrepid):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) wrote :

Why did you change the status of this bug? The intrepid package is there just like all the others.

Changed in tzdata (Ubuntu Intrepid):
status: Fix Committed → Fix Released

The change in fact introduces a bug for Bangladesh :(. Currently because of the update it shows me UTC +6 as my timezone while it is actually UTC +7. This change actually made me miss a meeting. Can this be fixed URGENTLY?

Martin Pitt (pitti) wrote :

So, according to http://www.timeanddate.com/worldclock/city.html?n=73 it's currently 18:37 in Bangladesh (UTC+7).

I confirm that I get 18:38 with 2009n, but 17:37 with 2009o in hardy/intrepid/jaunty/karmic. Dapper is correct.

I'm pretty sure that this is due to the weird glibc bug again which ignores TZ declarations without an end date, the same problem that we already had in the original "Bangladesh introduces DST" update. So this needs a workaround again.

Changed in tzdata (Ubuntu Hardy):
status: Fix Released → In Progress
Changed in tzdata (Ubuntu Intrepid):
status: Fix Released → In Progress
Changed in tzdata (Ubuntu Jaunty):
status: Fix Released → In Progress
Changed in tzdata (Ubuntu Karmic):
status: Fix Released → In Progress
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Changed in tzdata (Ubuntu Intrepid):
importance: Undecided → High
Changed in tzdata (Ubuntu Hardy):
importance: Undecided → High
Martin Pitt (pitti) wrote :

With 2009n, zdump shows that DST was introduced for 2009 and does not continue beyond 2009, and shows UTC+6 for non-DST (21600 seconds), and UTC+7 for DST (25200 seconds):

$ zdump -v -c 2007,2015 Asia/Dhaka
Asia/Dhaka Fri Jun 19 16:59:59 2009 UTC = Fri Jun 19 22:59:59 2009 BDT isdst=0 gmtoff=21600
Asia/Dhaka Fri Jun 19 17:00:00 2009 UTC = Sat Jun 20 00:00:00 2009 BDST isdst=1 gmtoff=25200
Asia/Dhaka Thu Dec 31 16:59:59 2009 UTC = Thu Dec 31 23:59:59 2009 BDST isdst=1 gmtoff=25200
Asia/Dhaka Thu Dec 31 17:00:00 2009 UTC = Thu Dec 31 23:00:00 2009 BDT isdst=0 gmtoff=21600

With 2009o, the bug manifests so that DST is not considered at all:

$ zdump -v -c 2007,2015 Asia/Dhaka
Asia/Dhaka Fri Jun 19 16:59:59 2009 UTC = Fri Jun 19 22:59:59 2009 BDT isdst=0 gmtoff=21600
Asia/Dhaka Fri Jun 19 17:00:00 2009 UTC = Fri Jun 19 23:00:00 2009 BDST isdst=0 gmtoff=21600

Meh, sorry for the mess. Should have checked that earlier.

Martin Pitt (pitti) wrote :

OK, I uploaded a patch with a workaround, similar to bug 383444. Now it works:

$ zdump -v -c 2007,2101 Asia/Dhaka
Asia/Dhaka Fri Jun 19 16:59:59 2009 UTC = Fri Jun 19 22:59:59 2009 BDT isdst=0 gmtoff=21600
Asia/Dhaka Fri Jun 19 17:00:00 2009 UTC = Sat Jun 20 00:00:00 2009 BDST isdst=1 gmtoff=25200
Asia/Dhaka Thu Dec 31 16:59:59 2099 UTC = Thu Dec 31 23:59:59 2099 BDST isdst=1 gmtoff=25200
Asia/Dhaka Thu Dec 31 17:00:00 2099 UTC = Thu Dec 31 23:00:00 2099 BDT isdst=0 gmtoff=21600

I now set an arbitrary end date to January 1, 2100. I hope nobody plans appointments beyond that which have to be precise up to the hour. :-)

Fix uploaded to Karmic, preparing backports now.

Martin Pitt (pitti) on 2009-10-23
tags: added: regression-updates verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o-1ubuntu1

---------------
tzdata (2009o-1ubuntu1) karmic; urgency=low

  * Add bdst-workaround.diff: Work around glibc not being able to cope with
    open end dates by specifying an arbitrary one far in the future. This
    fixes time Bangladesh, which has eternal DST now. (LP: #456322)

 -- Martin Pitt <email address hidden> Fri, 23 Oct 2009 14:00:01 +0200

Changed in tzdata (Ubuntu Karmic):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Hardy/Intrepid/Jaunty updates uploaded to -proposed.

Changed in tzdata (Ubuntu Hardy):
status: In Progress → Fix Committed
Changed in tzdata (Ubuntu Jaunty):
status: In Progress → Fix Committed
Changed in tzdata (Ubuntu Intrepid):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Argh - the previous patch worked perfectly on my system (amd64), but it seems to fail on 32 bit (i386). Seems I need to move the cutoff date to 2038.

Martin Pitt (pitti) on 2009-10-23
Changed in tzdata (Ubuntu Karmic):
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

I verified the packages in -proposed, and they now all work.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o+repack-0ubuntu0.8.04.2

---------------
tzdata (2009o+repack-0ubuntu0.8.04.2) hardy-proposed; urgency=low

  * bdst-workaround.diff: Move end date to 2038, so that it works on 32 bit
    systems, too. (LP: #456322)

 -- Martin Pitt <email address hidden> Fri, 23 Oct 2009 17:37:38 +0200

Changed in tzdata (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o+repack-0ubuntu0.8.10.2

---------------
tzdata (2009o+repack-0ubuntu0.8.10.2) intrepid-proposed; urgency=low

  * bdst-workaround.diff: Move end date to 2038, so that it works on 32 bit
    systems, too. (LP: #456322)

 -- Martin Pitt <email address hidden> Fri, 23 Oct 2009 17:48:38 +0200

Changed in tzdata (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o+repack-0ubuntu0.9.04.2

---------------
tzdata (2009o+repack-0ubuntu0.9.04.2) jaunty-proposed; urgency=low

  * bdst-workaround.diff: Move end date to 2038, so that it works on 32 bit
    systems, too. (LP: #456322)

 -- Martin Pitt <email address hidden> Fri, 23 Oct 2009 17:50:27 +0200

Changed in tzdata (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2009o-1ubuntu2

---------------
tzdata (2009o-1ubuntu2) karmic; urgency=low

  * bdst-workaround.diff: Move end date to 2038, so that it works on 32 bit
    systems, too. (LP: #456322)

 -- Martin Pitt <email address hidden> Fri, 23 Oct 2009 17:52:37 +0200

Changed in tzdata (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in tzdata (Debian):
status: Unknown → New
Changed in tzdata (Debian):
status: New → Fix Committed
Arafat Rahman (opurahman) wrote :

Bangladesh keeping DST.
DST started on 19 June 2009 and ended on 31 December 2009.

From next year DST will start on 31 March 23:59 and end on 31 October 00:00.

Is it adjusted in tzdata ?

Arafat Rahman [2010-01-02 3:30 -0000]:
> Bangladesh keeping DST.
> DST started on 19 June 2009 and ended on 31 December 2009.

This is tracked in bug 502110.

Changed in tzdata (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.