Argentina changes its timezone on 30/Dec/2007

Bug #178924 reported by Alberto Bertogli on 2007-12-27
22
Affects Status Importance Assigned to Milestone
tzdata (Debian)
Fix Released
Unknown
tzdata (Ubuntu)
High
Unassigned
Dapper
High
Martin Pitt
Edgy
High
Martin Pitt
Feisty
High
Martin Pitt
Gutsy
High
Martin Pitt

Bug Description

Binary package hint: tzdata

Argentinian congress voted on 26/Dec/2007 in favour of changing the timezone from
GMT-3 to GMT-2 for the summer this year.

The timezone change will take place on 30/Dec/2007 (yeah, I know it sucks) at 0 hour,
and apparently we will go back to -3 on 16/Mar/2008 at 0 hour or 23 hour (we can't
find reliable information on this yet).

The official text will be published tomorrow morning, but the change has been
announced everywhere already, as it is part of a much publicized set of laws regarding
the energetic situation of the country.

Most sysadmins will want to do the change tomorrow because it will be the last
working day until 2/Jan/2008.

There is a patch and an ongoing dicussion to address this in Debian by patching
tzdata.

You can find the Debian bug report at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=457938

If you need any additional information, please let me know.

Thanks,
    Alberto

Andrea Colangelo (warp10) wrote :

Confirming this bug.

Changed in tzdata:
status: New → Confirmed
Changed in tzdata:
status: Unknown → New
Alberto Bertogli (albertito) wrote :

As it looks like the debian bug status will not be updated until tomorrow,
I thought I should add a comment to let you know that it is already
solved in Debian, with a minor patch to tzdata.

If you need anything else to resolve this, please let me know.

Thanks a lot,
    Alberto

Changed in tzdata:
assignee: nobody → warp10
status: Confirmed → In Progress
Andrea Colangelo (warp10) wrote :

Alberto, thank you for your comment and your help offer, it was a pretty easy one
Since we are past DIF, I prepared a debdiff to fix this sudden change. It builds and installs flawlessly.
If someone thinks this is worth a SRU, I can take care of it.

Changed in tzdata:
assignee: warp10 → nobody
status: In Progress → Confirmed

On Fri, Dec 28, 2007 at 09:27:45PM -0000, Andrea Colangelo wrote:
> Alberto, thank you for your comment and your help offer, it was a pretty easy one

Thanks to you for the quick response.

> Since we are past DIF, I prepared a debdiff to fix this sudden change. It builds and installs flawlessly.
> If someone thinks this is worth a SRU, I can take care of it.

This means this upgrade will not be in the stable releases, right?

I think it make sense to include it (after reading the guidelines in
https://wiki.ubuntu.com/StableReleaseUpdates, please let me know if
that's not the place to look for them), because it is a high-impact bug
(every user in Argentina will want their timezone updated as soon as
possible, and if this change doesn't go in everyone will have to do the
time switch manually on monday) and tzdata is listed as a special case
in that page.

Thanks a lot,
  Alberto

Martin Albisetti (beuno) wrote :

This absolutely needs to be backported to Gutsy/Feisty/Edgy/Dapper.
The work involved seems trivial, and the impact is quite high.

Andrea Colangelo (warp10) wrote :

After considering Alberto's and Martin's comments, and following guidlines for SRUs, I have nominated this bug for Gutsy, Feisty, Edgy and Dapper. ubuntu-sru team has been subscribed, I'll wait for approval from it to go ahead with the procedure.
Regression potential for the debdiff provided is very low, since it just modify the timezone according to the patch published on Debian BTS.

Changed in tzdata:
status: New → Fix Released
Changed in tzdata:
importance: Undecided → High
status: Confirmed → Triaged
status: Triaged → Confirmed
status: Confirmed → Triaged
Julian Cerruti (jcerruti) wrote :

Just wanted to cast another vote for adding this as an update. Also willing to help.

Martin Pitt (pitti) wrote :

This is the diff between 2007j and 2007k. This primarily concerns the Argentinia DST rule changes, plus the deprecation of Atlantic/Jan_Mayen (backward compatibility link is provided).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2007k-1ubuntu1

---------------
tzdata (2007k-1ubuntu1) hardy; urgency=low

  * New time zone data 2007k for the recent DST rule changes in Argentinia.
    (LP: #178924)
  * Resynchronise with Debian. Remaining changes:
    - debian/control: Add Replaces: to locales, where tzdata was kept in
      Dapper (must be kept until after Hardy's release).

tzdata (2007k-1) unstable; urgency=low

  * New upstream release.
    - Drop Argentina patch (fixed upstream in a different way).

 -- Martin Pitt <email address hidden> Tue, 01 Jan 2008 13:56:44 +0100

Changed in tzdata:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

 tzdata (2007k-0ubuntu0.7.10) gutsy-proposed; urgency=low
 .
   * Replace tzdata2007j.tar.gz with new version tzdata2007k:
     - Updates DST rules for Argentina. (LP: #178924)

Changed in tzdata:
assignee: nobody → pitti
importance: Undecided → High
status: New → Fix Committed
Martin Pitt (pitti) wrote :

 tzdata (2007k-0ubuntu0.6.10) edgy-proposed; urgency=low
 .
   * Replace tzdata2007j.tar.gz with new version tzdata2007k:
     - Updates DST rules for Argentina. (LP: #178924)

Changed in tzdata:
assignee: nobody → pitti
importance: Undecided → High
status: New → Fix Committed
Martin Pitt (pitti) wrote :

 tzdata (2007k-0ubuntu0.7.04) feisty-proposed; urgency=low
 .
   * Replace tzdata2007j.tar.gz with new version tzdata2007k:
     - Updates DST rules for Argentina. (LP: #178924)

Changed in tzdata:
assignee: nobody → pitti
importance: Undecided → High
status: New → Fix Committed
Martin Pitt (pitti) wrote :

 langpack-locales (2.3.18.8) dapper-proposed; urgency=low
 .
   * Replace debian/tzdata2007j.tar.gz with new version tzdata2007k:
     - Update DST rules for Argentina. (LP: #178924)

Changed in tzdata:
assignee: nobody → pitti
importance: Undecided → High
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Please test the new version in proposed and verify that it has the correct time now. As soon as this is done, I'll move them to -updates, waiving the usual 7-day aging period.

Tested all Argentina's timezones at Feisty and its working fine (both Dic-30th-2007 and March-16th-2008 updates). Thanks!

Martin Pitt (pitti) wrote :

Thanks for testing. All copied to -updates.

Changed in tzdata:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
sancheztavo (sancheztavo) wrote :

Works great! thanks

Julian Cerruti (jcerruti) wrote :

Seems to work great on Feisty and Gutsy. The three machines I updated went perfectly smooth

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.