Gutsy Installer, "Kolkata" is shown as "Calcutta"

Bug #155042 reported by Raghu Nayak on 2007-10-20
2
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
Undecided
Martin Pitt

Bug Description

This is a minor bug.

In Gutsy installer, during the select time zone step, If you select Indian time zone, you will see the city name as "Calcutta".

However this is the old name of the city, since then the name of the city has been changed, and the current name of city is "Kolkata"

for more info visit http://en.wikipedia.org/wiki/Kolkata

Please fix this bug for Hardy installer.

Nanley Chery (nanoman) on 2007-10-20
Changed in ubiquity:
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This comes straight from the tzdata package. Please report this to tzdata upstream (<email address hidden>) to have the timezone name changed.

Raghu Nayak (openguru) wrote :

I asked this question in that mailing list and here is their answer..

Display names for time zones should come from localization resources
(such as CLDR) and only fall back to the time zone ID if there is no
display name available for it. In other words, for a UI it should not
matter whether the internal ID uses the old or the new spelling.

markus

On Tue, Mar 18, 2008 at 9:47 AM, Olson, Arthur David (NIH/NCI) [E]
<email address hidden> wrote:
> Here is the original bug report.
> https://bugs.launchpad.net/ubuntu/+source/tzdata/+bug/155042
> >In Gutsy installer, during the select time zone step, If you select
> Indian time zone, you will see the city name as "Calcutta".
> >However this is the old name of the city, since then the name of the
> city has been changed, and the current name of city is "Kolkata"
> >for more info visit http://en.wikipedia.org/wiki/Kolkata
> >Please fix this bug for Hardy installer.
> Please change the city name accordingly.

Martin Pitt (pitti) on 2008-03-25
Changed in tzdata:
assignee: nobody → pitti
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2008b-1ubuntu1

---------------
tzdata (2008b-1ubuntu1) hardy; urgency=low

  * Update to tzdata 2008b:
    - New name of "Calcutta" is "Kolkata". (LP: #155042)
    - New name of "Saigon" is "Ho Chi Minh". (LP: #121540)
  * Resynchronise with Debian. Remaining changes:
    - debian/control: Add Replaces: to locales, where tzdata was kept in
      Dapper (must be kept until after Hardy's release).
    - Build a tzdata-java package, with the help of javazic.tar.gz.uu.

tzdata (2008b-1) unstable; urgency=low

  * New upstream release.
    - Renames Asia/Saigon to Asia/Ho_Chi_Minh. closes: #471305.
  * Add conversion code for Asia/Saigon and Asia/Calcutta to
    Asia/Ho_Chi_Minh and Asia/Kolkata respectively.

 -- Martin Pitt <email address hidden> Tue, 25 Mar 2008 12:50:36 +0100

Changed in tzdata:
status: In Progress → Fix Released
Raghu Nayak (openguru) wrote :

Hi,

Thanks for fixing this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers