Brazilian DST date change needs upgrade to 2007h

Bug #152113 reported by Cesar Eduardo Barros on 2007-10-12
38
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
High
Martin Pitt
Dapper
High
Martin Pitt
Edgy
High
Martin Pitt
Feisty
High
Martin Pitt
Gutsy
High
Martin Pitt

Bug Description

Binary package hint: tzdata

The summer time dates for Brazil changed again (as it does almost every year). Upstream already has the needed changes on version 2007h.

References: http://article.gmane.org/gmane.comp.time.tz/1876 and http://article.gmane.org/gmane.comp.time.tz/1878

Nick Moffitt (nick-moffitt) wrote :

I can confirm seeing this. It seems that the information was inserted incompletely:

$ TZ=America/Rio_de_Janeiro date
Mon Oct 15 09:29:34 BRT 2007
$ TZ=America/Sao_Paulo date
Mon Oct 15 10:29:41 BRST 2007

My feisty system currently has tzdata version 2007f-0ubuntu0.7.4

Nick Moffitt (nick-moffitt) wrote :

On gutsy, with tzdata 2007f-3ubuntu1 I see the following:

$ TZ=America/Rio_de_Janeiro date
Mon Oct 15 12:58:45 UTC 2007
$ TZ=America/Sao_Paulo date
Mon Oct 15 09:58:47 BRT 2007

Martin Pitt (pitti) on 2007-10-15
Changed in tzdata:
assignee: nobody → pitti
importance: Undecided → High
status: New → In Progress
assignee: nobody → pitti
importance: Undecided → High
status: New → In Progress
assignee: nobody → pitti
status: New → In Progress
assignee: nobody → pitti
importance: Undecided → High
status: New → In Progress
importance: Undecided → High
Martin Pitt (pitti) wrote :

I inspected the diff between 2007f and 2007h, effective diff attached. This

 * fixes a lot of DST rules which are very important and unproblematic for upgrades
 * fixes the coordinates of some cities, which is unproblematic for upgrades, too
 * adds a new timezone America/Indiana/Tell_City, which does not affect upgrades.

No TZ removals or merges.

Thus taking the entire 2007h tarball is fine for an SRU.

Martin Pitt (pitti) wrote :

langpack-locales for dapper and tzdata for edgy and feisty uploaded to and accepted in -proposed now. Please test and give feedback if it has correct values now.

Gutsy will follow soon, I want to debug and fix bug 116193 for it, too.

Changed in tzdata:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

The Gutsy change has been uploaded to the queue, but we have to wait until the Gutsy release to accept it.

Changed in tzdata:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Binaries are available in -proposed now.

Michael Vogt (mvo) wrote :

feisty-proposed is done
edgy-proposed is done
dapper-proposed is done

I verified that zdump -v America/Indiana/Tell_City gives different outputs before and after the update.

Albert Damen (albrt) wrote :

I have got confirmation from https://answers.launchpad.net/ubuntu/+question/15207 that the -proposed package solves the DST issue for Brazil.

paozinho (paonoforno) wrote :

This "bug" f*** my life and my evolution appoitments. Because I installed the package tz-brasil and it delete almost all my appointments, some appoitments have been add by two hours. =\

paozinho (paonoforno) wrote :

Maybe a bug in evolution or tz-brasil....in attachment a Snapshot.

Martin Pitt (pitti) wrote :

Dapper/Edgy/Feisty copied to -updates.

Changed in tzdata:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I removed verification-done again since gutsy SRU needs to be done independently.

Changed in tzdata:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, binaries should be available in ~ 20 minutes.

Changed in tzdata:
status: In Progress → Fix Committed
Michael Vogt (mvo) wrote :

I just verfied gutsy, and it works fine (same test as dapper,feisty,edgy).

Martin Pitt (pitti) wrote :

Package copied to gutsy-updates.

Changed in tzdata:
status: Fix Committed → Fix Released
paozinho (paonoforno) wrote :

Ok...tzdata already appear here in update manager in Gutsy.

Changed in tzdata:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
paozinho (paonoforno) wrote :

I change the status to Fixed.

Marco A L Barbosa (malbarbo) wrote :

How this bug is related with this one https://bugs.launchpad.net/ubuntu/+source/tz-brasil/+bug/138652?

Why the package tz-brasil is necessary? The package tzdata is not enough?
If not, how the brazilian users will now that they have to install tz-brasil to keep
their time correct? Should the tz-brasil package be installed by default (like broffice.org)
when locale is pt_BR?

paozinho (paonoforno) wrote :

I Think no Marco...because some Brazilians like me use the Locale in another language. I use my Ubuntu in English, and I also learn Japanese and German. But its a good idea if the location is in Brazil....do you agree ?

Here in Brazil the president (with National Eletric System Operator orientation) sets the start and end date of DST every year. If someone tells me how I can maintain this information.

Marco A L Barbosa (malbarbo) wrote :

paozinho,

you are right, I agree with you. It's not the locate, but the location that matters. Thanks.

Martin Pitt (pitti) wrote :

This is not yet fixed in Hardy, reopening task.

Changed in tzdata:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :
Download full text (3.6 KiB)

tzdata (2007h-2ubuntu1) hardy; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/control: Add Replaces: to locales, where tzdata was kept in
      Dapper (must be kept until the next LTS release).
  * Provides 2007 data for Hardy (LP: #152113)

tzdata (2007h-2) unstable; urgency=low

  * debian/po/ca.po update from Jordà Polo. closes: #446397.
  * debian/po/ja.po: update from Kenshi Muto. closes: #446564.

tzdata (2007h-1) unstable; urgency=low

  * New upstream version.
    - Includes Venezuelan time zone change. closes: #443202.
  * debian/po/ru.po: update from Yuri Kozlov. closes: #444040.

tzdata (2007g-2) unstable; urgency=low

  * debian/po/fr.po: update from Christian Perrier. closes: #439883.
  * debian/po/es.po: update from Rudy Godoy Guillén. closes: #440595.

tzdata (2007g-1) unstable; urgency=low

  * New upstream version.

tzdata (2007f-12) unstable; urgency=high

  * debian/preinst: remove.
  * debian/config: don't try to detect modified /etc/localtime file.
    closes: #438449.

tzdata (2007f-11) unstable; urgency=high

  * Urgency set to high as it fixes an RC bug.
  * debian/configure: remove comparison of /etc/localtime
    with /usr/share/zoneinfo/. closes: #438191.
    rework the rest of the script.
  * debian/preinst: new script to compare /etc/localtime
    with /usr/share/zoneinfo/.
  * debian/postinst: don't touch anything if /etc/timezone
    if not there.
  * debian/rules: Remove the Canada area, all cities are
    already in America.

tzdata (2007f-10) unstable; urgency=low

  * New Catalan debconf translation from Jordà Polo. closes: #431972.
  * debian/postinst: only print "Run 'dpkg-reconfigure tzdata' if you wish
    to change it." message when not using dpkg-reconfigure. closes:
    #428083.

tzdata (2007f-9) unstable; urgency=low

  * debian/po/wo.po: update from M Mamoune Mbacke. closes: #427504.
  * debian/config: patch form Ingo Saitz to fix handling of
    cases where /etc/localtime is missing. closes: #427584.
  * debian/po/vi.po: update from Clytie Siddall.
  * debian/po/fr.po: update from Christian Perrier. closes: #427733.
  * New Spanish debconf translation from Rudy Godoy Guillén.
    closes: #429414.

tzdata (2007f-8) unstable; urgency=high

  * debian/config: reverse the division of area/zone given the hack
    for the 3-level zones in America/ . closes: #427389.

tzdata (2007f-7) unstable; urgency=medium

  * debian/po/fr.po: update from Christian Perrier.
    closes: #427305.
  * debian/config: strip off any leading right/ or posix/ ;
    this allows tzdata to install when such a zone is set, but
    makes it more difficult for the user to set a "right"
    time zone. closes: #427226.

tzdata (2007f-6) unstable; urgency=low

  * debian/po/en.po: a few minor cleanups.
  * Remove Asmera as a debconf choice.
  * Convert Antarctica/South_Pole to Antarctica/McMurdo.

tzdata (2007f-5) unstable; urgency=medium

  * Handle three-level timezones (including Argentina) in debconf
    selection, as well as converting Argentine compatibility zones
    to their three-level counterparts. closes: #426914.
  * debian/po/en.po: updates for "new" zones.

tzdata (2007f-4)...

Read more...

Changed in tzdata:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers